Sad day in SB land
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
Like Tree13Likes

Thread: Sad day in SB land

  1. #1
    Super Member boborone's Avatar
    Join Date
    Nov 2013
    Location
    Plano, Tx
    Posts
    590

    Default Sad day in SB land

    Not sure what's happened. But it doesn't work anymore. Guess it's lived a good life. Long hard life being a workhorse of the bunch. It's getting voltage to the center pin but no matter what atty I hook up, there is no connection. Very puzzling to me. I've even tried shimming it and using a 510 to 510 and 510 to eGo adapter. I'm at a loss.

    Anybody have any ideas? Has this happened to you and you figured out what the problem is?

    TIA
    Dustin
    Purplepeeps likes this.
    Quote Originally Posted by rico942 View Post
    I would much rather continue my enjoyment of nicotine in a benign manner, than risk turning into a self-righteous nuisance with an unfulfilled craving ...

  2. #2
    PV Master Verified Member
    ECF Veteran
    Supporting Member
    oplholik's Avatar
    Join Date
    Mar 2011
    Location
    San Bernardino area, So. Cal.
    Posts
    4,523

    Default

    I think I'm having the same problem on my BB. Seems the center pin is getting pushed down and I have to pry it up along with prying out the pin in the carto. I'm having to repeat this fairly often.

    I just had the switch replaced a few weeks ago and it was working good till now, and now I'm back to fiddling with it to make it work.
    Last edited by oplholik; 03-18-2014 at 12:54 PM.
    Quit Date: 03/2011
    Look, read, and listen. Vape safe!

  3. #3
    ECF Guru ECF Veteran Baditude's Avatar
    Join Date
    Apr 2012
    Location
    Cincinnati, Ohio
    Posts
    18,930
    Blog Entries
    18

    Default

    Probably a center pin issue. Use a mini flathead screwdriver to "tease" the pin up enough to make electrical contact with your juice attachment's connector.


  4. #4
    Supplier Associate ECF Veteran
    Supporting Member
    rocks82's Avatar
    Join Date
    Oct 2009
    Location
    Columbus
    Posts
    1,093

    Default

    What type of atomizer are you using on it? any adapters? Wondering if there's a post issue. Adapters have a tendency to crush insulators sometimes... but there are a few designs out there with long posts that can push stuff in. Def email us about it though. [email protected]


    Wife of Halopunker

  5. #5
    Super Member boborone's Avatar
    Join Date
    Nov 2013
    Location
    Plano, Tx
    Posts
    590

    Default

    Quote Originally Posted by Baditude View Post
    Probably a center pin issue. Use a mini flathead screwdriver to "tease" the pin up enough to make electrical contact with your juice attachment's connector.

    I've tried that. It seems pretty squishy. Like maybe it's broken. But if was broken it wouldn't have voltage to it O.o idk
    Baditude likes this.
    Quote Originally Posted by rico942 View Post
    I would much rather continue my enjoyment of nicotine in a benign manner, than risk turning into a self-righteous nuisance with an unfulfilled craving ...

  6. #6
    Super Member Verified Member
    ECF Veteran
    Mattnatti's Avatar
    Join Date
    Jul 2013
    Location
    Cincinnati, Ohio
    Posts
    750

    Default

    Quote Originally Posted by boborone View Post
    Guess it's lived a good life.
    TIA
    Dustin

    It's not finished yet!
    At least if you don't want it to be.
    Protovapor XPV DNA20 x3, XPV DNA30x1
    Silver Bullet x8
    Fazedboxmods budget DNA20


  7. #7
    PV Master Verified Member
    ECF Veteran
    aikanae1's Avatar
    Join Date
    Feb 2013
    Location
    az
    Posts
    5,199

    Default

    Ah-ha! Thx for the vid. I'll have to give it a try.
    Baditude likes this.
    "Don't blink."

  8. #8
    Super Member boborone's Avatar
    Join Date
    Nov 2013
    Location
    Plano, Tx
    Posts
    590

    Default

    Quote Originally Posted by Baditude View Post
    Probably a center pin issue. Use a mini flathead screwdriver to "tease" the pin up enough to make electrical contact with your juice attachment's connector.

    I finally got it. Ended up it was going down with every atomizer I put on it. Like the rubber insulator is bad or something. I put a bit of cotton under the pin to keep it up, works just fine now. Is there anything this beast can't withstand? I bet there are more people still using their SBs than any other mod. Maybe the reo, but that's it. I can't think of another mod that has had it's staying power.
    Baditude likes this.
    Quote Originally Posted by rico942 View Post
    I would much rather continue my enjoyment of nicotine in a benign manner, than risk turning into a self-righteous nuisance with an unfulfilled craving ...

  9. #9
    ECF Guru ECF Veteran Baditude's Avatar
    Join Date
    Apr 2012
    Location
    Cincinnati, Ohio
    Posts
    18,930
    Blog Entries
    18

    Default

    Mine has been going strong for nearly 2 years.

    Silver Bullet with AGA T2.jpg

    The Silver Bullet was one of the first mass-produced mods ever. It is nearly as popular today as it was when it was first put on the market. A testament to the design and the manufacturing skills of Mr. Chad.

  10. #10
    Super Member boborone's Avatar
    Join Date
    Nov 2013
    Location
    Plano, Tx
    Posts
    590

    Default

    I'm so glad it's back to working. Always been my no fuss mod. All the other guys get pushed aside when I need something that just works. Like morning. I don't want to mess around with fancy this or that. Just a SB, 2 RCR123A batteries, single coil dripper, DIY juice, and black coffee.

    boochips likes this.
    Quote Originally Posted by rico942 View Post
    I would much rather continue my enjoyment of nicotine in a benign manner, than risk turning into a self-righteous nuisance with an unfulfilled craving ...

Page 1 of 2 12 LastLast

Bookmarks