Need some help here
Results 1 to 9 of 9
Like Tree8Likes
  • 1 Post By Leatherneck
  • 1 Post By Leatherneck
  • 1 Post By Leatherneck
  • 1 Post By IronHorse
  • 1 Post By Leatherneck
  • 1 Post By Leatherneck
  • 1 Post By IronHorse
  • 1 Post By Leatherneck

Thread: Need some help here

  1. #1
    Super Member
    Join Date
    Jan 2013
    Location
    Oregon
    Posts
    689

    Default Need some help here

    I've had two cartomizers crap out on me. It separates at the silver point where the mouthpiece goes in. In both cases, the thing just pops off. How can I get them back on?
    IronHorse likes this.

  2. #2
    Super Member
    Join Date
    Jan 2013
    Location
    Oregon
    Posts
    689

    Default

    I figured out a work-around. I jammed a driptip into the end where it popped off. I couldn't figure out why it popped off the first time. Second time, it popped off in my mouth, which was a bit disconcerting.

    So...note to self...driptips.
    IronHorse likes this.

  3. #3
    Registered Supplier ECF Veteran IronHorse's Avatar
    Join Date
    Mar 2012
    Location
    Oregon
    Posts
    12,084

    Default

    Leather...sorry for my delayed response...Internet isn't as it should be here as I am temporarily using Satellite Internet...could you post a picture and show me where it is separating? Thank you..

  4. #4
    Super Member
    Join Date
    Jan 2013
    Location
    Oregon
    Posts
    689

    Default

    Sure. Here ya go. It's happened to two of them. Since I got two from the eGo kit I got and one a la carte, I couldn't say if there's a common thread or not, as they all look the same. The Titan I got from Apollo later seems to be working well.

    BTW. I think the coffee flavor is pure awesome, made from win and bottled in excellence.

    IronHorse likes this.

  5. #5
    Registered Supplier ECF Veteran IronHorse's Avatar
    Join Date
    Mar 2012
    Location
    Oregon
    Posts
    12,084

    Default

    That is really unusual for those to separate there...I would recommend emailing them to let them know...send them the same pic..and see about getting a replacement.
    Leatherneck likes this.

  6. #6
    Super Member
    Join Date
    Jan 2013
    Location
    Oregon
    Posts
    689

    Default

    I emailed them. We'll see.
    IronHorse likes this.

  7. #7
    Super Member
    Join Date
    Jan 2013
    Location
    Oregon
    Posts
    689

    Default

    Yah, well, so much for that. I haven't heard from them since the 29th. I've been through two people who keep asking the same questions. I've twice asked for communication and have received no response.
    IronHorse likes this.

  8. #8
    Registered Supplier ECF Veteran IronHorse's Avatar
    Join Date
    Mar 2012
    Location
    Oregon
    Posts
    12,084

    Default

    Leather...please PM me your order info...ie: name..order #, mention the defective items and the date they were ordered and I will contact them myself...any other relevant info is good too...Thank you...and I apologize for the delay..
    Quote Originally Posted by Leatherneck View Post
    Yah, well, so much for that. I haven't heard from them since the 29th. I've been through two people who keep asking the same questions. I've twice asked for communication and have received no response.
    Leatherneck likes this.

  9. #9
    Super Member
    Join Date
    Jan 2013
    Location
    Oregon
    Posts
    689

    Default

    PM sent.

    /10char
    IronHorse likes this.

Tags for this Thread