Issue with Apollo eGo 1200mah VV Battery - Need Help
Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By Aphex_Twin

Thread: Issue with Apollo eGo 1200mah VV Battery - Need Help

  1. #1
    Full Member Verified Member
    Supporting Member
    Aphex_Twin's Avatar
    Join Date
    Jun 2013
    Location
    San Antonio, Texas
    Posts
    39

    Default Issue with Apollo eGo 1200mah VV Battery - Need Help

    Also posted within the Battery Forum but hoping someone here might have insight:
    Does anyone have a recommendation on the eGo 1200mah VV battery from Apollo? I reached out to their customer service this morning but I received the unit yesterday and it wouldn't power up. I figured mailing regulations down allow them to ship charged. I charged it overnight with the pass through as stated in the instructions, but even this morning when I tried it, the second I unplugged it from the cable, it died. I thought maybe it was locked as per the operation of a number of other ego batteries. Clicked the power button 5 times within 3 seconds and nothing. I've tried it with and without the tank on it. I tried using it while plugged into the pass through, but it wont produce a charge at all. Does it sound like a DOA or does anyone else have a recommendation at this point other than request a replacement?
    IronHorse likes this.

  2. #2
    Registered Supplier ECF Veteran IronHorse's Avatar
    Join Date
    Mar 2012
    Location
    Oregon
    Posts
    12,020

    Default

    Aphex...I have replied to your PM regarding this...
    Quote Originally Posted by Aphex_Twin View Post
    Also posted within the Battery Forum but hoping someone here might have insight:
    Does anyone have a recommendation on the eGo 1200mah VV battery from Apollo? I reached out to their customer service this morning but I received the unit yesterday and it wouldn't power up. I figured mailing regulations down allow them to ship charged. I charged it overnight with the pass through as stated in the instructions, but even this morning when I tried it, the second I unplugged it from the cable, it died. I thought maybe it was locked as per the operation of a number of other ego batteries. Clicked the power button 5 times within 3 seconds and nothing. I've tried it with and without the tank on it. I tried using it while plugged into the pass through, but it wont produce a charge at all. Does it sound like a DOA or does anyone else have a recommendation at this point other than request a replacement?

  3. #3
    Registered Supplier ECF Veteran IronHorse's Avatar
    Join Date
    Mar 2012
    Location
    Oregon
    Posts
    12,020

    Default

    Quote Originally Posted by Aphex_Twin View Post
    Also posted within the Battery Forum but hoping someone here might have insight:
    Does anyone have a recommendation on the eGo 1200mah VV battery from Apollo? I reached out to their customer service this morning but I received the unit yesterday and it wouldn't power up. I figured mailing regulations down allow them to ship charged. I charged it overnight with the pass through as stated in the instructions, but even this morning when I tried it, the second I unplugged it from the cable, it died. I thought maybe it was locked as per the operation of a number of other ego batteries. Clicked the power button 5 times within 3 seconds and nothing. I've tried it with and without the tank on it. I tried using it while plugged into the pass through, but it wont produce a charge at all. Does it sound like a DOA or does anyone else have a recommendation at this point other than request a replacement?
    It sounds like it might be defective...which occasionally can happen but rarely in my experience with Apollo. Hit them up on the Live Chat Customer Service on the website and they'll get that straightened out for you. E cigs | Electronic cigarettes | Apollo Electronic cigarettes

Tags for this Thread

Bookmarks