Page 1 of 2 12 LastLast
Results 1 to 10 of 13
Like Tree1Likes

Thread: Nemesis Beauty Ring / Accent Ring Getting Hot

  1. #1
    Full Member wolfparty's Avatar
    Join Date
    Jan 2014
    Location
    Bay Area, CA
    Posts
    22

    Default Nemesis Beauty Ring / Accent Ring Getting Hot

    I recently picked up the Nemesis extended positive post from Vaperev to run the beauty ring on my Hcigar clone. However, whenever I fire the mod, the ring instantly gets hot. I tried rubbing down the threads with alcohol to clean them off but still no luck. I also tried running it on the stock post with the negative one unscrewed a bit and am still getting the hot spot, so I'm pretty sure it has something to do with the ring.

    Any ideas would be much appreciated.

    Thanks!

  2. #2
    Full Member wolfparty's Avatar
    Join Date
    Jan 2014
    Location
    Bay Area, CA
    Posts
    22

    Default

    Bump

    10char


    Sent from my iPhone using Tapatalk

  3. #3
    Super Member Topacka's Avatar
    Join Date
    Jan 2014
    Location
    Seattle
    Posts
    646

    Default

    I wish I knew...

    Stop using the beauty ring?

  4. #4
    Super Member Verified Member
    ECF Veteran

    Join Date
    Dec 2012
    Location
    New Hampshire
    Posts
    365

    Default

    Are you running a kick in it?

    I find that if I don't have things arranged JUST SO my kick is getting HOT. Hot enough to heat up the top part of my battery. It's a smoketech kick clone, and only seems to be happening when I have a relatively new battery in, but the kick has to be making PERFECTLY flat contact, which is hard to do, b/c it doesn't like to sit flat when the battery pushes on it.

    I've learned that if I want to adjust anything, I need to dissassemble the whole mod so that I can make my adjustment, then put the mod back together just so. If I baby it just right, I don't get a hot kick.

  5. #5
    Super Member Verified Member Sucker_dad's Avatar
    Join Date
    Oct 2013
    Location
    topeka, ks, USA
    Posts
    969

    Default

    I would take pictures of exactly how you have it assembled and post info such as if you are running a kick or not. Post them and maybe there might be some more help. This is the second Nemesis getting hot thread I have seen in 2 days. mine has never done that is all I can say.
    k702 likes this.

    If at any time I offend you with something I post, you better suck it up, I'm going to do it again.

  6. #6
    PV Master Verified Member
    ECF Veteran
    crxess's Avatar
    Join Date
    Sep 2012
    Location
    Williamsport Md
    Posts
    8,176
    Blog Entries
    3

    Default

    Test Bottom of mod to top cap with and without the Ring, using a good Multimeter.

    I can almost guaranty you have a Resistance issue. Ring threads not cleanly contacting Mod threads.

    Cheap possible fix - Dremel tool with brass wire brush attachment. Clean threads inside ring and on Mod.

    What atomizer coil, Wire ga. Resistance are you running?
    What type Battery are you running?
    Kicked?
    Last edited by crxess; 02-12-2014 at 12:43 AM.
    Smoke free since 08/06/12 for my loving Wife, our Children and Grand Children
    Someone has to pay the bills - lol


  7. #7
    PV Master Team ECF (folding@home)
    Verified Member
    ECF Veteran
    Supporting Member
    Ryedan's Avatar
    Join Date
    Mar 2012
    Location
    Brampton, Canada
    Posts
    6,758

    Default

    I agree with crxess, you've got resistance happening. That's the only way to create heat. You've already cleaned the threads. Make sure there isn't a burr somewhere. Tighten the beauty ring at both ends (not too much, just so it's not loose). Can't think of anything else.
    COMPLETE THE FOURTH CALL TO ACTION BY CASAA HERE AND HELP STOP THE FDA FROM REGULATING VAPING AS WE KNOW IT OUT OF EXISTENCE !
    HERE'S THE STREAMLINED VERSION OF THE CALL FOR ACTION.
    THE DEADLINE IS AUG. 8.


  8. #8
    Full Member wolfparty's Avatar
    Join Date
    Jan 2014
    Location
    Bay Area, CA
    Posts
    22

    Default

    Resurrecting this thread back from the dead. I've been caught up with work over the last few weeks and haven't had time to be on the forums.

    I am not running a kick in it, so I can rule that one out.

    I am running 26 gauge dual microcoils measuring out to 0.3ohms on an Origen dripper and have it set up as show in the picture below. I haven't compared the resistance of the mod with & without the kick yet, but will do so as soon as I get a chance to.

    I've cleaned the threads with a dremel using a nylon brush attachment. Is that abrasive enough to get rid of any potential burrs?

    photo(1).jpg

  9. #9
    Super Member Verified Member
    ECF Veteran
    IrishUpstart's Avatar
    Join Date
    Mar 2013
    Location
    River Falls, WI, USA
    Posts
    605

    Default

    0.0

    What battery are you using at .3ohm?

  10. #10
    Full Member wolfparty's Avatar
    Join Date
    Jan 2014
    Location
    Bay Area, CA
    Posts
    22

    Default

    I cycle through a couple of 18650 Sony vtc4 2100mah batteries rated at 30A


    Sent from my iPhone using Tapatalk

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks