Mech Mod Firing Problems - FastTech Copper Nemesis Won't Fire With Locking Ring Attached
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
Like Tree3Likes

Thread: Mech Mod Firing Problems - FastTech Copper Nemesis Won't Fire With Locking Ring Attached

  1. #1
    Full Member
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    130

    Default Few Problems With My New FastTech Clones - Kayfun Screw Stripped / Taifun 'O' Ring Comes Off & That Horrible Stingray Sticky Crunchy Button

    Firstly, on the positive side I have the Taifun GT cone with the private v2 which is working perfectly. Really amazing setup - so pleased with it. The black rubber 'o' ring on the bottom adjustable pin screw keeps slipping over the screw and coming loose. How exactly should this be fitted? I was having a problem with the copper nemesis not firing without taking the locking ring off but adjusting the top battery contact pin fixed this - new user error.

    The Mixed stingray also seems to be working after I screwed out the adjustable pin on my Taifun GT a bit more but the button is horrible, crunchy and sticks frequently. Not happy with this button at all. Should I sent it back or can you suggest something.

    Also my FT Kayfun - one of the screws on the build deck will not unscrew no matter what I do. It just turns and turns but doesn't go up or down so I can't trap the wire underneath. Any ideas? Send it back?

    Thanks! Hope you can help.
    Attached Images Attached Images
    Last edited by PTJH; 05-22-2014 at 12:29 AM.

  2. #2
    Ultra Member Verified Member
    ECF Veteran
    xtwosm0kesx's Avatar
    Join Date
    Jun 2010
    Location
    Face down in the gutter, USA
    Posts
    1,656

    Default

    Quote Originally Posted by PTJH View Post
    Firstly, on the positive side I have the Taifun GT cone with the private v2 which is working perfectly. Really amazing setup - so pleased with it. Other than that I seem to be having a hell of a lot of problems with the gear that has arrived.

    However I can't for the life of me get the Copper Nemesis & Mixed Stingray to fire properly. The copper nemesis will fire if I take off the locking ring so I can only think that the locking ring is bigger than it should be meaning proper contact is not made with the battery. I'm using 18650 Sony VTC5 flat tops by the way. Here's the photo in case you don't know what I mean. It's my first day with mechs so maybe I'm doing something wrong. Other than that I'm pleased with the Nemesis too.

    Copper Nemesis Locking Ring.jpg


    The Mixed stingray also seems to be working after I screwed out the adjustable pin on my Taifun GT a bit more but the button is horrible, crunchy and sticks frequently. Not happy with this button at all. Should I sent it back or can you suggest something.

    Also my FT Kayfun - one of the screws on the build deck will not unscrew no matter what I do. It just turns and turns but doesn't go up or down so I can't trap the wire underneath. Any ideas? Send it back?

    Thanks! Hope you can help.
    Are you using the tiny, very thin, beauty ring (smallest sleeve piece) on the mod? If so remove it and you should have a proper switch throw.

    Regarding the kayfun, turn it upside down and try to turn/remove the bad screw, usually they come with a spare screw, try that one, if not or it doesnt work, open a ticket with FT. They have a place to return/ship to in the US.

    For the stingray, completely disassemble the button and thoroughly clean it. Its then a good idea to apply a VERY light coating of lube/grease to the contact areas ie the center button shaft, inside the threaded ring and a bit on the rice pin. BE VERY CAREFUL NOT TO LOSE THE RICE PIN WHEN YOU TAKE APART THE SWITCH!
    Quote Originally Posted by CABBA View Post
    Just who do you think you are? Stalin? Or some keyboard warrior, AVE fan boy, Power Ranger wanna be.

  3. #3
    PV Master Verified Member
    ECF Veteran
    crxess's Avatar
    Join Date
    Sep 2012
    Location
    Williamsport Md
    Posts
    8,555
    Blog Entries
    3

    Default

    Several people have had issues with various releases of the Stingray. Hunt around, there are a few SWITCH FIX threads.

    Nemesis - You are likely bottoming the switch against the Lock ring before it contacts the battery bottom(negative)
    Remove the thin Beauty(kick)Ring and it should work properly. < the 2-3mm ring not the short 18500 ring>

    Kayfun - screws are not SS on some so weak threads. Try a pair of side cutter pliers to put pressure under the screw head as you attempt to unscrew.

    If it comes out and the threads are wiped, you can check the deck with the other screw - GENTLY
    M1.6 x 3mm Stainless Screws for replacement.
    Last edited by crxess; 05-22-2014 at 12:20 AM.
    bluesbishop likes this.
    Smoke free since 08/06/12 for my loving Wife, our Children and Grand Children
    Someone has to pay the bills - lol


  4. #4
    Full Member
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    130

    Default

    I'm not sure which is the beauty ring on my nemesis - I'm not sure I have one? I fixed the problem with the copper nemesis not firing without taking the locking ring off by adjusting the top battery contact pin. Just user error then?

    Yeah I had a little read about the stingray - I did try cleaning it but doesn't seem to have made things any better. I've seen that tiny rice pin haha!

    Thanks for the tip with the kayfun. I'm surprised it arrived like that - sheer bad luck I guess. I find it odd that the screw turns but doesn't go anywhere. In the past when I've seen this sort of thing the screw just won't turn as the top of the screw won't catch the screwdriver.

  5. #5
    Ultra Member Verified Member
    ECF Veteran
    bsoplinger's Avatar
    Join Date
    Apr 2010
    Location
    Capitol District New York
    Posts
    2,877

    Default

    The Nemesis comes with the following parts:
    Lock ring
    Top cap
    Switch
    Main body. Use for 18350. Has threads for lock ring.
    18500/kick tube. Smaller extension tube. Add to main tube to use 18500 or 18350 with kick.
    18650 tube. Larger extension tube. Add to main tube to use 18650 or 18500 with kick. (Use both extension tubes to use 18650 with kick.)
    Beauty ring. Smooth like the lock ring. Only needed when the combination of 510 connector adjustment and battery size gets too long.

    When you get the mod its typically assembled in one of two ways. Switch, main tube, beauty, both extension tubes, top cap. Or switch, main tube, both extension tubes, beauty, top cap.

    Hopefully this will help you figure out where the beauty ring is.

    Stingray switch trouble. I'll second the suggestion, disassemble and thoroughly clean. Polishing the inside of the hole in the threaded part and the corresponding part of the bottom that slides up and down inside that hole with fine sandpaper can help if the switch is still crunchy after cleaning.

    Sent from my Nexus 7 using Xparent Purple Tapatalk 2

  6. #6
    Full Member
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    130

    Default

    @crxess Thanks, I took out the kayfun screw using pliers as you suggested. It must be the threading and possibly that the hole is too big. When I put the other screw into it it slides down without needing to be screwed in. Looks like the deck is no good

    The FT Russian 91% arrived today - doesn't seem to fit on anything particularly well as the connector stem is very big. Fits on my MVP2 fine but not my mods??! So far not finding it as amazing as the Taifun GT but haven't tried my own coil yet. It whistles like a ..... too. The GT just rapidly floods your mouth with smoke so you don't even need to suck on it - amazing. Hits like a champ! I can see why the original cost 100 now but I don't think many would spend that kind of money without trying it first. It's the beast! I thought my previous setup was good as the mvp2 and evod outperforms so many others. Different class. So much more like smoking. Some people say these are difficult to set up but I just put in a microcoil and cotton wick which I pushed through the slots in the chimney bit.

    Really liking the private v2 and nemesis. Not holding out much hope for the stingray despite it's beautiful looks. The nemesis with 2 magnets is so easy to press. I would install 3 so it'll stand up without firing but it's just so nice with 2.

    @bsoplinger Ah, I found it - it was screwed so tightly into the 18500 ring I wasn't using that I thought it was all one piece. So anyway that wasn't the issue. Just needed to adjust the top battery connector pin. Is that normal?
    Last edited by PTJH; 05-22-2014 at 11:05 PM.

  7. #7
    Super Member Verified Member
    Join Date
    Jan 2014
    Location
    Russell Springs, Kentucky
    Posts
    566

    Default

    I've circled the beauty ring for you on this one. I am running a kick here with not only the 18500 tube but the beauty ring and a 18650 battery. Here I'm running a black aluminium tube and kick2 with the top cap and a kayfun clone.

    IMG_1640.jpg

  8. #8
    Ultra Member Verified Member
    ECF Veteran
    bsoplinger's Avatar
    Join Date
    Apr 2010
    Location
    Capitol District New York
    Posts
    2,877

    Default

    Quote Originally Posted by PTJH View Post
    @bsoplinger Ah, I found it - it was screwed so tightly into the 18500 ring I wasn't using that I thought it was all one piece. So anyway that wasn't the issue. Just needed to adjust the top battery connector pin. Is that normal?
    Yes. In fact that's the main complaint with the Nemesis. That an adjustment is needed with every battery charge. I have a pair of the same brand batteries (I always buy my batteries in pairs) bought at the same time and I need to adjust between them. I use 2 other pairs that don't have this issue but yes you'll be adjusting often most likely. Personally I do it in seconds and have no issue with needing to adjust.

    Sent from my Nexus 7 using Xparent Purple Tapatalk 2
    PTJH likes this.

  9. #9
    Full Member
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    130

    Default

    Ah ok, thanks. Good there's nothing wrong with my nemesis then - just new to this mech mod game. I haven't been able to resolve my issues with the terrible crunchy sticky stingray button - it's terrible. I took it apart gave it a clean - didn't help. Applied vaseline - didn't help. Sanded down and reapplied - didn't help. Rice pin is the only thing left to try if i can find a small enough nail or something.

    Have since lost the rubber o ring and spring for the connection pin of my taifun gt but doesn't seem to matter. Only occasional tiny leakage. Anyone know where I can get taifun spares (preferably in the UK). Can't say enough about the taifun gt clone and private v2. Might get the M16!

  10. #10
    Ultra Member Verified Member
    ECF Veteran
    bsoplinger's Avatar
    Join Date
    Apr 2010
    Location
    Capitol District New York
    Posts
    2,877

    Default

    Try to find a replacement for the rice pin that's as big as possible. That'll help stabilize the movement of the switch and help with the crunchy-ness. Suggestion: get a brass finishing nail that's just a bit too large, chuck it on a drill or Dremel and file it down to a working size.

    Sent from my Nexus 7 using Xparent Purple Tapatalk 2

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks