Copper Nemesis clone won't fire!!
Results 1 to 3 of 3

Thread: Copper Nemesis clone won't fire!!

  1. #1
    Full Member
    Join Date
    Mar 2014
    Location
    Binghamton Ny
    Posts
    82

    Default Copper Nemesis clone won't fire!!

    Hello everyone,

    I just received a copper nemesis clone in the mail from Fasttech and it will not fire. I have tried everything that I know of, I've tried adjusting the top contact, the bottom contact, flat top batteries and button top. I am using in 18650 mode. I have been Vaping for awhile now so I'm pretty good with troubleshooting my mods and nothing I do works so any help at all would be greatly appreciated.

  2. #2
    ECF Guru Verified Member
    ECF Veteran
    tmcase's Avatar
    Join Date
    Apr 2011
    Location
    Rave's neighbor!
    Posts
    18,152

    Default

    First if you haven't already swapped out the spring(s) in the switch for magnets, I would do that. Second, there is a beauty ring, very thin under the top cap. Remove that. It's useless and probably preventing your battery from making contact.

    Life is short, bend the rules, forgive quickly, kiss slowly, love truly, laugh uncontrollably, live passionately and never forget anything that made you smile.

  3. #3
    Ultra Member Verified Member
    ECF Veteran
    steved5600's Avatar
    Join Date
    Sep 2012
    Location
    Dallas, Texas
    Posts
    2,633
    Blog Entries
    6

    Default

    LOL what tmcase said. LOL Also if you have a VOM volt ohm meter you can see if your getting voltage to the connector on top of the nemesis. If you are then your center pins are not making a connection. Solutions if the pin is adjustable on the atomizer adjust it. If not sometimes a 510 to 510 adapter will fix that. I have one Kayfun lite that the pin is a bit to high and it will not work on some of my mods. As soon as the present wick gives up i will fix that with either a new pin or add an insulator washer to fix it.

Tags for this Thread

Bookmarks