HELP! My ego-T Battery Stopped Working!!!
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: HELP! My ego-T Battery Stopped Working!!!

  1. #1
    Full Member
    Join Date
    Feb 2011
    Location
    Toronto
    Posts
    30

    Default HELP! My ego-T Battery Stopped Working!!!

    Hello Everyone,

    I bought my ego-T about 2 weeks ago and I absolutely love it. That was until today. I was just sitting there vaping, and when I went to take another drag, no vapor came out. I looked at the led on the battery and it was flashing (about 10-15 times). After it stopped flashing, it wouldn't turn on any more. So I thought the battery might have been dead, so I went to recharge it, but the charger lights up "green" and is reading it as fully charged.

    So I tried to vape it again, and nothing. It doesn't light up, charge, or vape any more. I'm a casual smoker, so I don't vape all day. Probably 1-4 times a day and I take really good care of it, so what could possibly be the problem??

    Thanks for your help everyone.

  2. #2
    PV Master ECF Veteran Rosco's Avatar
    Join Date
    Dec 2010
    Location
    KCMO:>)
    Posts
    6,928

    Default

    My guess would be the battery up and croaked.
    I always -always have more spares than I need, just for occasions like this for one. I'd put a meter on it and test it. Which is another item I would never be without. A simple $6 ebay multimeter answers a multitude of questions when that need arises.

    Good luck.


    WWW.NOTCIGS.COM You're a Pro - so vape like one with a BuzzPro.

  3. #3
    Member greeneon's Avatar
    Join Date
    Mar 2011
    Location
    Waldorf
    Posts
    9

    Default

    Don't giveup! Check it with a meter to be sure. If you don't have one, stop by your auto parts store or full service filling station or even a Radio Shack and have them test it.

  4. #4
    PV Master & Musician ECF Veteran
    Supporting Member
    DaveP's Avatar
    Join Date
    May 2010
    Location
    Central GA
    Posts
    7,970

    Default

    Try pressing the button 5 times, then put it on the charger.

  5. #5
    Full Member ECF Veteran ymgie's Avatar
    Join Date
    Jan 2011
    Location
    Utica NY
    Posts
    104

    Default

    If its what i think , you might want to try this first before you scrap it....
    This is the advice i got when i was having that problem with a riva 901

    What tends to happen is the center pin on the battery gets depressed too far, especially if using cartos or if an atty is screwed on too tight. The battery is probably fine, just that center pin needs pulling up, it looks a little like a screw head, you should be able to get a pin UNDER the head and pull it up, corner by corner. This should bring it closer to the charger center pin. This solves virtually all battery problems.

    hope it works for ya

  6. #6
    Full Member
    Join Date
    Feb 2011
    Location
    Toronto
    Posts
    30

    Default

    Thanks all for the help. Turns out the battery went into a recovery like mode, so I had to leave it charging for 8 straight hours in order for it to trigger back to operate fully. Who woulda thunk.

  7. #7
    Full Member ECF Veteran ymgie's Avatar
    Join Date
    Jan 2011
    Location
    Utica NY
    Posts
    104

    Default

    STRANGE ????????????????
    I went into recovery mode last night and slept for 9 hours before i could recharge myself

  8. #8
    Full Member
    Join Date
    Mar 2011
    Location
    Indianapolis,Indiana
    Posts
    71

    Default

    i just hadda 12 hour recover mode. yaaaawwwwwwwwnnnn

  9. #9
    Full Member
    Join Date
    Feb 2011
    Location
    Toronto
    Posts
    30

    Default

    Quote Originally Posted by ymgie View Post
    STRANGE ????????????????
    I went into recovery mode last night and slept for 9 hours before i could recharge myself
    Well yeah, I found it strange because the batteries were already fully charged and this happened out of nowhere. I barely vape, so it was definitely not because the battery was dead. Damn recovery modes!

  10. #10
    Senior Member Verified Member
    ECF Veteran
    Sgt.Taz's Avatar
    Join Date
    Sep 2010
    Location
    Chicago,IL.
    Posts
    183

    Default

    Quote Originally Posted by iwontgiveup View Post
    Well yeah, I found it strange because the batteries were already fully charged and this happened out of nowhere. I barely vape, so it was definitely not because the battery was dead. Damn recovery modes!
    Sounds like you got stuck in "OFF" mode. It happens when you click it repeatedly. putting it on the charger resets the safety switch. The click feature is new, but you might have a bad board in this one-if it does this again the circuit board might be the problem

Page 1 of 2 12 LastLast

Bookmarks