Evic charge problem
Results 1 to 7 of 7

Thread: Evic charge problem

  1. #1
    Member
    Join Date
    Jan 2013
    Location
    Italy
    Posts
    12

    Default Evic charge problem

    Sigh, I've been using my eVic for 10 days and everything has been fine. Unfortunately now I'm experiencing a problem. The battery charge level on the display once the eVic is charged does not go below 100% anymore and after some hours of use I get the " power too low" message. I also noticed that I don't get anymore the "charge completed" message when the battery reaches the fully charged state. I've tried to reset to factory settings by downloading and overwriting the code.bin file but to no avail. Someone else has been experiencing this ? Suggestions ?


    Inviato dal mio iPad con Tapatalk HD

  2. #2
    Member
    Join Date
    Jan 2013
    Location
    Misplaced
    Posts
    11

    Default

    I am also having a charging issue on my eVic. I have the 1.1 Firmware and did not upgrade anything yet. I have charged for a while at work, but had to disconnect at 93%. I used the eVic all day with no troubles. I then re-connected the included charger to let it charge up. When I went to sleep the screen said there was a 99% charge. When I woke, the screen said 93% charge. I would think that 6+ hours of charging would have completely charged the eVic, but it would appear that it lost charge during the night.

    Any advice would be much appretiated.

  3. #3
    Ultra Member Verified Member
    ECF Veteran
    MikenGA's Avatar
    Join Date
    Oct 2011
    Location
    Georgia
    Posts
    1,075

    Default

    Interesting. After charging all night, evic showed 73% charge. I disconnected, and strangely enough, the charge slowly rose to 100%. I have no idea what's going on, but it is certainly unusual.

    $2854.79 vaping supplies since 9/25/2011.

  4. #4
    Full Member jaco944's Avatar
    Join Date
    Feb 2011
    Location
    Ky
    Posts
    30

    Default

    Just a thought could your computer or evic be going to "sleep" and stopping charge?

  5. #5
    Ultra Member Verified Member
    ECF Veteran
    ImThatGuy's Avatar
    Join Date
    Sep 2012
    Location
    California
    Posts
    1,427

    Default

    Regardless of my computer going to "sleep" the usb ports still have power. I don't have any charging problems on my evic. Just wish it would last the whole week without any kind of recharge...

    And why do some evic users still have 1.1? 1.2 is a great update and should be installed.

    "The only thing necessary for evil to triumph is for good men to do nothing." --some guy

  6. #6
    Member
    Join Date
    Jan 2013
    Location
    Italy
    Posts
    12

    Default

    Bah, my eVic is completely messed up. The charge goes randomly from 0% to 100% and viceversa. I also discovered that my serial number is in the range of recalled eVics and that when I use low resistance cartomizers the device delays to activate. I asked for a replacement and the seller will send me a new control head as soon as he has them in stock.


    Inviato dal mio iPad con Tapatalk HD

  7. #7
    Senior Member ECF Veteran
    Join Date
    May 2011
    Location
    Omaha, NE
    Posts
    172

    Default

    mine is doing the same. I think the evic charges battery by looking at the voltage not by change in voltage during charge.
    it still works flawlessly just wont say the battery is fully charged. I think they should fix that in the next update.

Tags for this Thread

Bookmarks