Results 1 to 5 of 5

Thread: Pack Charging question

  1. #1
    AMP
    AMP is offline
    Full Member
    Join Date
    Sep 2011
    Location
    Neptune
    Posts
    76

    Default Pack Charging question

    I have this random problem of my blu pack not charging my spare batterie on occasion. It happens a lot when there is one batter bar (not blinking) and also at other random times. Anyone have any help or advice?

  2. #2
    Full Member Verified Member
    Join Date
    Feb 2012
    Location
    ohio
    Posts
    67

    Default

    Quote Originally Posted by AMP View Post
    I have this random problem of my blu pack not charging my spare batterie on occasion. It happens a lot when there is one batter bar (not blinking) and also at other random times. Anyone have any help or advice?
    More than likely you're pcc pack is low and needs recharging?? I notice mine won't charge my batts until I charge mine too.

  3. #3
    Super Member ECF Veteran KnotGillty's Avatar
    Join Date
    Jan 2012
    Location
    Sacramento CA
    Posts
    352

    Default

    I am using the Premium 100 pack.

    I've noticed that on occasion, the battery doesn't charge, regardless of the pack charge level. This happens most frequently immediately upon placing the dead battery into the charging port. For some reason, the battery charge feature is triggered by the opening and closing of the pack. I'm assuming this, because a full charged battery will sometimes begin charging again (red light blinking on the pack) for a few minutes after opening the pack to pull out a new flavor cartridge.

    If the red lights don't begin to flash (indicating charging of the battery) when you put a drained battery into the pack, simply wait a few minutes and then reopen the charging pack lid, and then close again. I do this until the red charging lights begin to blink.

    I'm speculating the non-charge issue has something to do with a fully discharged battery still being warm (put into charging pack immediately upon it going dead).

    Just reopen & close the pack until charging begins. Works for me . . .
    Last edited by KnotGillty; 02-19-2012 at 06:38 PM.

  4. #4
    Ultra Member ECF Veteran Bullette the Cowdog's Avatar
    Join Date
    Mar 2012
    Location
    Treasure Coast, FL
    Posts
    1,582

    Default

    My blu premium 100 pcc has a new problem. When I plug it into the wall to charge it...
    It continues to cycle the 3 blue lights for hours & days and never seems to notify that is fully charged by buzzing and stopping the cycling lights. It worked as advertised when I first got it 3 weeks ago. Do you think this is a problem? It seems to charge my cig batteries ok. & of course I unplug it from the wall before I go to sleep. I'm giving it plenty of time to finish charging (4 hours approx)
    Thanks in advance for your replies.

  5. #5
    Moved On ECF Veteran
    Join Date
    Aug 2011
    Location
    Kapetown
    Posts
    556

    Default

    Quote Originally Posted by AMP View Post
    I have this random problem of my blu pack not charging my spare batterie on occasion. It happens a lot when there is one batter bar (not blinking) and also at other random times. Anyone have any help or advice?
    I think ppc pack needs recharging.

Bookmarks