kanger evod bcc carto gurgling/flooding issues
Page 1 of 4 1234 LastLast
Results 1 to 10 of 31
Like Tree7Likes

Thread: kanger evod bcc carto gurgling/flooding issues

  1. #1
    Super Member ECF Veteran sarahhonald's Avatar
    Join Date
    Feb 2013
    Location
    Marietta, GA
    Posts
    757

    Default kanger evod bcc carto gurgling/flooding issues

    I have a new kanger evod bcc carto with gurgling/flooding issues....I am a noobie so I wasn't sure exactly how to try to fix the problem. I am using 50/50 vapedudes blend and it isn't a thin juice so I am not sure what caused it. I appreciate any advice!!!!

    Below is a link to the carto I am referring to:
    Kanger E-vod cartomizer/clearomizer 5pcs - Kangertech ecig shop - electronic cigarette iDrink by brother union


    Thanks,
    Sarah

  2. #2
    Member
    Join Date
    Dec 2012
    Location
    Vapeshine State
    Posts
    13

    Default

    this doesn't really help, but just to share, my kanger t3 starts leaking at the bottom when the juice is down to around .8ml. what I do is, take it off the battery wipe the connection on the battery and then blow the t3 until its clear.

  3. #3
    Super Member ECF Veteran sarahhonald's Avatar
    Join Date
    Feb 2013
    Location
    Marietta, GA
    Posts
    757

    Default

    I really appreciate it, thanks!

  4. #4
    PV Master ECF Veteran JeremyR's Avatar
    Join Date
    Dec 2012
    Location
    Oregon, IL
    Posts
    3,285
    Blog Entries
    8

    Default

    Does it flood right away? How bad is the flooding? Definitely keep it above the 1 ml mark if possible. Also if there is too much gap around the wicks it will flood, wicks too tight you'll get dry hits.

    If it just plain leaks every time you use it even when full check out this thread

    T3 leaking fixed / resolved


    Zmax v3, Flash e-vapor v2, Oddy, Rayon, 100vg, DIY, 8mg, Hangsen tobaccos. Rayon thread, VCore Thread, Zmax v3 Thread

  5. #5
    Super Member ECF Veteran sarahhonald's Avatar
    Join Date
    Feb 2013
    Location
    Marietta, GA
    Posts
    757

    Default

    Yes I flooded right away....it was leaking out the bottom and I was also getting it in my mouth...I am a noobie so excuse any redundancy...

  6. #6
    PV Master ECF Veteran JeremyR's Avatar
    Join Date
    Dec 2012
    Location
    Oregon, IL
    Posts
    3,285
    Blog Entries
    8

    Default

    Look over the thread above, if it sounds like your issue, and it does, post questions there. There is also a very fine balance of wick material for the to work well. I use 4 strands 1 millimeter silica with a notched cup seal. The passages need to be lightly filled. I made a vid of the insides if you want to see its very short.
    Easy Rewicking T3 with cotton string video


    Zmax v3, Flash e-vapor v2, Oddy, Rayon, 100vg, DIY, 8mg, Hangsen tobaccos. Rayon thread, VCore Thread, Zmax v3 Thread

  7. #7
    Senior Member ECF Veteran Haktuspit's Avatar
    Join Date
    Feb 2013
    Location
    Truckee, CA
    Posts
    247

    Default

    Anyone else been having this issue? I'm pretty new at these tanks systems, just got 2 ego twists, a Kanger EVOD, and a Vision Clearomizer 2.0 in recently. The Vision one has been working fine but I seam to be losing a lot of juice blowing out the Kanger. It gurgles very easily and I'm not sure if it's something I'm doing. Jeremy I'm not sure that your link applies since the EVOD appears to have the mouthpiece connected to the tank with no way of removing it.

  8. #8
    Senior Member ECF Veteran Moses195's Avatar
    Join Date
    Jan 2013
    Location
    New Mexico
    Posts
    186

    Default

    Sounds like you over filled it? I've been using 2 eVods for over a week and have had NO problems. I can vape them all the way down to almost nothing without a dry hit. Wash them out and dry them and fill no more than 1.5ml.

    Good Luck,

    Dana
    Harplayr likes this.

  9. #9
    Senior Member ECF Veteran Haktuspit's Avatar
    Join Date
    Feb 2013
    Location
    Truckee, CA
    Posts
    247

    Default

    That has happened but it happens at other times as well. I'm starting to get the impression these want to be at between 1.0-1.5 ml at all times as I'm having trouble when it gets below 0.8 ml as well.

  10. #10
    Super Member Verified Member
    ECF Veteran
    CloudZ's Avatar
    Join Date
    Nov 2012
    Location
    Minneapolis, MN
    Posts
    955
    Blog Entries
    1

    Default

    Is the removable atomizer head screwed tightly onto the base? Do you see the wicks protruding slightly from each side, and are there any gaps? Is the metal retaining post (which holds the silicone seal cup) pushed all the way in?
    Harplayr likes this.

Page 1 of 4 1234 LastLast

Tags for this Thread