SvoeMesto Support Thread - Page 2
Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17
Like Tree4Likes

Thread: SvoeMesto Support Thread

  1. #11
    Registered Supplier - Offline ECF Veteran
    Join Date
    Feb 2013
    Location
    DC metro
    Posts
    940

    Default

    .......and on the third day my semovar died..... Worked great, set it down for an hour picked it up and no signs of life. Changed the battery still nothing. Took it apart cleaned reassembled still nothing. Dead..... Now what?

  2. #12
    Supplier Associate ECF Veteran vapn's Avatar
    Join Date
    Jul 2009
    Location
    UK
    Posts
    3,357

    Default

    Now what? Hmm perhaps contact me via email or PM and we'll get you sorted?

  3. #13
    Registered Supplier - Offline ECF Veteran
    Join Date
    Feb 2013
    Location
    DC metro
    Posts
    940

    Default

    Awesome! On it.
    Pm sent.
    Last edited by Chowderhead1972; 07-11-2013 at 07:27 PM.

  4. #14
    Registered Supplier - Offline ECF Veteran
    Join Date
    Feb 2013
    Location
    DC metro
    Posts
    940

    Default

    Taken care of with no problems... Great job Cloud9!
    vapn likes this.

  5. #15
    Ultra Member ECF Veteran soba1's Avatar
    Join Date
    May 2013
    Location
    Van Nuys Ca., USA
    Posts
    2,246

    Default

    Can anyone direct me to english speaking customer service.
    I had a tank leak while attached.
    Then it got an E5 error and it doesnt seem to
    be working like when I first bought it.
    I did get it from the US distributor here in the US I can call them as well.
    Thought I would start here since its early in the morn thanks

  6. #16
    Ultra Member ECF Veteran soba1's Avatar
    Join Date
    May 2013
    Location
    Van Nuys Ca., USA
    Posts
    2,246

    Default

    Quote Originally Posted by soba1 View Post
    Can anyone direct me to english speaking customer service.
    I had a tank leak while attached.
    Then it got an E5 error and it doesnt seem to
    be working like when I first bought it.
    I did get it from the US distributor here in the US I can call them as well.
    Thought I would start here since its early in the morn thanks
    I figured out the problem I made sure the part on 5c was screwed all the way down, firing like a chanp

  7. #17
    Supplier Associate ECF Veteran vapn's Avatar
    Join Date
    Jul 2009
    Location
    UK
    Posts
    3,357

    Default

    Good glad you got it sorted.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks