What kind of atties do you use on your darwin?Problems here....
Page 1 of 2 12 LastLast
Results 1 to 10 of 14
Like Tree2Likes

Thread: What kind of atties do you use on your darwin?Problems here....

  1. #1
    Super Member Verified Member
    ECF Veteran
    rrayda's Avatar
    Join Date
    Nov 2010
    Location
    ND
    Posts
    309

    Question What kind of atties do you use on your darwin?Problems here....

    Hey folks, been vaping on my darwin for almost a full year now. I love the thing. I have had a few problems, but Evolv has always made them right, and fast. Problem is, I'm getting sick of blowing atties so insanely fast on this thing. It's not the Darwin (it's been checked quite thoroughly by Evolv and they can find no problems). The atty life (or lack thereof) is getting to the point where I'm about ready to try something else, mod-wise to see if this is a Darwin issue or just a hazard of high-power vaping.

    I've been going through atties at a rate of about one every two days for too long now. At first I thought it was the quality of atomizer I was using (the EM 510 SR from Liberty-Flights). These are inexpensive, so maybe that's why they weren't lasting I thought. Next I tried the Joye 510 SR atties from Vapor Kings. Joye are supposed to be the good stuff...same problem. I moved on to the HV 510 atties from Greenhouse One thinking that the higher resistance would save me...nope. I've tried 801, 901, 306, cartos....just about everything from many vendors with just about the same results. I've been able to eke maybe a week out of an atty in the past, but not lately. A week I can live with, two days, not so much.

    I vape Backwoods Brew, Alien Visions and Vapor4Life juices pretty much exclusively and direct drip right around 9.2W (this varies, obviously, but I rarely exceed this power setting). Liquid consumption is probably right around 5mL/day. I haven't cleaned an atty in ages as they're blowing before I can get to that point. Blowing, in this context, means a zero resistance reading and failure to fire on my Darwin. All atties are mounted on the sealed 510 adapter from Evolv, and my PV is really clean, no stray juice causing shorts or anything.

    So.....What have my fellow Darwin users found works for them? What are your experiences with atty life? Am I just destined to try something else (say, a ProVari) or is there something I can do to fix this? I love this PV, there's nothing out there I'd rather use, but this is getting expensive and just plain annoying. Anything you can offer will be greatly appreciated by me and my bank account.
    Dripping gallons of NETs on some manner of VW device.

  2. #2
    Ultra Member Team ECF (folding@home)
    Verified Member
    ECF Veteran
    Supporting Member
    Keeno's Avatar
    Join Date
    Dec 2011
    Location
    Indiana
    Posts
    1,084

    Default

    Great post.....I've had mine a couple weeks and it's worked as intended. Are you sure your keeping your attys wet....sounds as if they may be getting dry and blowing and that will happen pretty easily if not kept wet. I use strictly carts or a combination of cart/tank. I've gone almost exclusively tank as I get tired of constantly topping off my carts as they can get dry pretty quickly with the power we can put to them using the Darwin. Also, PG is quite a bit thinner than VG so say an 80/20 pg to vg ratio is gonna require more drops more often that a higher concentrate VG based juice.

    EDIT: Much above 8.6 or the middle setting on your dial may be the issue if your running 1.5 ohm attys as well.

    Great little guide for you below.

    https://docs.google.com/spreadsheet/...wUEJEZXc#gid=1
    Last edited by Keeno; 02-01-2012 at 11:15 PM.
    Creniker likes this.
    510-T, Ego-T, Lava Tube, Darwin x2 , Reo Grand x2 , Buzz Pro, Saber Touch VV HP, Altoids VV Tin Mod by Cage, Garry Dibley M&S VV Tin Mod, Line V2, SS GGTS w/UFS V2, Ody V2, Penelope, Proteus (#1926), iHybrid 9/11 TRIBUTE EDITION (2012), ZAtty Pro, Reo Woodvil, MCM #53




  3. #3
    Ω Destroyer Verified Member
    ECF Veteran
    Supporting Member
    Killjoy1's Avatar
    Join Date
    Aug 2011
    Location
    New Hampshire, US
    Posts
    9,272

    Default

    Wow. I really wish I had a whole bunch of good solid suggestions for you, as it doesn't sound like you're having a good time of it

    Unfortunately, the only ones I can think of are perhaps you have a problem with your adapter or you are overtightening your attys. Either one is easy to check. I'd start by removing the adapter and screwing in a new atty directly, but making sure to go just snug and not too tight, then see how long you get out of it

    I doubt it's your juice and 9.2 watts isn't really excessive and since you've tried different attys I really have no other ideas for you, sorry
    tearose50 likes this.
    Last analog: 2-23-2011

    Current Gear: Darwin, SS GGTS #882, Ωpus-D, iHy Illuminati & Pure, Precise ELA, Simplicity 350Ti, Black Copper Stingray #459

  4. #4
    PV Master Verified Member
    ECF Veteran
    Supporting Member
    tearose50's Avatar
    Join Date
    Feb 2011
    Location
    Los Angeles
    Posts
    4,893

    Default

    When I get frustrated with atty's -- I switch to carto's for a bit. Seems to magically help. I've found that once a carto "breaks in" (they all don't, even out of the same box) it's pretty sweet.

    I've had similar experiences -- but not all the time. My fixes have also been --- not dripping on overly hot atty and rotating devices.

    I'm using an Iken 2.5 ohm io6 right now on my Darwin. The io6 was the first atty I'd had in months that lasted 3 weeks---with a lot of use -- before it simply wimped out. My second, not as good. But the third is doing fine!

  5. #5
    Super Member Verified Member
    ECF Veteran
    rrayda's Avatar
    Join Date
    Nov 2010
    Location
    ND
    Posts
    309

    Default

    never mind....
    Last edited by rrayda; 02-02-2012 at 10:27 PM.
    Dripping gallons of NETs on some manner of VW device.

  6. #6
    Super Member Verified Member
    ECF Veteran
    rrayda's Avatar
    Join Date
    Nov 2010
    Location
    ND
    Posts
    309

    Default

    All:

    Thanks for the great suggestions. I've got another 510 adapter on the way, I've got months of use out of the one I'm using...sure won't hurt.

    I'll order some of the io6 from IkenVape. Their stealth cannons were my favorite until they started lasting me less than a day. Then they were still my favorite, just no longer economically feasible.
    Dripping gallons of NETs on some manner of VW device.

  7. #7
    Ultra Member Team ECF (folding@home)
    Verified Member
    ECF Veteran
    Supporting Member
    Keeno's Avatar
    Join Date
    Dec 2011
    Location
    Indiana
    Posts
    1,084

    Default

    Quote Originally Posted by rrayda View Post
    never mind....
    Open up the LEGEND tab on the bottom left of the screen and it explains it all.....
    510-T, Ego-T, Lava Tube, Darwin x2 , Reo Grand x2 , Buzz Pro, Saber Touch VV HP, Altoids VV Tin Mod by Cage, Garry Dibley M&S VV Tin Mod, Line V2, SS GGTS w/UFS V2, Ody V2, Penelope, Proteus (#1926), iHybrid 9/11 TRIBUTE EDITION (2012), ZAtty Pro, Reo Woodvil, MCM #53




  8. #8
    Super Member Verified Member
    ECF Veteran
    rrayda's Avatar
    Join Date
    Nov 2010
    Location
    ND
    Posts
    309

    Default

    Quote Originally Posted by Keeno View Post
    Open up the LEGEND tab on the bottom left of the screen and it explains it all.....
    Yeah...I actually looked closely at it after I posted and all was revealed.... Thanks for the awesome tool.
    Dripping gallons of NETs on some manner of VW device.

  9. #9
    Senior Member ECF Veteran ccbflo's Avatar
    Join Date
    Jan 2010
    Location
    Buffalo, NY
    Posts
    158

    Default

    Sorry to hear about your troubles, I've had my Darwin since early December and am only on my second atty. The first was a 3.5 i06 from ikenvape which died just before new years, but i think my adapter (510-510 sealed) screwed up the insulator. The second is a 2.5 i06 and is still going strong. I vape hard all day, everyday usually right at 8.4. The most important thing i've learned is to never drip on a hot atty. I take a couple draws with no power to cool it off, then drip and wait 10-30 seconds for the juice to soak in. I never clean em either, just blow em out once in a while. the i06 is a workhorse and I rarely get any leaks.
    Good luck with whatever you choose!

    Vapin' my IPV2, Darwin, BSB, Omega and my eroll!

  10. #10
    PV Master Verified Member
    ECF Veteran
    retird's Avatar
    Join Date
    Dec 2010
    Location
    Okie City
    Posts
    3,145

    Default

    Since I do not use atty's this will probably not help much, but offering it up anyway.....I use only Boge 2.8 thru 3.2 ohm cartomizers and at 8.4 to 8.6 watts, have never blown a single carto....when the taste starts to fail (around 4 days or so) I just fill a new one and vape....

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks