Results 1 to 4 of 4
Like Tree3Likes
  • 3 Post By spaceballsrules

Thread: EGO Twist Battery Prob Question?

  1. #1
    Full Member
    Join Date
    Mar 2012
    Location
    Westminster Maryland
    Posts
    56

    Default EGO Twist Battery Prob Question?

    First off I will say that this is my fault!! I dropped My EGO Twist with a CE5 Clero on it from about 10 feet and it hit on a concrete floor. At first I was dissapointed that I prob. broke my CE5 but low and behold my Twist was not working. When I plug it into the charger it looks at me if I am stupid and does nothing, when I put my CE5 on it, it blinks 3 times and if I hit the button it blinks about 38 times then stops. Now I have already ordered replacements thinking I know the answer to my question, but here goes. Is this Battery trash or is there some hope for it?
    Thanks in advance
    Dave

  2. #2
    Large Member Verified Member
    ECF Veteran
    Supporting Member
    spaceballsrules's Avatar
    Join Date
    Dec 2011
    Location
    Cary, NC
    Posts
    2,600

    Default

    If you are good with a soldering iron, you can fix it yourself. If you don't feel comfortable opening it up, then it is unfortuantely good for the trash.

    Here is a vid that shows the innards and demonstrates how to fix a faulty button....

    Kent C, Gloria and MiamiMom63 like this.

  3. #3
    PV Master Verified Member
    ECF Veteran
    Underwhelmed's Avatar
    Join Date
    May 2012
    Location
    Texas
    Posts
    3,472

    Default

    You could also get verified and offer it for sale as is in the classified section.

    Some modder might enjoy taking it apart and making something entirely different out of it.
    Expert textpert choking smokers
    Don't you think the joker laughs at you?
    Last cigarette 04/11/2012 Last vape 07/13/2014

  4. #4
    Full Member
    Join Date
    Dec 2011
    Location
    Essex County, New Jersey, USA
    Posts
    55

    Default

    Keep looking for more info on your problem. I came home from work (tired as hell), and put my month-old 1000 Twist on charge and started using my backup. After an hour, I saw the charger LED was green and took the Twist off of charge.

    When I put on a Boge LR cartomiser it flashed three times. When I hit the fire button it flashed at least a dozen times. After trying two other cartomisers, I put it back on charge and the green charging LED did not flicker. (I think it may not have been charging when I first put it on charge tonight)

    While looking up information online (and finding this thread) I picked up the Twist again. As I picked it up, I saw the white LED was flashing at least twice. When I hit the button to fire it, it fired. With the same carto, it vapes fine.

    When I unscrewed the carto to put on another, I again saw the three flashes. I screwed it back on, and it works. I just put it on charge again (it's not hot) and it is charging. (red LED, flickers green every 10 seconds or so)

    I have no clue what is going on with this thing. When it hits full charge I will update this post.

    On a side note, the 650 eGo-C Upgrade (with mini-USB passthrough) in unregulated power seems to vape around 4.2 at full charge. This is my backup unit and I love it for it's small size. (only an inch longer than a cartomiser with a drip tip)

Bookmarks