problem with ego v v2
Results 1 to 6 of 6

Thread: problem with ego v v2

  1. #1
    Full Member ECF Veteran Acidspring13's Avatar
    Join Date
    Mar 2013
    Location
    East Hanover, New Jersey, United States
    Posts
    98

    Default problem with ego v v2

    Im not sure where to post this issue i dont know if it is in a actual prob with the battery or the Smok CE5 i have 3 batteries a regular ego 650 an ego twist and an ego V v2 now both claramizers work on the twist one works on the 650 and neither work on the v v2 just this week this has been happening and idea what has been going on??

  2. #2
    Senior Member Verified Member
    ECF Veteran
    Supporting Member
    Mr.Bungle's Avatar
    Join Date
    Jan 2013
    Location
    Somerset, NJ
    Posts
    236

    Default

    Have you checked the center battery posts on your batteries? Sometimes they get pushed down and no longer make contact with the + post on the clearo. You can try and GENTLY lift the center post and see if that clears things up; if not, I'm not really sure what your issue could be.

    Do you have other clearos/cartos that you are having the same problems with? or just the Ce5?

  3. #3
    Super Member Verified Member
    ECF Veteran
    shynsly's Avatar
    Join Date
    Jan 2013
    Location
    Chicago
    Posts
    528

    Default

    Try taking some tweezers and pulling the center post down a little, some times if you tighten them too much they wont make contact.

  4. #4
    Full Member ECF Veteran Acidspring13's Avatar
    Join Date
    Mar 2013
    Location
    East Hanover, New Jersey, United States
    Posts
    98

    Default

    I will try that when I get home today i guess use some tweezers? i just ordered a CE4 clearo but i dont know when that is coming in im fairly new so I only have 2 for right now

  5. #5
    Full Member ECF Veteran Acidspring13's Avatar
    Join Date
    Mar 2013
    Location
    East Hanover, New Jersey, United States
    Posts
    98

    Default

    Didnt work

  6. #6
    Full Member ECF Veteran Acidspring13's Avatar
    Join Date
    Mar 2013
    Location
    East Hanover, New Jersey, United States
    Posts
    98

    Default

    I fixed it the problem was the center post but what I did was take some foam from my viva nova package very thin strip and jammed them under the pin in the ego now they all fire like champs

Bookmarks