New eVic owner, Need help please!
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Like Tree1Likes

Thread: New eVic owner, Need help please!

  1. #1
    Full Member buck naked's Avatar
    Join Date
    Nov 2013
    Location
    CA
    Posts
    30

    Default New eVic owner, Need help please!

    A little long winded sorry.
    About 3 weeks ago I ordered and eVic easy head, factory 18650 battery tube, factory 3400mAh battery and usb cable. Wanted longer battery life than my ego 1000 mAh. I also got a Pro Tank 2 to hold more juice. Basically a longer lasting eCig; but was not sure I needed/wanted VV/VW. Dealt with the no draw issue on the Pro Tank 2 by slightly enlarging the PT2 base where the bottom of the head sticks thru to connect to battery center post. All was well with my world. Got into rebuilding the heads (micro coil and cotton). Everything is working well. Decided I DID want VV/VW. Was going to get the VV/VW eVic head. Found out I could get a complete Evic kit from Vaping Craze for about what just the head would cost; pulled the trigger. Arrived today! Charged it up when it arrived. Slapped the PT2 (my rebuilt coil 1.4 ohms) on it. Started vaping fine (it worked hadn`t changed any settings FW 1.2) Messed around with it, got wattage too high burnt the cotton. Changed to a factory 1.8 head. Thread it on snug, BAM! no draw. Im back to original air draw issues with PT2! Put PT2 back on the easy head works fine, what the hell? Are the center posts at different heights? Can I lower the center pin in the VV/VW head. I Have an airflow controller from MVS, it has a floating center pin and causes the same issue no matter what battery its on. Please any suggetions are welcome.
    Shane

  2. #2
    Ultra Member Verified Member humpstyles's Avatar
    Join Date
    Dec 2013
    Location
    Pennsylvania
    Posts
    1,506

    Default

    Shane,

    I am not familiar with the easy head from Joyetech at all, but I might be able to pick at your problem.

    A well-known eVic user, crxess, helped me a little bit ago with a center pin problem. Basically I wanted to preserve my 510 threads from wearing down, as the eVic's are known to do from cranking down atties on them too tightly. I snagged a 'support cone' to use on the eGo threads and I wasn't screwing it down all the way so it sat up a few mm's above the top-cap; however, my PT2 wasn't making contact with the eVic's center pin. crxess advised me to use a paperclip, bend it into a tiny L at one end, stick between the center pin and the surrounding female 510 threads, and gently "pry" the center pin up. After 30 seconds or so, I could physically see a difference in how high the center pin sat. I screwed down the PT2 slowly with the support cone still sitting up, and it made contact (eVic display detected the atomizer). It has only done this to me twice in the past month or so which goes to show the the eVics center pin isn't wobbly and loose, but can be budged. Maybe this will solve your problem?

    P.S. Screwing down too hard will push the center pin in further, so be very gentle when using the 510 threads. I advise you as well to grab a support cone to increase the longevity of your 510 threads, as they're made out of a very soft and durable metal which will wear quickly if you don't take precaution!

    If I didn't answer you question, hopefully someone else on here with easy head experience can shoot you some info.

    hump.
    Last edited by humpstyles; 02-15-2014 at 05:59 AM. Reason: typos
    ...cooler than a polar bear's toes...





  3. #3
    Full Member buck naked's Avatar
    Join Date
    Nov 2013
    Location
    CA
    Posts
    30

    Default

    Thanks humpstyles. Any info helps. I did try to use the PT2 support ring that comes with it but the evic top cap from screwing down far enough to work; causing a similar problem to yours. I'll look into using your suggestion.
    Shane

  4. #4
    Full Member buck naked's Avatar
    Join Date
    Nov 2013
    Location
    CA
    Posts
    30

    Default

    could not edit my earlier post: It should read the evic top cap kept the Kanger support ring from screwing done far enough.
    Shane

  5. #5
    PV Master Verified Member
    ECF Veteran
    Supporting Member
    Rickajho's Avatar
    Join Date
    Apr 2011
    Location
    Boston MA
    Posts
    9,064

    Default

    This sounds like more on a PT problem than an eVic problem.

    When you get a total vacuum lock on a PT when it's put on any PV the problem is the center post insulator on the PT coil has become compressed. There is very little clearance between the coil assembly and the inner wall of the PT base 510 threaded connector that air has to flow between to get into the very bottom of the coil. If the center post insulator is the tiniest bit compressed it completely blocks off air getting down that channel.

    How do you know that's the problem? Remove the PT from the eVic and you have a normal draw since you are now sucking air directly into that center hole in positive post. Put the PT onto your eVic and the squooshed insulator stops air from getting from the air holes above the 510 threading down to that hole in the center post.

    Take a hard look at your center post insulators on your PT coils. The newer, clear-ish insulators are softer than the older white ones and are causing problems. You can try pulling the metal center post on the coil a tiny bit to uncompress the insulator. Or use something like an X-acto knife to trim away any excess insulator that you can feel is larger around that the post itself. Like I said, it takes very little of that insulator to completely block air that is supposed to be moving right past it when the coil is screwed into the PT base.

    Of course, then screwing the PT onto the eVic too tightly can recreate the problem.
    Last edited by Rickajho; 02-15-2014 at 03:20 PM.

  6. #6
    Full Member buck naked's Avatar
    Join Date
    Nov 2013
    Location
    CA
    Posts
    30

    Default

    Thanks Rickajho. I went thru all those specific PT2 draw problems when I got it. I drilled out the PT base where the center pin/insulator sit to a slightly bigger diameter. From previous searches I believe all PT heads I have are the newer squishier style. My PT2 works fine on the 3 eGo batteries and the eVic Easy Head that I have. The new VV/VW eVic head that I received on Thursday is the only piece of equipment that I have that my PT2 will not sit flush and allow airflow. Thats why I was asking if the center post could be lowered or if anyone knew if the center pins sat a different heights. At this time I`m using the base off of my PT2 mini on my fullsize PT; obviously plenty of room for airflow in it. I would just prefer to have a smoother transition down the length of the device. Any other ideas are greatly appreciated.
    Shane

  7. #7
    Full Member buck naked's Avatar
    Join Date
    Nov 2013
    Location
    CA
    Posts
    30

    Default

    Well I went and got an eGo threaded straight cone cover to stabilize the PT2 on my eVic. It was the situation described by Rickajho in a previous post. I knew that but it didn't make sense to me why 2 pieces from the same company that are intended to interchangeable ( VV/VW head & easy head ) would not work the same way with the PT2. I decided why fight it just get it function like it should. Thanks again to those who helped with their insight.
    Shane

  8. #8
    PV Master Verified Member
    ECF Veteran
    crxess's Avatar
    Join Date
    Sep 2012
    Location
    Williamsport Md
    Posts
    8,865
    Blog Entries
    3

    Default

    The answer to all PT2 air flow issues it the new AeroTank Base. It draws air from the side, not the 510 area.
    Smoke free since 08/06/12 for my loving Wife, our Children and Grand Children
    Someone has to pay the bills - lol


  9. #9
    Full Member Verified Member viseversa101's Avatar
    Join Date
    Sep 2013
    Location
    ohio
    Posts
    65

    Default

    either bore out the p2 holes on the head like i did just a tad or do like suggested get an adjustable airflow, itl preserve the threads and allow you to adjust flow to your liking.

    Evic - Protank II / Provari V2.5 - Davide / VTR - Davide / Nemesis - Nimbus Clones

  10. #10
    Full Member buck naked's Avatar
    Join Date
    Nov 2013
    Location
    CA
    Posts
    30

    Default

    Per crxess suggestion I have been searching for an Aerotank base! Has seemed futile; out of stock everywhere! Finally came across a thread here on ECF, ordered it from Avid Vapor. I hope this will help the problem while having as few items screwed on to it. Thanks agin for the info.
    Shane
    Be unique!!! Like everyone else.

Page 1 of 2 12 LastLast

Bookmarks