Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: BAD chemical taste in atomizers

  1. #1
    Super Member ECF Veteran Bastage's Avatar
    Join Date
    Oct 2008
    Location
    Houston, TX
    Posts
    426

    Default BAD chemical taste in atomizers

    Just wondering if anyone else has this problem regularly or has seen it. I've had 2 different 901b atomizers do this to me. I'll take a brand new atomizer and prime it, start puffing and it just produces the nastiest chemical burning taste. I'm thinking ok if I take a few puffs it'll go away... but it never does. If I refill I get a few decent tasting puffs, then right back to the strong chemical taste. It tastes toxic... dont' know if it is or not but I can't continue to inhale that mess, no telling what's in it if it tastes that bad. I'm not talking about your first few puffs on a new atomizer that aren't very good... I'm talking about a horrible strong chemical taste. If it had just happened to me once I coudl dismiss it, but I think this is potentially very unsafe, and is a serious manufacturing defect that needs to be addressed.

  2. #2
    Senior Member ECF Veteran
    Join Date
    Oct 2008
    Location
    UK
    Posts
    190

    Default

    Bastage, I think it's the battery self cleaning.... Some people have recommended giving the atomiser a bath.

  3. #3
    Senior Member ECF Veteran
    Join Date
    Apr 2008
    Location
    Tx
    Posts
    260

    Default

    Sounds like your atomizer wick is burnt. There's no amount of cleaning that will get rid of the taste, chuck the atomizer and get a new one.

  4. #4
    Senior Member
    Join Date
    Sep 2008
    Posts
    172

    Default

    Quote Originally Posted by efaglil View Post
    Bastage, I think it's the battery self cleaning.... Some people have recommended giving the atomiser a bath.
    They self clean? What do they do exactly?

  5. #5
    Full Member
    Join Date
    Oct 2008
    Location
    South Africa
    Posts
    44

    Default

    I had the same problem, I was running my atomizer off 4 AAA batteries. For the first 2 days it was making lots of smoke and tasted fine, then all of a sudden it got the chemical taste and it just kept coming back after a few puffs if I cleaned it out. Now I am using 3 batteries but the smoke is not that great but it tastes fine. It's like 3 batteries is too little and 4 is to much, still haven't tried your USB plan although that's what I started out doing.

  6. #6
    Senior Member ECF Veteran
    Join Date
    Oct 2008
    Location
    UK
    Posts
    190

    Default

    lucisac?? They self clean... I don't know!

    I've read somewhere on here that the self clean takes place (allegedly around the 1500 puff mark). I don't know the mechanics of it, just that it happens. I expect they're burning off all the cruddy eliquid between battery and atomiser.

    I've got about six batteries on the go and rotate them. They've all decided to self clean within the past week. You can hear a sizzling sound and the LED light starts flashing. If you can unscrew the battery fast enough you're fine, if not you get that horrible chemically taste. I've got two atomisers lined up for a bath because of this.

  7. #7
    Senior Member ECF Veteran
    Join Date
    Oct 2008
    Location
    UK
    Posts
    190

    Default

    I've also got a new battery which tastes exactly the same. I've tried numerous atomisers and carts and it's definitely the battery. Anyone else had this?

  8. #8
    Super Member ECF Veteran Bastage's Avatar
    Join Date
    Oct 2008
    Location
    Houston, TX
    Posts
    426

    Default

    I'm using a manual switch so there is no self cleaning cycle. It was not a used one, brand new one and it has had this problem since the first time I tried it.

    As far as running 4 batteries, yes I can see why that would burn up your atomizer, it's too much voltage. If you're going to use AA or AAA it's best to only use 3. (that provides 3.6-4v to your atomizer).

  9. #9
    Forum Supplier ECF Veteran CaSHMeRe's Avatar
    Join Date
    Jun 2008
    Location
    USA
    Posts
    7,933

    Default

    Every once in a while, you will get an atomizer that taste like a chemical plastic taste right from the get go. No matter of cleaning or liquid will get rid of the taste.

    In the past 4-5 months, I think I have seen a total of about 5-6 ...

    I must admit, the throat hit is intense on them though ... HAHA ... to bad it tastes sooo bad ...

  10. #10
    Super Member
    Join Date
    Oct 2008
    Location
    Belfast, UK
    Posts
    314

    Default

    Alcohol dissolves oil-gunk pretty well but I guess members have tried this before?

    If it doesn't get rid of the bad taste perhaps we should try cleaning atomisers with strong liquours that we like. ... Then again ... could I really waste a Bushmills malt on an atomiser?

    I'd need to be nicotine starved!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks