Protank 2 leaking
Page 1 of 2 12 LastLast
Results 1 to 10 of 20
Like Tree8Likes

Thread: Protank 2 leaking

  1. #1
    Full Member
    Join Date
    Sep 2013
    Posts
    94

    Default Protank 2 leaking

    My tank leaks throw to the battery connection its really bad any ideara

  2. #2
    Ultra Member Verified Member
    ECF Veteran
    JonnyB88's Avatar
    Join Date
    May 2013
    Location
    Elgin, IL, USA
    Posts
    1,595

    Default

    So many variables.

    Are they stock coils, or rebuilt ones?
    Either way, did you remove the flavor wick?
    If rebuilt coils, what's your wick (silica, Ekowool, cotton, mesh)?
    What's the PG/VG ratio of your juice?
    murphyramone likes this.

  3. #3
    Full Member Verified Member
    Join Date
    Sep 2013
    Location
    Portland, OR, USA
    Posts
    74

    Default

    What ProTank? 1/2 full size mini? How long have you been using the current coil? Premade Coil? Rebuild? At a guess I would say clean the center tube with a q-tip/blow out any extra juice that may have gotten in there when filling.

    Also could be:
    o-rings in top/bottom
    old atty break down
    coil not screwed in tight
    top/bottom not screwed in tight
    etc...

    Vape on
    murphyramone likes this.

  4. #4
    Full Member
    Join Date
    Sep 2013
    Posts
    94

    Default

    Had tank for 4 days so that's how old the head it protank 2 full coil is premade

  5. #5
    Ultra Member Verified Member
    ECF Veteran
    JonnyB88's Avatar
    Join Date
    May 2013
    Location
    Elgin, IL, USA
    Posts
    1,595

    Default

    If you've done no tinkering with the stock coils, then I would simply suggest trying a new coil. You could just have a bad apple.

  6. #6
    Full Member
    Join Date
    Sep 2013
    Posts
    94

    Default

    I did not remove a flaver stick shod i

  7. #7
    Full Member
    Join Date
    Sep 2013
    Posts
    94

    Default

    I use 100%vg

  8. #8
    Ultra Member Verified Member
    ECF Veteran
    JonnyB88's Avatar
    Join Date
    May 2013
    Location
    Elgin, IL, USA
    Posts
    1,595

    Default

    With 100%VG, removing the flavor wick could help with wicking. But, try a new coil first, and see how it goes.

  9. #9
    Full Member Verified Member
    Join Date
    Sep 2013
    Location
    Portland, OR, USA
    Posts
    74

    Default

    Agree 100% with Jonny, may be just a bad coil. If that doesn't work id check the seals.

  10. #10
    Full Member
    Join Date
    Sep 2013
    Posts
    94

    Default

    OK thanks I will try the coil

Page 1 of 2 12 LastLast

Tags for this Thread