EGO to 510 Adapters are Junk
Results 1 to 9 of 9
Like Tree2Likes
  • 2 Post By Just Me

Thread: EGO to 510 Adapters are Junk

  1. #1
    Super Member sky4it's Avatar
    Join Date
    Nov 2013
    Location
    Minnesota
    Posts
    311

    Default EGO to 510 Adapters are Junk

    Gotta Smok Pyrex bottom coil, needed an ego adapter for my lavatube its too wide, the Ego to 510 adapters drop the OHMs to nonexistent and they dont work.

    Anyone else have that problem with those adapters?
    Last edited by sky4it; 12-04-2013 at 11:32 PM.

  2. #2
    Senior Member ECF Veteran Just Me's Avatar
    Join Date
    Mar 2010
    Location
    Texas
    Posts
    266

    Default

    No, I have two, and they both work. Caveat--one sometimes doesn't work with some of my eVod tanks. When I ordered my first Provari, I also ordered the adapter. I realized the threading on some of my eVod heads didn't want to screw down on the adapter. Those would go if I forced them, but they were usually a bit sideways and didn't fit well. It seems the post inside was a little too high, and as soon as it contacted the firing pin under the tank, it just wouldn't fit down any farther. They did work, however, very carefully. I just ordered another Provari a couple of weeks ago, and the new adapter works very well. The pin isn't as high in this one, and I've not had any problems at all with it. I had noticed at least one very upset reviewer on their site about the adaptor. I guess they took care of it.

    Also, they sell the sealed one that won't leak onto your battery. I understand there are some out there that aren't sealed.
    Last edited by Just Me; 12-04-2013 at 11:43 PM. Reason: spelling
    Iffy and sky4it like this.

  3. #3
    Super Member sky4it's Avatar
    Join Date
    Nov 2013
    Location
    Minnesota
    Posts
    311

    Default

    Justme:

    yeah I dunno, they all look the same from different vendors, maybe my lavatube button inside the threading is worn down. Anyway took care of it, by ordering a vamo 5. thanks for the comment

  4. #4
    PV Master Verified Member
    ECF Veteran
    Supporting Member
    Iffy's Avatar
    Join Date
    Feb 2011
    Location
    Florida Suncoast
    Posts
    7,890
    Blog Entries
    1

    Default

    'Lift' da center posts on your batt, joose device and (if possible) da adapter.

    I've used MANY eGo/510 adapters. Solids are da best!
    If I'm awake, I vape!
    No 'bakky' since Apr 14, 2011, after 45 years of 2 PaD <insert Snoopy dance here>



  5. #5
    Super Member sky4it's Avatar
    Join Date
    Nov 2013
    Location
    Minnesota
    Posts
    311

    Default

    Quote Originally Posted by Iffy View Post
    'Lift' da center posts on your batt, joose device and (if possible) da adapter.

    I've used MANY eGo/510 adapters. Solids are da best!
    Iffy: What do you mean? lift center post on battery, you mean lift the center post on the lavatube?, I cant take the outside ring apart even with a pliars its on too tight?

  6. #6
    PV Master Verified Member
    ECF Veteran
    Supporting Member
    Iffy's Avatar
    Join Date
    Feb 2011
    Location
    Florida Suncoast
    Posts
    7,890
    Blog Entries
    1

    Default

    Quote Originally Posted by sky4it View Post
    Iffy: What do you mean? lift center post on battery, you mean lift the center post on the lavatube?, I cant take the outside ring apart even with a pliars its on too tight?
    Sorry, meant to day PV 510 center connection. Don't think ya can do dat on the LT.
    If I'm awake, I vape!
    No 'bakky' since Apr 14, 2011, after 45 years of 2 PaD <insert Snoopy dance here>



  7. #7
    Super Member Verified Member
    ECF Veteran
    vicflo's Avatar
    Join Date
    Dec 2009
    Location
    Virginia
    Posts
    333

    Default

    which ego to 510 adapter are you using? those are actually hard to find and not many manufacturers make them.
    ѴιςғĿδ

  8. #8
    Super Member sky4it's Avatar
    Join Date
    Nov 2013
    Location
    Minnesota
    Posts
    311

    Default

    Quote Originally Posted by vicflo View Post
    which ego to 510 adapter are you using? those are actually hard to find and not many manufacturers make them.
    vicflo:

    Just using a generic one I bought at a vendor in the Carolina's, but all look the same from different vendors. I even took the adapters apart and put them back together, they stink

  9. #9
    Super Member Verified Member
    ECF Veteran
    danny4x4's Avatar
    Join Date
    Feb 2013
    Location
    London
    Posts
    725

    Default

    I have 6 of them from fasttech and they all work. Maybe you just got a dud?

Bookmarks