Vision spinner problems!
Page 1 of 7 12345 ... LastLast
Results 1 to 10 of 70
Like Tree113Likes

Thread: Vision spinner problems!

  1. #1
    Full Member Verified Member
    Join Date
    Dec 2012
    Location
    Pittsburgh, PA, USA
    Posts
    118

    Default Vision spinner problems!

    My 1300 mah Vision Spinner Fat battery is no longer doing anything properly. It doesn't hold a charge. When the battery is on the charger, the white light on the button blinks, and it shows green on the charger, but the battery is "dead". This battery is pretty damn new, and it WAS my favorite battery ever cuz of how well it worked. I just don't understand what could be wrong. I've only had the battery for a month and have used it less than that. Any ideas?
    Last edited by strifeimmaculate; 03-01-2013 at 12:45 AM. Reason: misspelling corrections

  2. #2
    PV Master Verified Member
    ECF Veteran
    burns_erin's Avatar
    Join Date
    Mar 2010
    Location
    The ArmPit of Texas
    Posts
    3,993
    Blog Entries
    14

    Default

    Have you tried cleaning the contacts on the battery and on the charger? Do you have another charger you can try it on?
    COG =$2,350.36

  3. #3
    Full Member Verified Member
    Join Date
    Dec 2012
    Location
    Pittsburgh, PA, USA
    Posts
    118

    Default

    I have cleaned the contacts thoroughly and yes I have have my roommates eGo charger and it is giving me the same results. When it is unplugged completely, even pressing the button does nothing. (Normally, the button would turn white while holding the button.) And yes, I have hit the button 5 times to "turn the battery on or off."

    When the battery is plugged in, the white light just flashes and flashes and the green light on the USB charger stays green. All of this is very new to me, as I have never seen the button just flash over and over again whilst plugged in, but show absolutely no signs of life whilst not plugged in. The only thing I have ever really used on this battery was my Vision ViVi Nova STV and I have never had any of these issues before. It was working only an hour or two ago while I watched the Pittsburgh Penguins get stomped out. Sometime during the game, everything with the battery just stopped firing. I have plugged the STV into an 1100 mah Riva-T VV battery and also a 510 manual battery and that still works perfectly on both of those.

    This Spinner battery is practically brand new, but now does not work at all with anything that I have screwed into it; ie. STV, Vision Nanos, 510-T atomizers, etc.

  4. #4
    Full Member Verified Member
    Join Date
    Dec 2012
    Location
    Pittsburgh, PA, USA
    Posts
    118

    Default

    Ugh, I'm SO MAD! I love my Spinner! Is it ruined? What can I do? GAAAAAAAAAAAHHHHHHHHHHHHHHHHHHH!!!!!!!!!!

  5. #5
    Moved On
    Join Date
    Dec 2012
    Location
    Somerset, MA
    Posts
    1,731

    Default

    I searched online for possible modifications to broken spinners.
    Found nothing.
    strifeimmaculate likes this.

  6. #6
    Sdh
    Sdh is offline
    ECF Guru ECF Veteran Sdh's Avatar
    Join Date
    Aug 2010
    Location
    U.S.
    Posts
    10,428

    Default

    When you are charging your vision spinner do you have the voltage on the ecig set at 4.2 volts. If not, try that. Good luck!
    [SIGPIC][/SIGPIC]

  7. #7
    Full Member Verified Member
    Join Date
    Dec 2012
    Location
    Pittsburgh, PA, USA
    Posts
    118

    Default

    Quote Originally Posted by Sdh View Post
    When you are charging your vision spinner do you have the voltage on the ecig set at 4.2 volts. If not, try that. Good luck!
    Will try this right now and will post again the results. Thanks everyone for trying to help, I'm just so mad. I just got this damn batt and haven't even used it a full month. There should be no reason why my Spinner is just all of a sudden non-working as this battery should last much longer than a month.

  8. #8
    Sdh
    Sdh is offline
    ECF Guru ECF Veteran Sdh's Avatar
    Join Date
    Aug 2010
    Location
    U.S.
    Posts
    10,428

    Default

    Quote Originally Posted by strifeimmaculate View Post
    Will try this right now and will post again the results. Thanks everyone for trying to help, I'm just so mad. I just got this damn batt and haven't even used it a full month. There should be no reason why my Spinner is just all of a sudden non-working as this battery should last much longer than a month.
    :
    I hope it works for you. It's my only suggestion. I know many sites are saying to charge the battery at 4.2. Good luck!
    [SIGPIC][/SIGPIC]

  9. #9
    Full Member Verified Member
    Join Date
    Dec 2012
    Location
    Pittsburgh, PA, USA
    Posts
    118

    Default

    I don't think that is quite the issue, all the battery button does is blink, but when it would charge normally, that light simply just wouldn't do that. I think this one is somehow faulty because no matter what I charge it at, as soon as I take it off the charger, it does ABSOLUTELY nothing! Won't fire anything that is firing correctly on every other battery I have. (510's, Riva VV 1100, etc.) I got a beat on battery I think and I am not happy about it, one bit. I sent in a ticket so hopefully they will have some kind of good news for me cuz this battery wasn't terribly expensive but it wasn't really all that cheap either. I'm so mad I could HULK SMASH this laptap... but I won't.

    UGH!

    P.S. I never had to make sure it was on any specific voltage for it to charge in the first place. It just worked. And now it does absolutely nothing.
    Last edited by strifeimmaculate; 03-01-2013 at 04:33 AM. Reason: P.S.

  10. #10
    PV Master Verified Member
    ECF Veteran
    rdsok's Avatar
    Join Date
    Mar 2012
    Location
    Norman, Ok
    Posts
    6,033

    Default

    Make certain to pull the post just to ensure that it is making good contact... The posts are known to get pushed in when a person tightens a carto, clearo or atty on too tight.

Page 1 of 7 12345 ... LastLast

Tags for this Thread

Bookmarks