IKV MEGA 510 Platinum Standard problem
Results 1 to 5 of 5
Like Tree2Likes
  • 2 Post By pizza2me

Thread: IKV MEGA 510 Platinum Standard problem

  1. #1
    Super Member Verified Member
    ECF Veteran
    LucidAce's Avatar
    Join Date
    Aug 2012
    Location
    right about here, USA
    Posts
    565

    Default IKV MEGA 510 Platinum Standard problem

    So I've been a bit frustrated with cartomizer issues in recent months as I'm sure all cartomizer users are. I decided to pick up a box of the IKV MEGA 510 Platinums Standard cartomizers in hopes of getting cartomizers that avoided the various "bogegate" issues, but I'm afraid I wasn't so lucky.

    At first I was excited, because I could see differences in the design of these cartomizers compared to the Boges I have. But then I went to fill it up, and it exhibited the same sort of hydrophobic issues. It took forever to fill it up, and it didn't seem to hold as much liquid as I expected. But then I had hopes again, because it seemed to vape well. So I punched a hole in it and stuck it in a tank. After another ml or so of juice went through it (somewhere in the neighborhood of 2-3ml total) the flavor seemed to just totally disappear. I wasn't getting much of a strange flavor per se, but I could barely taste my juice anymore. And then I started noticing the draw tightening up intermittently.

    Was it unreasonable of me to expect these to sidestep the vast cartomizer QA issues of late? Perhaps it's a coincidence?

  2. #2
    Moved On Verified Member
    ECF Veteran

    Join Date
    Aug 2010
    Location
    Maryland
    Posts
    2,272

    Default

    I've had nothing but good with the regular platinums. But, there are, as with anything, occasional duds. Is it possible you punched the hole(s) to deep? Maybe it punctured the tube just enough so it worked for a while and then clogged/gunked?

    Or possibly too small a hole and it wasn't getting enough juice in?

    I hope you've tried another one and had better luck. Let us know.
    5cardstud and LucidAce like this.

  3. #3
    Super Member Verified Member
    ECF Veteran
    LucidAce's Avatar
    Join Date
    Aug 2012
    Location
    right about here, USA
    Posts
    565

    Default

    Quote Originally Posted by pizza2me View Post
    I've had nothing but good with the regular platinums. But, there are, as with anything, occasional duds. Is it possible you punched the hole(s) to deep? Maybe it punctured the tube just enough so it worked for a while and then clogged/gunked?

    Or possibly too small a hole and it wasn't getting enough juice in?

    I hope you've tried another one and had better luck. Let us know.
    I wanted to try out just this one first to really see how it was working and what was going on without confusing myself with another one. So, the first one really, really tightened up so I put it aside for now and opened a new one. I condom filled this one which went a little better, and it's vaping like a champ right now.

    The weird thing about the first one was that it still seemed to be producing really good vapor after the flavor went away and there was no "off" or burnt taste so I don't think it was a matter of the cartomizer not getting enough juice. I could still taste the juice, but it was just a very faint and week flavor. I also topped it off by hand a couple times to kind of test that and there was no difference. I'm almost afraid to punch a hole in this one now since it's working so well as is, though I can't imagine that I could've changed anything when I punched the hole. I punched it like I always do, and yeah, it seemed to work fine from a feeding and vapor production standpoint at first.

  4. #4
    Super Member Verified Member
    ECF Veteran
    LucidAce's Avatar
    Join Date
    Aug 2012
    Location
    right about here, USA
    Posts
    565

    Default

    Is there maybe something about punching these that I don't know? The one that I condom filled and vaped as a standalone outside a tank is still working very well, but I punched a brand new one, and it started performing poorly almost right away. The resistance has been erratic (dropped from the high 2's to the high 1s and has been up into the mid 2s and back into the low 2s; now is at about 2.6), the draw inconsistent, and the flavor quite muted. I've never had problems with the Boges and SmokTechs I've punched, and I'm doing the same thing here.

  5. #5
    ECF Guru (Fusionman) Team ECF (folding@home)
    Verified Member
    ECF Veteran
    Supporting Member
    5cardstud's Avatar
    Join Date
    Jan 2010
    Location
    Fusionmans Cave, WA.
    Posts
    18,745

    Default

    I wished I had an answer for you but alas I have good luck with them. All I can add is if you punch them too deep they leak. If the hole is to small they don't feed correctly and too large and they will flood. That's one of the reasons I use the pre-punched ones. I wish you luck.
    PS Nice job on the avatar.
    Last edited by 5cardstud; 12-02-2012 at 12:01 AM.

    To handle yourself, use your head; To handle others, use your heart.

Bookmarks