China Lava knock-offs....junk!
Results 1 to 7 of 7
Like Tree2Likes
  • 1 Post By skelley
  • 1 Post By skelley

Thread: China Lava knock-offs....junk!

  1. #1
    Super Member ECF Veteran
    Join Date
    Jan 2012
    Location
    Wild & Wonderful .................... West Virginia
    Posts
    922

    Default China Lava knock-offs....junk!

    I have a mini lava knock-off and it's a piece of junk!
    First the bottom knob cap came off (no big deal, little glue); next I noticed the 510 threads are tapered.
    Everything I put in this device only grabs the bottom threads as it drops in most of the way.
    This is a big issue, as it tipped over and now the brass threads are stripped.
    3 months in and it's worthless.

    /rant

  2. #2
    Ultra Member ECF Veteran
    Join Date
    Jun 2011
    Location
    West of Rochester,N.Y.
    Posts
    1,256

    Default

    I think the bottom cap is like that because it's a blowout plug so if the battery vented it would pop off..gluing it might not be a great idea unless you only used very little glue so it could still come off.

    Hmm sounds like you got a bad 510 connector from the start..I've been using mine over a month and things screw in multiple turns..I know it is tapered before the threads. You might be able to run a thread tap lightly into it or they make a thing called a helicoil for repairing broken threads not sure if they sell them in that size.

    If you can tap the threads you could stick an 510 eGo adapter or extension in there..maybe even glue it in there. If those don't work the connector might be able to be replaced..510 connectors don't cost much but it might be a pain getting the old one out without breaking wires..it's probably just pressed in there.

    Before you try any of that you should check to see if it's still warrantied because some sites they come with a year warranty..but it might not be covered if you dropped it...

  3. #3
    Super Member ECF Veteran
    Join Date
    Jan 2012
    Location
    Wild & Wonderful .................... West Virginia
    Posts
    922

    Default

    Good points, but I'm getting ready to disassemble it for further inspection.

    I've always had issues with the center post connection, so I gentle pulled the top off and noticed only 1 wire was connected to the head. The hot wire going to the center post has a big ball of solder on the end and I don't see that it was ever really connected.
    I was a electronic tech in the Marine Corps and this appears to be poorly constructed to be honest.
    I gently pushed the top back down and I can hold a carto in place and it will fire.
    This tells me it was a wire connecting issue all along.

    I also didn't 'drop' it, I stood it up which I typically don't do and it fell over. I was never really crazy about brass threads anyways and my future devices will not have them either.

    I will give the device credit as it did adjust voltage, but it was a $79 bad investment. Even though they are a lot cheaper now, I just wanted to let everyone know some of the issues that I have noticed.
    Seattle40 likes this.

  4. #4
    PV Master ECF Veteran
    Join Date
    Mar 2011
    Location
    Philly
    Posts
    3,134
    Blog Entries
    8

    Default

    madvapes sells a "silver" non-brass connector for a couple bucks. a couple solder beads and done.

  5. #5
    Super Member ECF Veteran
    Join Date
    Jan 2012
    Location
    Wild & Wonderful .................... West Virginia
    Posts
    922

    Default

    Thanks, I am checking it out now

    Quote Originally Posted by MASTER0FDAMPF View Post
    madvapes sells a "silver" non-brass connector for a couple bucks. a couple solder beads and done.
    MASTER0FDAMPF likes this.

  6. #6
    PV Master ECF Veteran
    Join Date
    Mar 2011
    Location
    Philly
    Posts
    3,134
    Blog Entries
    8

    Default

    Silver 510 Battery Connector, Sealed

    Just in case!

    Quote Originally Posted by skelley View Post
    Thanks, I am checking it out now

  7. #7
    Ultra Member Verified Member
    ECF Veteran
    KeysBum's Avatar
    Join Date
    May 2011
    Location
    Florida Keys, USA
    Posts
    1,663

    Default

    So far I've bought 4 LT's. One of the first two was Tango Uniform because the on/off button was AFU. (seller promply replaced it) The other three have been performing flawlessly. (4 months now) I'm using them much more than my Buzz Pros. I use regular resistance cartos and rarely go above 10 watts, so the amp limit is meaningless to me. If you have backups and buy from a retailer with a 1 year waranty, you cannot go wrong. One year from now there will be something so much better....Things are progressing FAST.
    Last edited by KeysBum; 04-19-2012 at 10:44 PM.

    .................................................. .................And I haven't saved a dime.

Tags for this Thread

Bookmarks