Page 1 of 5 12345 LastLast
Results 1 to 10 of 49
Like Tree4Likes

Thread: Vision Spinner Button Problem

  1. #1
    Full Member Verified Member
    ECF Veteran

    Join Date
    Aug 2012
    Location
    Chicago
    Posts
    127

    Default Vision Spinner Button Problem

    Vision Spinners buttons are getting stuck. After opening the battery and seeing the problem, I found that the glue (that holds the small circuit board) gets dislodged and button falls inside. This can happen easily from dropping the battery. The engineers at Vision need to use the method Joyetech uses to hold the button in place. Flimsy glue is a terrible idea and every battery is at risk from this defect.

    I urge madvapes to talk to Vision and sort this problem out.

  2. #2
    Member
    Join Date
    Nov 2012
    Location
    Coeur d'Alene, ID
    Posts
    14

    Default

    Happened to me today. I dropped it on carpet yesterday and the button got all messed up, then my friend dropped it on carpet again today and it became completely useless. Didn't know what caused it, but what you're describing sounds like exactly what happened to me. It's a shame, because I LOVE my Spinner. Going back to my backup eGo is really unsatisfying.

  3. #3
    Full Member ECF Veteran
    Join Date
    Dec 2012
    Location
    Sweden
    Posts
    93

    Default

    I got one like this today. The button wouldn't move and the light went on an off at random. I decided to open it up discovered the culprit was the micro switch on the circuit board. These sometimes break although I now wish I got the Ego Twist instead.

    EDIT:Ordered from a different vendor(thread came up on google search)
    Last edited by RoadToNever; 12-29-2012 at 01:58 PM.

  4. #4
    Member
    Join Date
    Nov 2012
    Location
    Coeur d'Alene, ID
    Posts
    14

    Default

    Madvapes is going to replace mine. Glad I've been sending them new vapers!

  5. #5
    Full Member Verified Member
    ECF Veteran

    Join Date
    Aug 2012
    Location
    Chicago
    Posts
    127

    Default

    Glad they're replacing it but all the vendors need to contact Vision about this, this problem can happen over and over again because the design is inherently flawed.

  6. #6
    Senior Member ECF Veteran
    Join Date
    May 2011
    Location
    Portland, OR
    Posts
    235
    Blog Entries
    1

    Default

    Mine fell about four feet onto a brass footrail... Flaw or not, I'm pretty sure my situation doesn't fall under the category as a "normal use failure" - so this one's all on me, lol...

    Anyhoo... I'm pretty handy and would like to open mine up to fix the button myself. Any pointers?

  7. #7
    PV Master ECF Veteran
    Supporting Member
    DavidOck's Avatar
    Join Date
    Jan 2013
    Location
    Eatonville WA
    Posts
    3,563

    Default

    I'm with you, Marb!

    Tips on how to open the battery up - in a nondestructive manner :-) - would be appreciated. I have two, although no button problems yet.

  8. #8
    Full Member ECF Veteran Pampavich's Avatar
    Join Date
    Sep 2011
    Location
    Netherlands
    Posts
    107

    Default

    Got this problem yesterday with my 1300. Also have 3 dead ego twist. Dont know what to buy anymore. The all brake and look like new from outside.. what a waste. Using an old kgo now and im not happy. Agree with david i would like to fix them. Cant even send them back lol.

  9. #9
    Senior Member ECF Veteran
    Join Date
    May 2011
    Location
    Portland, OR
    Posts
    235
    Blog Entries
    1

    Default

    My Spinner just completely stopped today. Doesn't do anything when I push the button; but the button lights when I put it on the charger, so IDK...

    If no one with helpful hints posts here, I'll probably do some recon into disassembly myself... I found that the old SMOK egos are just a simple press fit, so I'm thinking these are similar... If not, I'll be posting with what NOT to do, lol...

  10. #10
    PV Master ECF Veteran
    Supporting Member
    DavidOck's Avatar
    Join Date
    Jan 2013
    Location
    Eatonville WA
    Posts
    3,563

    Default

    Hi Marb,

    That would be a press fit from which end? I've heard - I think about the Twist - that the adjustment dial is held by some type of close fit / press fit bushing. If that's so on the Spinner, then maybe the first step is to pop off the adjust dial? Strictly a guess!

    Both of mine are still working fine, but nothing lasts forever. Looking forward to the results of your investigation, and wishing you good luck on the resurrection. (Any chance of step by step pics?)

Page 1 of 5 12345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •