Halo G6 battery charging issues?
Results 1 to 8 of 8

Thread: Halo G6 battery charging issues?

  1. #1
    Member
    Join Date
    Feb 2012
    Location
    Birmingham, AL
    Posts
    5

    Default Halo G6 battery charging issues?

    I bought the G6 starter kit in early january and have been using both batts at least once every 2 days. Im starting to notice that when i put the batts in the wall/usb charger that the blue light dosent come on, but when i unscrew it to attempt to take a drag the blinking "you need to charge me" blue light.....

    Both batts are clearly dead but wont take a charge.....anyone have any triks i can try to fix this problem?

  2. #2
    Ultra Member ECF Veteran mooreted's Avatar
    Join Date
    Sep 2011
    Location
    California
    Posts
    2,972

    Default

    Nothing you can do to make a bad battery charge.

    Do you have another charger? It's hard to believe two batteries would die in a couple of months.

  3. #3
    Member
    Join Date
    Feb 2012
    Location
    Birmingham, AL
    Posts
    5

    Default

    the only charger i have is the one that i got in the starter pack.

  4. #4
    Super Member Verified Member
    ECF Veteran
    OldDragon's Avatar
    Join Date
    Jun 2010
    Location
    Kansas
    Posts
    888

    Default

    The only thing I can say is check the battery and charger to make sure they are clean of any juice that could block the charging process. Next try raising the center post a little to make sure they are contack each other. Next, order your backups....

  5. #5
    Ultra Member ECF Veteran mooreted's Avatar
    Join Date
    Sep 2011
    Location
    California
    Posts
    2,972

    Default

    If cleaning doesn't work, order another charger. Halo usually has pretty good stuff. Nothing is perfect but it shouldn't fail in two months.

  6. #6
    Account closed on request
    Join Date
    Nov 2011
    Posts
    3,206

    Default

    It is probably out of warranty, but you might ask Halo for some kind of discount on some new batteries. Just a thought. Good luck,

  7. #7
    Member
    Join Date
    Mar 2012
    Location
    Tampa Bay, FL
    Posts
    10

    Default

    I had the same problem. JB at Halo told me to clean the contacts with a clean dry cloth. So scrub the heck out of the battery threads with a towel and did the same on the charger and it finally started to charge.

  8. #8
    Member
    Join Date
    Mar 2012
    Location
    Tampa Bay, FL
    Posts
    10

    Default

    Did you ever get this fixed?

    Quote Originally Posted by zbug84 View Post
    I bought the G6 starter kit in early january and have been using both batts at least once every 2 days. Im starting to notice that when i put the batts in the wall/usb charger that the blue light dosent come on, but when i unscrew it to attempt to take a drag the blinking "you need to charge me" blue light.....

    Both batts are clearly dead but wont take a charge.....anyone have any triks i can try to fix this problem?

Tags for this Thread

Bookmarks