Burnt taste with new evod
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
Like Tree3Likes

Thread: Burnt taste with new evod

  1. #1
    Full Member
    Join Date
    Apr 2013
    Location
    texas
    Posts
    17

    Default Burnt taste with new evod

    Hey everyone. I got my new kanger evods in the mail a few days ago and they really do not have much of a taste no matter what liquid or voltage or wattage I use. If I set my vamo v2 to a higher wattage it tastes burnt. The taste I'm getting with 3 different juices is all the same. They all kind of have a weird chocolate/ burnt taste even at low wattage. Every now and then I'll get a hint of what the liquid should taste like. I've tried 2 different 2.5 ohm heads and have cleaned and dry burned both of them with the same results afterwards. Does anyone know anything else to try?
    Bill's Magic Vapor likes this.

  2. #2
    Ultra Member Verified Member
    ECF Veteran

    Join Date
    Jan 2013
    Location
    Princeton, NJ
    Posts
    1,874
    Blog Entries
    1

    Default

    Have you removed the top wick?

  3. #3
    Full Member
    Join Date
    Apr 2013
    Location
    texas
    Posts
    17

    Default

    Yes and it seemed to get a little worse.

  4. #4
    PV Master ECF Veteran tj99959's Avatar
    Join Date
    Aug 2011
    Location
    utah
    Posts
    9,970

    Default

    Well, turn the voltage down so that it won't taste burn. That's what evods are for.
    http://www.casaa.org/images/9974739e5e33027c7244f0b4518d5a2d.jpg

  5. #5
    Ultra Member Verified Member
    ECF Veteran

    Join Date
    Jan 2013
    Location
    Princeton, NJ
    Posts
    1,874
    Blog Entries
    1

    Default

    Remove the tube and the center pole, carefully wet the wicks with 1-2 drops of juice, then press the button and smell that vapor to see if its different.

    I was thinking maybe some bad smell from burnt silica earlier is lingering in your tube.

  6. #6
    Full Member
    Join Date
    Jun 2013
    Location
    New Orleans, LA
    Posts
    91
    Blog Entries
    1

    Default

    I'm having this same issue - picked up some eVods from a local store and right out the pack they taste burnt. I've bought eVods in the past and they're perfect right after you fill them (granted, the hits taste burnt until the wicks are wet enough), but I let these new ones sit with juice overnight and they're still burnt-tasting.

    Anyone had similar problems and found a solution?

  7. #7
    Juice Maker Verified Member
    ECF Veteran
    Supporting Member
    Bill's Magic Vapor's Avatar
    Join Date
    Feb 2013
    Location
    USA
    Posts
    3,845
    Blog Entries
    17

    Default

    It could be many things including juice that needs to be steeped. Sure, I have issues frequently, and keep cleaning, replacing, dry burning or whatever I need to do to chase the vape I'm looking for. I think that's not uncommon here. Also, sometimes the original coils/heads are not as good as the genuine replacement heads. I tinker until I get it where I want it. If I'm in a hurry, I just change the topper until I have time to tinker. Rule number one again, backups, backups, backups. My two cents.
    b2darizzle and Vapoor eyes er like this.
    Three were given to the Elves, immortal, wisest, and fairest of all beings. Seven to the Dwarf lords, great miners and craftsmen of the mountain halls. And nine, nine Rings were gifted to the race of Men, who above all else, desire variable power.

  8. #8
    Super Member Verified Member
    ECF Veteran
    lilmrsyeti's Avatar
    Join Date
    Mar 2013
    Location
    Alabama
    Posts
    517

    Default

    I received one Evod that was the same way. No matter how many washings and what not, that burnt taste would not go away. Someone on here that works with Machines, said they had gotten one the same way, and it tastes like Machine Oil...maybe that they didn't get out of it after making it. Anyhow, my only solution was to just rebuild the head.

    Which I'm sure you've checked...but you did say you were using a Vamo...have you made sure it is on the NO2 (RMS mode)

  9. #9
    Senior Member* ECF Veteran Kabooma's Avatar
    Join Date
    Mar 2013
    Location
    Eastern PA
    Posts
    232

    Default

    I bought two recently. The first one I used for my ADV and at first it was fantastic, much like the vivi nova, very deep flavor and good TH, etc.. Then about 5 days in it just got a very burnt taste. I've run out of juice and burnt up a couple of carts in my day, but none were as nasty and pungent as this. I opened up the second one and within 2 days, it got the same burnt flavor, while FULL.. I learned from the first one not to let it go down less than 1/3 full (and you really can only fill it to 2/3), so it was a PITA to manage it from the get-go.

    I tired completely washing them out and no dice, still the burnt flavor outflavors the juice. Think I will just toss them. I'm back on my novas.

  10. #10
    Super Member Verified Member
    ECF Veteran
    murphyramone's Avatar
    Join Date
    Apr 2013
    Location
    Rockford, Il
    Posts
    490

    Default

    I found that the evod didnt seem to get enough air on my vamo, it works well on a ego style battery tho. It could be that i just got a bad one also to.

Page 1 of 2 12 LastLast

Tags for this Thread