Question on the Nimbus and what MOD I should use for it.
Results 1 to 5 of 5
Like Tree1Likes
  • 1 Post By Eric1217

Thread: Question on the Nimbus and what MOD I should use for it.

  1. #1
    Member
    Join Date
    May 2013
    Location
    San diego
    Posts
    3

    Default Question on the Nimbus and what MOD I should use for it.

    I've been vaping since February and Im still pretty newb-ish when it comes to it. My question is I plan on buying a Nimbus atty very soon but I was told that it does not work on the Joyetech EVIC. 1. Which would be a good MOD to use that is under $100 2. I was also told that there is a way to "modify" my EVIC so it can run a Nimbus atty. is that true? Your help is much appreciated. Vape vapors!!!!

  2. #2
    Full Member Verified Member
    Join Date
    Apr 2013
    Location
    Long Beach, CA, USA
    Posts
    86

    Default

    I do have a Nimbus and also a EVIC and you could vape it using an evic if you rebuild your coil with at least 1.5 ohm resistance, for me I use number 32 kanthal wire to kick the ohms up a little bit.

    Having said that EVIC for me dont really do it with any rebuildable atomizer for some reason (maybe it's the software) so I mainly use VAMO, Zmax, or Tesla for all my RBA atomizer either its Genesis type or drip.

    But if you want your Nimbus to really shine build it at around 1.0 ohms and use a mechanical MOD with vape2safe for protection then you really gonna love your Nimbus
    swearbear likes this.

  3. #3
    Member
    Join Date
    May 2013
    Location
    San diego
    Posts
    3

    Default

    Thanks alot Eric! your help is very much appreciated. Ill give it a try.

  4. #4
    Member
    Join Date
    May 2013
    Location
    San diego
    Posts
    3

    Default

    Alright I just picked up my Nimbus atty and had slapped it on my EVIC, problem is I get little to no vape! Can anybody help please?!?! Also weird thing is the ohms would fluctuate and sometimes it says atomizer not found. Can anybody help please?

  5. #5
    Full Member Verified Member
    Join Date
    Apr 2013
    Location
    Long Beach, CA, USA
    Posts
    86

    Default

    Quote Originally Posted by Suntzu619 View Post
    Alright I just picked up my Nimbus atty and had slapped it on my EVIC, problem is I get little to no vape! Can anybody help please?!?! Also weird thing is the ohms would fluctuate and sometimes it says atomizer not found. Can anybody help please?
    There are three possible reason for this,

    One, your coil is touching the body of the nimbus creating a short, that would make your resistance be inconsistent and report short or no atomizer error on the evic

    Two, the positive termminal on your evic or nimbus has dirt or dry up juice that interfere with the connection that would also result in inconsistent resistance and no automizer error

    Third, the nimbus positive terminal is either sticking to far out or in, that its making to little or to much contact with the positive terminal of the evic (Evic gives error reaading when you are pushing its positive terminal to much rearward) hence the error.

    Sorry for the late responce I have been out of town hope this helps.

Tags for this Thread

Bookmarks