Question regarding eGo C Twist + Kanger Protank
Results 1 to 8 of 8

Thread: Question regarding eGo C Twist + Kanger Protank

  1. #1
    Full Member
    Join Date
    Jun 2013
    Location
    Largo, Florida
    Posts
    32

    Default Question regarding eGo C Twist + Kanger Protank

    My rig is a eGo C Twist 1000mah Battery and a Kanger Protank. I have been Vaping for about 2 months now and love it. However, today I was filling my tank at work, and after I closed the back cap on the Protank, I accidentally dropped it pretty hard on a concrete floor. It made a small dent on the back cap (that holds the atomizer which came stock <2.5 ohm I believe> with the Protank kit). Well, shortly after, I noticed that to get any Vape out of it after dropping it, I had to turn the C Twist all the way up to 4.8 volts. I figured that I somehow broke the atomizer.

    Well, lucky enough for me, I previously purchased (2) 2.5ohm and (2) 1.8ohm Atomizers for the Protank from Vaporkings.com. I inserted the 2.5ohm Atomizer in the Protank, primed it, and set on to Vape. I usually vape a Turkish Tobacco flavor 50pg/50vg from Vaporkings, or a tobacco flavor called Cowboy Tobacco from Lizardjuice.com. Well, with the new 2.5ohm Atomizer, I first tried it at about 3.7 volts, and it tasted like a burnt chemical. I then turned it all the way down to 3.2 volts; still a weird taste.

    I then took out the 2.5ohm Atomizer and inserted a 1.8ohm. Primed it and set the eGo C Twist to 3.2 (for fear it may burn out the atomizer). It was "ok" but did not produce a lot of smoke. I have since played around with the settings but if I go past 3.7 volts, I get the same weird taste.

    Could it be that the 2.5 ohm I first tried in the eGo C Twist is defective? I have another one, but I thought it would be best to post here and see if there is anything I am doing wrong first. My original Atomizer that came with the Kanger Protank Kit worked great at any Voltage. This is kind of confusing to me.. not sure what to do. Any help would be greatly appreciated. Thank you all in advance. I am new to this board, so I have tried to be as complete as possible.

  2. #2
    Super Member Verified Member
    ECF Veteran
    Smokachino's Avatar
    Join Date
    Mar 2009
    Location
    Texas, USA
    Posts
    692
    Blog Entries
    2

    Default

    Welcome to ECF, Tommy! Sounds like you may have damaged the connection when you dropped it If the base where the atty goes is the only thing that's damaged, you can buy new ones if you can find them in stock.

    Here's a link for what I'm talking about. Is this what was damaged?

    http://www.discountvapers.com/kanger...e-replacement/
    Last edited by Smokachino; 06-12-2013 at 02:37 AM. Reason: added link

  3. #3
    Full Member
    Join Date
    Jun 2013
    Location
    Largo, Florida
    Posts
    32

    Default

    Thank you for the reply, and thank you for the welcome to the forum. I took it apart and inspected the bottom cap pretty well. The only visible damage I can see is a small (very small) dent on (more like a scratch) on the outer side of the cap. When screwed in, with an atomizer, it makes full contact with the battery. I can hear the atomizer engage when I touch the button. However, now I noticed another issue. My airflow seems a bit constricted maybe, 1 out of every 5 puffs. It is very strange. I have even had puffs with no vapor at all then, followed by another puff with a LOT of vapor (like almost too much). Ok so maybe I need to go back to the basics and ask a very silly question.

    With the Protanks, I have been topping off the same Protank for days now. I have (in the past) removed the atomizer and cleaned it. I have watched Youtube Vids on how to do this so I feel pretty confident that I am doing that right, but specifically, how often do you guys discard the juice in your protank and clean the tank? I notice that sometimes as I get the Protank down pretty low in volume of Juice, it turns dark. I have been just topping it off and letting the lighter juice mix with the darker juice and keep vaping. Is it possible that I have clogged something up inside the tank? Could that be my issue in a nutshell? Maybe I should just empty out the whole tank and start with some new juice. What do you guys and gals think? Am I on to something here?

  4. #4
    Full Member
    Join Date
    Jun 2013
    Location
    Largo, Florida
    Posts
    32

    Default

    Oh, I am sorry, I did look at the above posted picture and yes that is the piece that has the scratch. The piece is not bent, and has a scratch on the outer side (the side that does not make contact with the tank but does make contact with the battery). The scratch is near one of the vents on the outer side of the tank.

  5. #5
    Super Member Verified Member
    ECF Veteran
    Smokachino's Avatar
    Join Date
    Mar 2009
    Location
    Texas, USA
    Posts
    692
    Blog Entries
    2

    Default

    Glad you're here! You've come to the right place for info, advice, and opinions

    For me, when the juice gets dark like that it never tastes very good and I always dump it out, rinse out the tank, put on a new atty, and add fresh juice. I don't think you've clogged the tank, but it could be that the dark juice is gunking up your wicks and coil and now that's all you're tasting. IMO it's always best to vape fresh juice out of a clean tank with a fresh wick and coil.

  6. #6
    Super Member Verified Member
    ECF Veteran
    Smokachino's Avatar
    Join Date
    Mar 2009
    Location
    Texas, USA
    Posts
    692
    Blog Entries
    2

    Default

    Quote Originally Posted by TommyS View Post
    Oh, I am sorry, I did look at the above posted picture and yes that is the piece that has the scratch. The piece is not bent, and has a scratch on the outer side (the side that does not make contact with the tank but does make contact with the battery). The scratch is near one of the vents on the outer side of the tank.
    Well, if it's not bent . . . gosh, I really don't know. I've been seeing a lot of posts about damaged ProTank bases recently, so I'm hoping someone who's had a similar experience will chime in here.

  7. #7
    Full Member
    Join Date
    Jun 2013
    Location
    Largo, Florida
    Posts
    32

    Default

    Thank you Smokachino, that sounds like smart advice. It's getting late and my battery just flashed at me that it's out of power, and so am I. Time for bed. Thank you for the insight. Tomorrow I will dump the tank, add a new atomizer and clean the whole gizmo. Hopefully, it will behave for me tomorrow. I also have an EVOD (which I like), and a handful of CE-4's (stardusts) which I don't much care for. I have options until I get this properly resolved. I love the Protank and haven't had many issues with it until just today. Lesson to learn from this experiance .. Don't drop your Protank..It may be stainless steel but it's not Concrete proof! hehe. Thanks again!

  8. #8
    Super Member Verified Member
    ECF Veteran
    Smokachino's Avatar
    Join Date
    Mar 2009
    Location
    Texas, USA
    Posts
    692
    Blog Entries
    2

    Default

    Quote Originally Posted by TommyS View Post
    Thank you Smokachino, that sounds like smart advice. It's getting late and my battery just flashed at me that it's out of power, and so am I. Time for bed. Thank you for the insight. Tomorrow I will dump the tank, add a new atomizer and clean the whole gizmo. Hopefully, it will behave for me tomorrow. I also have an EVOD (which I like), and a handful of CE-4's (stardusts) which I don't much care for. I have options until I get this properly resolved. I love the Protank and haven't had many issues with it until just today. Lesson to learn from this experiance .. Don't drop your Protank..It may be stainless steel but it's not Concrete proof! hehe. Thanks again!
    You're welcome!

Tags for this Thread

Bookmarks