Newbie here having problems!
Page 1 of 4 1234 LastLast
Results 1 to 10 of 33
Like Tree28Likes

Thread: Newbie here having problems!

  1. #1
    Full Member Verified Member
    ECF Veteran
    wowoboi's Avatar
    Join Date
    Dec 2012
    Location
    GS
    Posts
    113

    Default Newbie here having problems!

    As shown on the title, I'm experiencing problems with my ego ctwist 900mah running on ce clero 2.4ohms and hangsen 12mg liquid. Im getting bad taste and very little vapor at 3.2v, while adjusting it at 3.8-4.0 gives me better flavour with burnt taste and tongue sting/throat roughy feeling. I tried to change to aquao's 12mg apple, it taste like burnt Paper and warm ..... Should I change my setup? Because I'm thinking to grab a set of tele mod + protank 2 but I'm afraid of even more hassle. Btw I'm living in sg so it's restricted here , getting it means crossing border for me 😞. Appreciated if someone could give some tips!!! 😊
    Vapoor eyes er likes this.

  2. #2
    Full Member Verified Member
    ECF Veteran
    wowoboi's Avatar
    Join Date
    Dec 2012
    Location
    GS
    Posts
    113

    Default

    Also after turning from analog to ecig, my sinus begun to surface more frequently, a very bad dry cough and phlegm build up.
    Vapoor eyes er likes this.

  3. #3
    PV Master Verified Member
    ECF Veteran
    WillyZee's Avatar
    Join Date
    Sep 2013
    Location
    Toronto
    Posts
    3,194

    Default

    Quote Originally Posted by wowoboi View Post
    Also after turning from analog to ecig, my sinus begun to surface more frequently, a very bad dry cough and phlegm build up.
    welcome to ECF ... this is common ... it will pass
    Smoke Free since Sept. 22nd 2013 ... Keep Calm & Vape On

  4. #4
    Full Member Verified Member
    ECF Veteran
    wowoboi's Avatar
    Join Date
    Dec 2012
    Location
    GS
    Posts
    113

    Default

    Um, actually I started vaping last year and I stopped after having some problems with my ego. I mean it wasn't as bad as this time..
    Vapoor eyes er likes this.

  5. #5
    Ultra Member ECF Veteran Recycled Roadkill's Avatar
    Join Date
    Oct 2013
    Location
    Garland, TX
    Posts
    1,201

    Default

    I'm thinking that it's about time to change out that coil.
    I've run into three things that adversly affect my EVODS.
    1. The wick in the coil has burned long enough to no longer wick in the liquid properly.
    2. A used up coil with pop and crackle producing little to no vapor.
    3. The battery gets low to the point where it doesn't produce the power to heat the coil properly.



    Well over Sixteen Thousand cigarettes NOT smoked and over $4000.00 savings in just 12 months. There's your milestone!

  6. #6
    Full Member Verified Member
    ECF Veteran
    wowoboi's Avatar
    Join Date
    Dec 2012
    Location
    GS
    Posts
    113

    Default

    Okay, firstly I've wasted 4 new ce, even with full charge and 0 noise. I still get the same effect or even worse. I feel like I've been cheated badly. :/. Ive tested with ego ctwist and ego c 1100mah, with twist I get even harsher throat. Im also an analog smoker for 5 years, really craving for analogs when this kind of situation pops up.
    Last edited by wowoboi; 10-20-2013 at 07:02 PM.
    Vapoor eyes er likes this.

  7. #7
    PV Master Verified Member
    ECF Veteran
    Supporting Member
    ShariR's Avatar
    Join Date
    Jun 2013
    Location
    Nashville, TN
    Posts
    7,767
    Blog Entries
    2

    Default

    Welcome to ECF wowoboi. Lots to learn and read here and plenty of people who can help you. I will try to give you a little help. Please tell us which specific clearomizer you have and if you have extra heads for it.

    Have you cleaned your clearo? Empty it and run it under hot running water from the faucet. Look up the exact type of clearo you have on Youtube for a video of how to clean your particular type. The video will show you how to do it. You may have to change the head, if you have one that can be changed.

    3.2 volts is too low to produce good flavor and vapor on a clearo that is 2.4ohms. You should be starting at around 3.7 or 3.8 ohms and adjust your volts up a bit at a time until the flavor is good. Turn it back down a bit if you get a burnt taste.

    You need to be drinking a lot of water. Vaping will dehydrate you. Drink more water, that will help with the cough and harshness. Vaping will also sometimes make your nose run and drip. It is the condensation from the vapor. What pg/vg ratio are your juices? High pg 80/20 will be a lot harsher that lower pg like 50/50. You can add a little vg to the juice but it will lessen flavor and nicotine and make it thicker.


    Your 900mah twist is a good battery. The clearo may be a good one. It depends on which one you have. Do a search in the following forum for your specific clearomizer. Good luck to you.



    http://www.e-cigarette-forum.com/for...s/clearomizers
    Last edited by ShariR; 10-20-2013 at 07:15 PM.
    mamalapuffala likes this.

    A Journey begins when you choose a Path

  8. #8
    PV Master Verified Member
    ECF Veteran
    Train2's Avatar
    Join Date
    May 2013
    Location
    CA, USA
    Posts
    6,585

    Default

    Trouble with flavor and burning is the CE's not the batteries.
    You might try an EVOD...lots of us like them far better...
    Burnie likes this.

  9. #9
    Full Member Verified Member
    ECF Veteran
    wowoboi's Avatar
    Join Date
    Dec 2012
    Location
    GS
    Posts
    113

    Default

    Okay, really appreciated for clarifying on the batt and clero!
    Vapoor eyes er likes this.

  10. #10
    Full Member Verified Member
    ECF Veteran
    wowoboi's Avatar
    Join Date
    Dec 2012
    Location
    GS
    Posts
    113

    Default

    I've been reading up, somehow come across that evod has problems in it? I find that lots of people are recommending the protank 2 or mini tank?
    Vapoor eyes er likes this.

Page 1 of 4 1234 LastLast

Tags for this Thread

Bookmarks