Itaste Mvp 2.0 settings question - Page 2
Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 33
Like Tree8Likes

Thread: Itaste Mvp 2.0 settings question

  1. #11
    Moved On Verified Member
    Join Date
    Oct 2013
    Location
    808 State
    Posts
    755

    Default

    Quote Originally Posted by packers29 View Post
    when I change the coil is there really a break in period before it gets up to full potential and full taste? and if so whats the right way to do that for the Iclear 30s

    I drip a very small drop on the coil itself before I fill up my tank. (remove the plastic cone, but be sure to put it back the same way; top slit for top wicks) After I fill the tank, I leave it on its side for about a minute, then rotate to the other side. Its tempting to go over the 3.0ml line but out of habit, I don't go past the top slit on the white rubber cone. Not to say you cant, but I've never had any experience with gurgling or flooding this way.

  2. #12
    Full Member Verified Member
    Join Date
    Oct 2013
    Location
    NOTTINGHAM ENGLAND
    Posts
    92

    Default

    I find with my i30s I have to leave them for a hour for the juice to get right up to the coil when there new you can also take a few draws on it with out pressing the fire button this will help to get the juice up also I lie mine flat when I put new coils in that puts juice on same level and helps it get to the coil faster I would say if you getting burnt taste with the i30 you will be at to high a setting I vape around 8-10 watts on a 2.0-2.4 ohm but you mite find you cant get it quite right with vv then try vw one way or the other you will get there and when you do you will love it try and get yourself a gene atty like rsst or a aga-t2 and try ss wick you will be amazed how nice the flavour is then I just started with my aga-t2 and im like a baby with a dummy its never out of my mouth now

  3. #13
    Super Member ECF Veteran
    Supporting Member
    Saltraker's Avatar
    Join Date
    Aug 2013
    Location
    Hannibal, Missouri
    Posts
    373

    Default

    Can't recommend pulling the center pin on the mod. It's connected to something on the inside and there's a risk of breaking whatever that something is. Also, pulling the pin can deform the insulator that it's riding in. I know from personal experience that the center pin doesn't always make contact with attached devices. I'm trying to solve the issue with my MVP right now. My next idea is to get a 510/510 adapter and see if that helps. Otherwise, I'm using my Spinners. It's a drag, but pulling on the MVP's center pin can't be a good idea.
    pufZeppelin likes this.

  4. #14
    Member
    Join Date
    Oct 2013
    Location
    michigan
    Posts
    8

    Default

    I don't know what happened but I added some watermelon flavored juice I have here to that apple one and it taste better now, no burnt taste as before. Is it possible it was just the juice the whole time. I have the watts set to 7.0 I believe because its 100% PG and doesn't taste good when its a very warm vape. I heard some people cut the strings that come out of the I30's coils to be shorter, what is the purpose of this? is it really necessary? on my replacement coils I have one so far where some of them are decently longer then the rest. Hope im not bugging you guys yet with all these noob questions.

  5. #15
    PV Master ECF Veteran DetraMental's Avatar
    Join Date
    Mar 2013
    Location
    United States
    Posts
    3,287
    Blog Entries
    9

    Default

    Excellent advice as always. Happy Vaping!!

    Have a sense of humor, keep a sense of humor, don't lose your sense of humor....

  6. #16
    Moved On Verified Member
    Join Date
    Oct 2013
    Location
    808 State
    Posts
    755

    Default

    Quote Originally Posted by Saltraker View Post
    Can't recommend pulling the center pin on the mod. It's connected to something on the inside and there's a risk of breaking whatever that something is. Also, pulling the pin can deform the insulator that it's riding in. I know from personal experience that the center pin doesn't always make contact with attached devices. I'm trying to solve the issue with my MVP right now. My next idea is to get a 510/510 adapter and see if that helps. Otherwise, I'm using my Spinners. It's a drag, but pulling on the MVP's center pin can't be a good idea.
    I agree 100%, as a matter of fact, if you have connection issues, I would recommend pulling the post on your attachment; its very simple to do, just insert small screwdriver or bent paperclip and gently wiggle the post out by a half a millimeter. That should solve your problem right away.
    Baycitypuff likes this.

  7. #17
    Super Member Verified Member
    ECF Veteran

    Join Date
    Aug 2013
    Location
    Chicago
    Posts
    943

    Default

    Quote Originally Posted by packers29 View Post
    Hey everyone, I just got an Itaste mvp 2.0. This is my first variable voltage/ wattage device, I come from the old school joye 510's. I have a question regarding settings though, I know you can adjust voltage and wattage, but on the Itaste if i adjust voltage do I need to change wattage too and vice versa or will it change on its own. I am confused about this part because when I tried that, the actual number settings doesnt change until I manually do it myself. Also I am trying to raise the center pin to fit some evod tanks but I cant find anything that'll fit in the small opening to get a hold of it and im nervous about bring it up to high or breaking the center washer that is there. When I connect the evod's its a constant burnt taste and an almost plasticy taste to it, and when I unscrew it off of the MVP there is a small amount of smoke that comes out of that area where the connection pin is. Is this because the center pin isn't making contact with the Evod's ?
    That problem has nothing to do with the height of the center pin. Always screw down a topper only until you feel slight resistance. Never over tighten. You're most likely getting a burning flavor because your EVODs arent wicking properly. You may have the voltage or wattage set too high. You may be vaping juice that's too thick.

  8. #18
    PV Master Verified Member
    ECF Veteran
    suspectK's Avatar
    Join Date
    Aug 2013
    Location
    somewherez
    Posts
    4,375

    Default

    Big factor in power needs is the type of coil and liquid. I use 8-11Watts with single coil cartomizers, 10-15 watts on dual coil cartomizers, 6-~10 watts on clearomizers dual or single, 5-6.5watts with bridged atomizers, 6-9watts on bridgeless atomizers, and RBAs have an extremely wide range for me.

  9. #19
    Member
    Join Date
    Oct 2013
    Location
    michigan
    Posts
    8

    Default

    Does anyone have any idea why the Evod tanks I bought aren't working on my mvp 2.0 I get a ohm reading of 2.2 I believe it was, I get vapor production but its just a constant burnt/plasticy almost taste every time. When I go to unscrew the Evod from the MVP there will be a little smoke coming from where it connects onto the mod. I have tried low volt settings and watt settings. I just want to be able to use the Evods without that horrible taste. I am nervous to mess around much with the center pin and mess up anything internally on the mvp 2.0

  10. #20
    Full Member ECF Veteran
    Join Date
    Sep 2013
    Location
    Bay city, mi
    Posts
    100

    Default

    Quote Originally Posted by Saltraker View Post
    Can't recommend pulling the center pin on the mod. It's connected to something on the inside and there's a risk of breaking whatever that something is. Also, pulling the pin can deform the insulator that it's riding in. I know from personal experience that the center pin doesn't always make contact with attached devices. I'm trying to solve the issue with my MVP right now. My next idea is to get a 510/510 adapter and see if that helps. Otherwise, I'm using my Spinners. It's a drag, but pulling on the MVP's center pin can't be a good idea.
    Had this problem on one of my mt3s. Just take needle nose pliers and slightly pull out the bottom pin on the tank. Vaping away.


    Sent from my iPhone using Tapatalk - now Free

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks