vivi nova burnt taste
Page 1 of 4 1234 LastLast
Results 1 to 10 of 38
Like Tree33Likes

Thread: vivi nova burnt taste

  1. #1
    Super Member nobreak1970's Avatar
    Join Date
    Oct 2013
    Location
    Hartford, Alabama USA
    Posts
    384

    Default vivi nova burnt taste

    Just got one and no matter what voltage and what resistence coil I use all burnt taste.
    Help?
    Ego-T vv battery.
    Vapoor eyes er likes this.

  2. #2
    Senior Member ECF Veteran quiter's Avatar
    Join Date
    Jul 2013
    Location
    hanging around
    Posts
    172

    Default

    It helps to put a couple drops right onto the coil and wait a while before vaping it. Also make sure to keep it relatively full. Most of the time the burnt taste is from it not getting juice. Tipping helps.
    Jean-Paul Sartre, “When the rich wage war, it’s the poor who die”

  3. #3
    Super Member ECF Veteran StarDose's Avatar
    Join Date
    Mar 2013
    Location
    Brampton
    Posts
    835

    Default

    Sounds like a bad coil if you haven't used it before. Bad coils aren't uncommon for any premade heads unfortunately.
    Currently vaping on my nemesis/kfl setup

  4. #4
    Super Member nobreak1970's Avatar
    Join Date
    Oct 2013
    Location
    Hartford, Alabama USA
    Posts
    384

    Default

    trying it at 3.7 volts 3ohms
    Vapoor eyes er likes this.

  5. #5
    Super Member nobreak1970's Avatar
    Join Date
    Oct 2013
    Location
    Hartford, Alabama USA
    Posts
    384

    Default

    seems better by not having the thing sinched way down on battery. spring loaded.
    Vapoor eyes er likes this.

  6. #6
    Super Member nobreak1970's Avatar
    Join Date
    Oct 2013
    Location
    Hartford, Alabama USA
    Posts
    384

    Default

    4.2v at 3.x ohms seems ok. hmmm
    Vapoor eyes er likes this.

  7. #7
    PV Master Team ECF (folding@home)
    Verified Member
    ECF Veteran
    Supporting Member
    Ryedan's Avatar
    Join Date
    Mar 2012
    Location
    Brampton, Canada
    Posts
    7,264

    Default

    Is 3.0 ohm the head you started with?

  8. #8
    Super Member nobreak1970's Avatar
    Join Date
    Oct 2013
    Location
    Hartford, Alabama USA
    Posts
    384

    Default

    no 2.4
    I think I had it screwed too tight

    Trying the 1.8ohm again.
    Last edited by nobreak1970; 10-30-2013 at 12:01 AM.
    Vapoor eyes er likes this.

  9. #9
    Super Member nobreak1970's Avatar
    Join Date
    Oct 2013
    Location
    Hartford, Alabama USA
    Posts
    384

    Default

    SOLVED: don't tighten the head too tight on these things.
    Jolly rancher is goooooood!
    Vapoor eyes er and Ryedan like this.

  10. #10
    Super Member nobreak1970's Avatar
    Join Date
    Oct 2013
    Location
    Hartford, Alabama USA
    Posts
    384

    Default

    OK perfect: 4.2v at 3.0 ohms.
    Vapoor eyes er likes this.

Page 1 of 4 1234 LastLast

Tags for this Thread

Bookmarks