Terrible kit experience - Page 3
Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 35
Like Tree5Likes

Thread: Terrible kit experience

  1. #21
    Ultra Member Verified Member
    ECF Veteran
    Ref Minor's Avatar
    Join Date
    May 2013
    Location
    UK
    Posts
    2,474

    Default

    Try this, it works for the Protank 1: take the rubber seal ring from one of your used heads that fits over the stem like this =] then add it to the stem of the head you are using so it looks like this =][ with 2 rings

    I hope that makes sense.
    Just because you are offended doesn't mean you are right.

  2. #22
    PV Master Verified Member
    ECF Veteran
    Nikkita6's Avatar
    Join Date
    Oct 2011
    Location
    New York
    Posts
    6,490
    Blog Entries
    6

    Default

    Quote Originally Posted by Stroupe View Post
    This is my first post! But anyways, I recently just bought a new setup from a local vape shop here in Knoxville. I got the Vamo v3 with the Kanger Protank 2. The vamo 510 threading is terrible, period. My cartos and tanks wouldnt screw in properly or even screw in at all. Took it back and got a new one and it's doing it also. And now my pro tank is gurgling and leaking in the mouthpiece terribly, but only when half full. If it's full it works fine. Which is rediculous. I love Knoxville vapor and they are great people and I'm not blaming them at all.
    I am very surprised to hear this about a Vamo, as I have not heard any such thing before ... are you sure it was authentic?? Or maybe you bought the kind made from Aluminum Alloy, which is a softer metal?? I have seen these on Fasttech ... I can't imagine what you described happening on stainless steel or chromed brass.

    I hope you didn't pay a lot for it, and I don't believe that your experience is typical. And I have read several ppl reporting a gurgling Protank @half full, but mine don't do this. I frequently vape until almost empty.

  3. #23
    Full Member Verified Member
    Join Date
    Oct 2013
    Location
    Sacramento, CA
    Posts
    39

    Default

    What type of fluid are you using? If its high VG and the ambient temperature is warm it can cause flooding, used to happen all the time to my Evod's this past summer and that was even with a 50/50 mix, moved up to 70/30 and the flooding went away. I think the Kanger heads as small as they are could use another strip or two of flavor wick, especially with higher VG juices.

    Edited to add: Also could occur after vaping for a while if the head/tank is getting to warm from heavy vaping as the heat will thin out the liquid.
    Last edited by Blu916; 11-02-2013 at 01:46 AM.

  4. #24
    Full Member
    Join Date
    Nov 2013
    Location
    Knoxville, Tennessee
    Posts
    19

    Default

    It's definitely authentic and you can google "vamo threading issues" and see it everywhere.

  5. #25
    Full Member
    Join Date
    Nov 2013
    Location
    Knoxville, Tennessee
    Posts
    19

    Default

    Quote Originally Posted by Blu916 View Post
    What type of fluid are you using? If its high VG and the ambient temperature is warm it can cause flooding, used to happen all the time to my Evod's this past summer and that was even with a 50/50 mix, moved up to 70/30 and the flooding went away. I think the Kanger heads as small as they are could use another strip or two of flavor wick, especially with higher VG juices.
    I've been using unicorn blood and ectoplasm both 0 nicotine. From fuzion vaporz

  6. #26
    Ultra Member Verified Member
    ECF Veteran
    Supporting Member
    meanckz's Avatar
    Join Date
    Sep 2013
    Location
    Greer, SC
    Posts
    1,375

    Default

    I'm so sorry you having such issues with pro tank, I have the one 1 and the 2 and a bunch of mini pro tanks...only time I ever had issues was when I had non kanger coils

    Keep up the good vape!
    since 6/26/2013

  7. #27
    Full Member
    Join Date
    Nov 2013
    Location
    Knoxville, Tennessee
    Posts
    19

    Default

    Yeah I have no clue what's wrong. My brother bought one too at the same time as me and his works fine. It's all kanger for sure. Came In kanger box still wrapped in plastic

  8. #28
    Ultra Member Verified Member
    ECF Veteran
    mackman's Avatar
    Join Date
    Aug 2013
    Location
    NorCal
    Posts
    1,603

    Default

    Quote Originally Posted by Stroupe View Post
    This is my first post! But anyways, I recently just bought a new setup from a local vape shop here in Knoxville. I got the Vamo v3 with the Kanger Protank 2. The vamo 510 threading is terrible, period. My cartos and tanks wouldnt screw in properly or even screw in at all. Took it back and got a new one and it's doing it also. And now my pro tank is gurgling and leaking in the mouthpiece terribly, but only when half full. If it's full it works fine. Which is rediculous. I love Knoxville vapor and they are great people and I'm not blaming them at all.
    Chinese mods= poor/cheap threading that's all.

    Lately it occurs to me, what a long strange trip it's been

  9. #29
    Full Member Verified Member
    Join Date
    Oct 2013
    Location
    Sacramento, CA
    Posts
    39

    Default

    Quote Originally Posted by Stroupe View Post
    I've been using unicorn blood and ectoplasm both 0 nicotine. From fuzion vaporz
    Do you know what the PG/VG ratio's are?

  10. #30
    Super Member Verified Member CABBA's Avatar
    Join Date
    Oct 2013
    Location
    Thailand
    Posts
    363

    Default

    Buy a provari.


    Sent from my iPad using Tapatalk

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks