Kanger EVOD problem!
Results 1 to 6 of 6
Like Tree4Likes
  • 1 Post By Metsmafia
  • 1 Post By SupplyDaddy
  • 1 Post By Mark Anthony
  • 1 Post By vansslipon

Thread: Kanger EVOD problem!

  1. #1
    Full Member ECF Veteran
    Join Date
    Nov 2009
    Location
    Tallinn, Estonia
    Posts
    118

    Default Kanger EVOD problem!

    So... I lost my eGo on my way to work, probably droped from my pocket in a train. So I went and grabbed some quick "replacement" . I use to drip onto 510 atty but they didnt have one. I bought evod with a twist battery, my first clearo ever.
    I always get a dry hits after few puffs even on 3.8v. Any possible way to fix it? I figured out that blowing inside between the puffs helps sometime but still flavor is too weak. I use 50/50 vg/pg maybe its too thick or should i remove top wick?

  2. #2
    Full Member Verified Member
    ECF Veteran
    Metsmafia's Avatar
    Join Date
    Apr 2013
    Location
    Jersey
    Posts
    84

    Default

    Remove the top wick and try flipping the washer on top of the coil upside down. 50/50 should be fine that's all I vape.
    vansslipon likes this.

  3. #3
    Ultra Member Verified Member
    ECF Veteran
    SupplyDaddy's Avatar
    Join Date
    Oct 2012
    Location
    San Antonio, Texas
    Posts
    1,884

    Default

    Remove one or both of the flavor wicks, located under the coils stem.
    vansslipon likes this.

  4. #4
    PV Master Verified Member Mark Anthony's Avatar
    Join Date
    Oct 2013
    Location
    Scranton, Pa USA
    Posts
    3,040

    Default

    Quote Originally Posted by SupplyDaddy View Post
    Remove one or both of the flavor wicks, located under the coils stem.
    This should do the trick.... if you can, drop a few drops of juice on them before assembling.
    vansslipon likes this.

  5. #5
    Full Member ECF Veteran
    Join Date
    Nov 2009
    Location
    Tallinn, Estonia
    Posts
    118

    Default

    Quote Originally Posted by SupplyDaddy View Post
    Remove one or both of the flavor wicks, located under the coils stem.
    Okie! Sooo... There is 2 packs of wicks about 4 in each, cant tell as they all juiced at the moment. One pack on top and one wraped with coil. Should i remove pack of them or just few of a small ones??? Bit confused sorry

  6. #6
    Full Member ECF Veteran
    Join Date
    Nov 2009
    Location
    Tallinn, Estonia
    Posts
    118

    Default

    Thanks a lot!
    Dryed it up and saw 2 wicks... Removed one and damn its good now! Works like a charm! Btw fliping ruber "ring" on top of atty made it fluid bit too much... No dry hits even at 4.8v.
    Thank you once again!
    Last edited by vansslipon; 11-07-2013 at 09:05 PM.
    SupplyDaddy likes this.

Tags for this Thread

Bookmarks