Page 1 of 2 12 LastLast
Results 1 to 10 of 15
Like Tree5Likes

Thread: Stumped with my MVP 2.0

  1. #1
    Full Member Team ECF (folding@home)
    Verified Member
    AgeAgainst's Avatar
    Join Date
    Sep 2013
    Location
    Las Vegas, Nevada, United States
    Posts
    50

    Default Stumped with my MVP 2.0

    Hey gang!

    Got my MVP 2.0 and my Protank II in the mail today. I was in a rush to meet up with someone for dinner so I just put my Mini Protank II v2 on it and walked out the door. Was getting nice big clouds, good hits and was extremely happy. Finally got home and filled up the PT II and no big clouds, no good hits. Did some research for changing the watts and came up with what I thought I understood to be as such:

    Mini PT II (1.8 coil) reads: A2.1/U4.0. So, (4*4)/2.1 = 7.619... Rounded up to 8 watts. Result: Good smoke/hits
    PT II (2.2 coil) reads: A2.4/U4.0. So, (4.4)/2.4 = 6.66... Rounded up to 7 watts. Result: Weak smoke/hits

    The driptip on my PT II seems kind of loose (some wiggle to it) whereas the driptip on the Mini PT fits solid. Also - it seems like I can't get a good draw in through the PT II, but a good draw through the Mini PT.

    In fairness, I am using two different flavor liquid (same manufacturer) - not sure if this affects anything.

    Am I doing something wrong with this? I did get a 5 pack of the 2.2 coil replacements for the PT, should I switch both tanks to the 2.2 coils?

    Absolutely baffled and would appreciate any guidance.

    Thanks in advance!

  2. #2
    PV Master Verified Member suspectK's Avatar
    Join Date
    Aug 2013
    Location
    somewherez
    Posts
    3,601

    Default

    Different flavors may require different power levels.
    stylezuk likes this.

  3. #3
    Senior Member Iquitcigs's Avatar
    Join Date
    Oct 2013
    Location
    Kent uk
    Posts
    255

    Default

    did you prime the pro tank the heads won't make a lot of difference with mvp v2 as you can alter your watts and volts if you didn't prime let it sit for bit with the juice in it and try again if it still docent work take it apart and check everything make sure all the o rings are in the right places blow the head out on to a paper towel it could be flooded then reassemble and try again

  4. #4
    Full Member Verified Member SweptEdge's Avatar
    Join Date
    Nov 2013
    Location
    USA
    Posts
    88

    Default

    I have been changing between an iClear30 and Protank 3 using the same voltage and watts on my Mvp 2.0. I have it set to 4.2 volts and 9 watts

  5. #5
    Senior Member Utew's Avatar
    Join Date
    Sep 2013
    Location
    Eugene, OR
    Posts
    167

    Default

    ProTanks (and all the Kangers) can be a bit problematic sometimes.

    A lot depends on the viscosity of the juice as to how well they wick and how fast they wick. High VG content can be difficult, high PG content may be easier, due to it being thinner. I run 100% VG in one of my ProTank 2's, but I have to remove one of the flavor wicks (in the head) to do it.

    On a new tank, be sure to wash it well before use. Fill your tank.. and prime the head, this helps in my experience. Unscrew the head from the tank, drop a couple of drops of eliquid on the wicks, both sides... then screw the head back in. This may be enough.

    If you do go to remove a flavor wick (two flavor wicks set on top of the main wick with the coil around it). I suggest doing it when it is wet with eliquid, use tweezers and remove about half of one wick (the topmost wick) and see how it is vaping at that point.
    Last edited by Utew; 11-30-2013 at 03:07 PM.
    AgeAgainst likes this.
    " All those moments will be lost in time... like tears in rain..."

  6. #6
    Member
    Join Date
    Nov 2013
    Location
    Moreno Valley, California, United States
    Posts
    2

    Default

    the kanger protank 3 is kind of a pain....It works great at home, but when i go out or have a hard day at work it likes to flood on me lol

  7. #7
    Ultra Member
    Join Date
    Aug 2013
    Location
    Venice, FL
    Posts
    1,061

    Default

    Never had any luck with Kanger heads, never reliable. I run the MVP 2 in wattage mode, so I don't have to concern myself with the voltage. 8 watts is 8 watts, regardless of the atomizer. Good luck and have fun!

  8. #8
    Full Member Team ECF (folding@home)
    Verified Member
    AgeAgainst's Avatar
    Join Date
    Sep 2013
    Location
    Las Vegas, Nevada, United States
    Posts
    50

    Default

    Thank you all for the tips and advice. I didn't wash the tank out prior to using it but I did prime the head a few times. I'm letting all the parts soak in water overnight and will put in a new head and see how it comes along.

  9. #9
    Super Member Verified Member Ian444's Avatar
    Join Date
    Oct 2013
    Location
    QLD, Australia
    Posts
    650

    Default

    AA, just a tip, when you press both buttons to read the coil resistance, the voltage that is displayed after the coil resistance is the voltage of the battery, not the voltage you have set if you're in VV mode. Its not very clear in the instructions.

    When you're in variable wattage mode, both PT's should be getting the same power regardless of the coil resistance.

    If you last changed the voltage, then its in variable voltage mode, if you last changed the wattage, then it goes into variable wattage mode.

    Possibly just a coil replacement will get the PT going.

  10. #10
    Ultra Member Verified Member
    ECF Veteran
    denali_41's Avatar
    Join Date
    Aug 2011
    Location
    Over Der
    Posts
    2,877

    Default

    different resistance,different juice,different power settings
    THE MORTAR........ Solid Brass construction with copper post contacts.just pure raw power !!!!

Page 1 of 2 12 LastLast

Bookmarks