Page 1 of 5 12345 LastLast
Results 1 to 10 of 42
Like Tree93Likes

Thread: Is this right?

  1. #1
    Super Member Verified Member
    ECF Veteran

    Join Date
    Apr 2013
    Location
    Las Vegas, NV, USA
    Posts
    528

    Default Is this right?

    So I noticed today my 510 connection doesn't look properly made. I noticed cause my reomizer isn't exactly sitting leveled. I was admiring the beauty and saw a lip then looked on the inside



    Sent from my SGH-T999 using Tapatalk 2

  2. #2
    REOnaughty Verified Member
    ECF Veteran
    Supporting Member
    Statistic's Avatar
    Join Date
    Apr 2013
    Location
    United States
    Posts
    2,102

    Default

    Not sure what you mean, Tim.. looks normal to me.

    Are you saying your atty is crooked when it's on the mod? If so can you post up a pic of it on the mod?
    malkuth likes this.


    REO Grand - Paying Homage with my Ohmage

  3. #3
    Registered Supplier - Offline ECF Veteran pdib's Avatar
    Join Date
    Nov 2012
    Location
    Seattle
    Posts
    8,291

    Default

    To me it looks like the positive (center) piece is misshapen? (wrongshapely?) (squeezed with needlenose?)
    malkuth likes this.

  4. #4
    Proud REOnaut Verified Member
    ECF Veteran
    Supporting Member
    JC Okie's Avatar
    Join Date
    Jul 2010
    Location
    Tulsa, OK
    Posts
    4,888

    Default

    Tim, it looks funny to me, too. It looks like the connector part (all the metal looking area) is sunk in too far. On all of my REOs, the SS rim of that part sticks above the colored aluminum a tiny bit...maybe 1 mm. It's not flush with the colored aluminum like yours appears to be.

    I don't know if it will hurt anything or not....but after checking all my REOs, that's what looks different. It could be some new connector Rob is using?? I'd PM redeyedancer and simply ask him. Or....he'll see your picture the next time he pops on the forum and I'm sure he'll have an answer.
    Last edited by JC Okie; 08-04-2013 at 07:29 PM.
    Della Cirque and malkuth like this.
    Using various REOs with various RM2s and LOVIN' it!



  5. #5
    ECF Guru Verified Member
    ECF Veteran
    Supporting Member
    unsure's Avatar
    Join Date
    Feb 2010
    Location
    Silicon Valley, California
    Posts
    16,631

    Default

    Is it new?


  6. #6
    Proud REOnaut Verified Member
    ECF Veteran
    Supporting Member
    JC Okie's Avatar
    Join Date
    Jul 2010
    Location
    Tulsa, OK
    Posts
    4,888

    Default

    It's brand new from Rob's site.....I'm pretty sure. I went back and checked and I think he ordered it straight from Reosmods. Gil, doesn't it look like it's been pushed down in too far? If he got it from classifieds, I'd say someone pounded it in......
    unsure and malkuth like this.
    Using various REOs with various RM2s and LOVIN' it!



  7. #7
    ECF Guru Verified Member
    ECF Veteran
    Supporting Member
    unsure's Avatar
    Join Date
    Feb 2010
    Location
    Silicon Valley, California
    Posts
    16,631

    Default

    Quote Originally Posted by JC Okie View Post
    It's brand new from Rob's site.....I'm pretty sure. I went back and checked and I think he ordered it straight from Reosmods. Gil, doesn't it look like it's been pushed down in too far? If he got it from classifieds, I'd say someone pounded it in......
    Yeah it does look a little deformed but I have no metal REOs to compare. Looking at my woods and they don't have that crimped look.....and does it matter if its working with no issues.
    malkuth likes this.


  8. #8
    Proud REOnaut Verified Member
    ECF Veteran
    Supporting Member
    JC Okie's Avatar
    Join Date
    Jul 2010
    Location
    Tulsa, OK
    Posts
    4,888

    Default

    Well....he says the RM2 sits a little wonky.....and it's more than the center pin that I'm talking about. The whole connection piece is pushed down into the body too far. Take your atty off and you can feel the rim of the connector. In fact, on all of mine (both woodvils and metals) I can definitely feel the rim of the connector stick up, and it actually collects gunk (dried juice) and I have to clean around it with a q-tip. With his, the whole round connection piece is pushed down below the edge of the aluminum hole it sits in. Am I seeing things? All of mine have a tiny lip.....none of them is flush with the aluminum of the body.

    It's hard to tell with a picture....even a great close-up.....because it could be an optical illusion of sorts. It looks one way to me. I wish I could FEEL of it....or I wish Tim would come talk to us......
    Last edited by JC Okie; 08-04-2013 at 07:47 PM.
    Using various REOs with various RM2s and LOVIN' it!



  9. #9
    Registered Supplier - Offline ECF Veteran pdib's Avatar
    Join Date
    Nov 2012
    Location
    Seattle
    Posts
    8,291

    Default

    Yep, the whole 510 is sitting low, too, Jan.
    malkuth likes this.

  10. #10
    ECF Guru Verified Member
    ECF Veteran
    Supporting Member
    unsure's Avatar
    Join Date
    Feb 2010
    Location
    Silicon Valley, California
    Posts
    16,631

    Default

    Rob checks here often so may show up soon...or just PM him with the pic.


Page 1 of 5 12345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •