Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Vamo V3 won't turn on.

  1. #1
    Ultra Member Verified Member
    Join Date
    Jun 2013
    Location
    Michigan
    Posts
    1,566

    Default Vamo V3 won't turn on.

    So I just got a vamo v3 in the mail today. I charged up 2 aw imr flat top 18350 and put one in. I clicked the center button 5 times and nothing! Am I missing something? I already contacted the vendor.

  2. #2
    Vape 4 Life Verified Member
    ECF Veteran
    Supporting Member
    Talyon's Avatar
    Join Date
    Feb 2013
    Location
    Toronto
    Posts
    2,964
    Blog Entries
    2

    Default

    Are those batteries chemically protected?

  3. #3
    Ultra Member Verified Member
    Join Date
    Jun 2013
    Location
    Michigan
    Posts
    1,566

  4. #4
    Super Member Verified Member
    ECF Veteran
    HughDaHand's Avatar
    Join Date
    Nov 2012
    Location
    Swartz Creek, MI
    Posts
    599

    Default

    Maybe they are not making good contact inside. Try using both battery's stacked or an 18650 if you have it, if that works you can stretch the spring out a little for better contact.

  5. #5
    Ultra Member Verified Member
    ECF Veteran
    Supporting Member
    terry w's Avatar
    Join Date
    Sep 2012
    Location
    manchester uk
    Posts
    2,695

    Default

    Quote Originally Posted by Jazzi Mike View Post
    So I just got a vamo v3 in the mail today. I charged up 2 aw imr flat top 18350 and put one in. I clicked the center button 5 times and nothing! Am I missing something? I already contacted the vendor.
    It could be something as simple as pressing the button 6 or 7 times instead of 5.
    I sometimes have to do it on my v2.
    Worth a try.
    Bagua, Tvs all brass, nemesis, Caravela, Chi-you, Atom, I Atty, Trident, 3 x kayfuns 3.1, 2 x russian 91%.

  6. #6
    Super Member Verified Member
    ECF Veteran
    GetVaked's Avatar
    Join Date
    May 2011
    Location
    Central Texas
    Posts
    745

    Default

    Try stretching your spring out.
    Vaping: TimeBomb - Julius, SuicideBunny - Mothers Milk, AVE - Bobas Bounty.




  7. #7
    Ultra Member Verified Member
    ECF Veteran
    jnnfrlsw's Avatar
    Join Date
    Dec 2009
    Location
    East Central Ind
    Posts
    1,233

    Default

    Stretching out the string took care of the problem with my vamo. Also, try using another battery-could have got a bad battery or make sure its fully charged. just got a new SVD mod yesterday and am having a hard time with it doing the same. I had to keep clicking it several times and it finally came on. Ecigs are quirky sometimes.

  8. #8
    Full Member
    Join Date
    May 2013
    Location
    North of the wall
    Posts
    102

    Default

    I don't know if the V3 does the same thing as the V2, but on my V2 when you screw the bottom battery cap on the display blinks twice when it recognizes the battery. If it's not doing this it may not be receiving power.

  9. #9
    Ultra Member Verified Member
    Join Date
    Jun 2013
    Location
    Michigan
    Posts
    1,566

    Default

    The screen is not turning on at all.

  10. #10
    Ultra Member Verified Member
    ECF Veteran
    SupplyDaddy's Avatar
    Join Date
    Oct 2012
    Location
    San Antonio, Texas
    Posts
    1,691

    Default

    Turn the battery around....

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •