Bad USB on Zues
Results 1 to 4 of 4
Like Tree7Likes
  • 3 Post By sal997
  • 2 Post By Morandir835
  • 1 Post By BHam
  • 1 Post By oO_Gab727_Oo

Thread: Bad USB on Zues

  1. #1
    Full Member
    Join Date
    Jan 2010
    Location
    Riverview Mich usa
    Posts
    69

    Default Bad USB on Zues

    I have Zues that I got in April. The USB is intact but lately it seems loose. When I plug it in the light will switch from green to red or go out completely until I move it around. I love my Zues so I called CS to ask about it. They are sending me a new one. The girl I talked to was very nice and considerate. As always a great experience with V4L and it's service people. Thank you all.
    Amraann, BHam and Heden Aklowd like this.

  2. #2
    Idiot Guru ECF Veteran
    Supporting Member
    Morandir835's Avatar
    Join Date
    Jan 2011
    Location
    Greenbelt, MD
    Posts
    11,227
    Blog Entries
    5

    Default

    Glad cs took care of it for you Sal sir.
    BHam and Heden Aklowd like this.
    "Everyone loves a revolution, all the liberty they bring, everyone loves a revolution, one man's chain is another man's key, you never know what you'll get when tyrants fall... A revolution just a circle after all."- ilyAIMY "Revolutions Per Minute"

  3. #3
    Supplier Associate ECF Veteran BHam's Avatar
    Join Date
    Aug 2011
    Location
    Chicago, IL
    Posts
    3,633

    Default

    +1 to what Morandir said !
    Heden Aklowd likes this.

  4. #4
    Supplier Associate ECF Veteran
    Join Date
    Aug 2013
    Location
    Northbrook, Ill, USA
    Posts
    204

    Default

    Hi Sal! Hope everything is going well with the new one!
    Heden Aklowd likes this.

Bookmarks