just got my new Magma kit...is it broken?
Results 1 to 5 of 5

Thread: just got my new Magma kit...is it broken?

  1. #1
    Senior Member* ECF Veteran gearjunky's Avatar
    Join Date
    Dec 2012
    Location
    illinois
    Posts
    170

    Default just got my new Magma kit...is it broken?

    I just got my new magma kit from the blowout cyber sale....when I go to put a battery inside the pcc im supposed to just push the battery down into the charger until it simply clicks into place for charging HOWEVER my batts are not pressing easily down correctly...seems I have to fiddle with the battery and turn it and twist it around some before I can push it down into position. this doesn't seem to be correct. I have watched the magma kit video quite a few times to be sure of the process, and one of the things I liked about the magma kit was that you didn't have to screw down the batteries anymore to the charger. what's up with my magma charger kit guys? I really have to turn and twist and noodle the batts to get it to the excact position to be clicked/pushed down into the charger hole correctly for charging. I have tried all 3 of my batteries...all do the same thing...its already a hassle to use this kit...

  2. #2
    Forum Supplier ECF Veteran JoeInferno's Avatar
    Join Date
    Oct 2010
    Location
    Honolulu, HI
    Posts
    980

    Default

    Aloha gearjunky,

    I an very sorry to hear you are having issues with the batteries snapping into the PCC for charging. Some times they can be a bit tight when first new, making it a bit hard to snap in. Normally after a few days of use they loosen up a little, and begin to snap in just fine with no fiddling. Please give it a day or so and see if it gets better. If not please contact our CS team and we will make it right for you.
    Let the Lava Flow!
    http://www.volcanoecigs.com/

  3. #3
    Senior Member* ECF Veteran gearjunky's Avatar
    Join Date
    Dec 2012
    Location
    illinois
    Posts
    170

    Default

    ya, I just messed around with it again...and I put a battery in the slot and gave it a better/firmer push down and it snapped into place more easily. apparently I wasn't pressing down hard enough....I didn't want or think that I would have to press it down that hard from the get go...ya, hopefully it will loosen up some over time...ALSO GOT MY NEW LAVATUBE 2.5 KIT....LOOKS AWESOME, BUT IM NOT GONNA USE IT YET...waiting until Christmas...as a gift to myself (if I can wait that long)...lol.

  4. #4
    Forum Supplier ECF Veteran JoeInferno's Avatar
    Join Date
    Oct 2010
    Location
    Honolulu, HI
    Posts
    980

    Default

    good to hear it is working a bit better now for you.

    Good luck lasting till Christmas..... I know its sitting there calling your name....LOL
    Let the Lava Flow!
    http://www.volcanoecigs.com/

  5. #5
    Senior Member* ECF Veteran gearjunky's Avatar
    Join Date
    Dec 2012
    Location
    illinois
    Posts
    170

    Default

    lol....ya, it's calling out - VAPE ME !!!

Bookmarks