1. Deeming is here... Mitch Zeller to make an announcement at 8.45am EST. We're liveblogging it at vaping.com. Stay tuned for the announcement and reaction to the most significant event in vaping for 6 years...
    Dismiss Notice

Any ideas on this Crystal Vision issue?

Discussion in 'Nhaler' started by taylormomto6, Sep 17, 2013.

Tags:
Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. taylormomto6

    taylormomto6 Full Member

    Sep 15, 2010
    California
    First let me say, I LOVE LOVE LOVE Nhaler and buy all my hardware here with no issues :)

    I've been vaping crystal vision carts on my igo's for a while with no issues. I have the old igos as well as a revolver and a couple of Echos as well. I used the originals, then bought some rebuildables for both the igo and the echo.

    Problem is, some of them won't work on my older igo's now. I know I had used at least one of them on those batts before. I have 3 or 4 that will work on my Revolver, but not on my others. 2 are rebuildables, one isn't. It seems like a connection issue. I tried slightly lifting the battery post, but still no connection. They all connect fine to the Revolver. I recently bought a new one for the Echo that works just fine on the all my batts.

    Any ideas?

    Thanks, Cindy T
     
  2. Drewsworld

    Drewsworld Resting In Peace

    Mar 14, 2009
    New Jersey
    Try pulling on the post of the Cartomizer...I had this happen once and then it corrected itself somehow? I thought I was just nuts that day but who knows....I am relieved that you posted it! I dont feel so crazy alone anymore!
     
  3. taylormomto6

    taylormomto6 Full Member

    Sep 15, 2010
    California
    Ha! No, you're not crazy, at least not on this issue:p

    I tried your suggestion, but still nothing. When I get a few minutes, I'm going to work on it some more.

    Its baffling to me that they all work on the igo Revolver, but not the 3 other igos. Also, the one I had for the Echo doesn't work on anything but the Revolver, but the new one I just bought for the Echo works on everything:confused:

    I know damn well I was using some of those on those igos!

    I'll update if I figure something out.

    Cindy T
     
  4. taylormomto6

    taylormomto6 Full Member

    Sep 15, 2010
    California
    Ok, I got them working, except the non rebuild able echo.

    I had some older 2.4 coil heads that I'd cleaned and put away when I put in my newer 1.8s. Apparently my igos don't like the 1.8s. I'm not sure why, but they work fine on all 3 igos once I put the 2.4s back in. Guess I'll be ordering some 2.4s very soon :)

    Cindy
     
Thread Status:
Not open for further replies.

Share This Page