1. Win Vaping gear! The ECF 15 Millionth Post contest

    We are fast approaching the 15 millionth ECF post and we have a contest to celebrate this huge landmark and amazing prizes to give out to our members! Head over to the official contest thread to see the rules and check out the prizes generously pledged by our registered suppliers on the prize announcement thread.

Blinking blue light

Discussion in 'New Members Forum' started by Lorenzal, May 21, 2013.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Lorenzal

    Lorenzal Full Member Verified Member

    Joined:
    May 15, 2013
    Location:
    Singapore
    Hi All ,

    Need your help on this issue. My Ego has this weird problem today. When i press the blue button to start vaping , it blinks for a few times then stops...It doesnt fires up the juice...no smoke is coming when i vape...

    I thought it was the battery issue , so i charged it for a couple of hours and try...Still no luck

    When i detached the top part ( the one that contains the juice ) and just leave the battery and press the blue button , it will continue to light up until i let go...

    My apologies in advance i dont get the part name right...
     
  2. SpiritBear

    SpiritBear Senior Member ECF Veteran

    Joined:
    Apr 29, 2013
    Location:
    Maricopa Co, Arizona, USA
    To turn an eGo on, you press the blue button 5 times fairly quickly -- the button will then blink blue 3 or 4 times. To turn it off, you again press the button 5 times fairly quickly, and again the button will blink blue 3 or 4 times. Is it possible that when you thought you were turning it on, you actually turned it off?

    Sorry if you already tried this -- I'm still pretty new myself and it this doesn't work, hopefully someone will come along who has a better idea!
     
  3. lilmrsyeti

    lilmrsyeti Super Member Verified Member ECF Veteran

    Joined:
    Mar 17, 2013
    Location:
    Alabama
    What type of "tank" are you using...Nova, Cart, Kanger? Have you tried using a different tank on it to see if that will work? Sounds like maybe you are getting a short?
     
  4. juddyau

    juddyau New Member

    Joined:
    Feb 16, 2013
    Location:
    Western Australia
    Agreed, could well be a bad connection. Maybe try pulling the centre pin out of whatever carto etc you are attaching to the eGo.
     
  5. Patrick O'Brien

    Patrick O'Brien Senior Member Verified Member ECF Veteran

    Joined:
    May 13, 2013
    Location:
    MN

    This actually just happened to me. Take the tank off the battery and take a q-tip to clean both the battery head (gently) and the underside of the tank.There is a little pin/gold pad inside the battery you can see, clean that off. Liquid and moisture get down in there and cause a short, which is why it blinks. The blinking means its self protection mode has been activated. If that doesnt fix it, your tank may be clogged causing airflow issues, which can also overheat the battery. You should always clean your battery heads, as well as the charger part where the battery connects. It really prolongs the life of your equipment.
     
  6. Patrick O'Brien

    Patrick O'Brien Senior Member Verified Member ECF Veteran

    Joined:
    May 13, 2013
    Location:
    MN
    Dont try pulling the pin out either. If it was down too far, it wouldnt fire at all, let alone short out................nor would it charge. Just gently clean the pin and check for any debris or buildup. That should do the trick everytime.
     
  7. Lorenzal

    Lorenzal Full Member Verified Member

    Joined:
    May 15, 2013
    Location:
    Singapore
    Hi All , thank you for the nice suggestions...after much googling , lifting out the battery and pulling that pin out it still does not work...

    I found out the charger was the faulty one! It keeps showing Green LED but and wont charge..i borrowed another charger and yes it is showing red and in a few hours i was vaping again...

    Thank you all again for the great help and advise!!
     
Thread Status:
Not open for further replies.

Share This Page