Ce4 Clearomizer Not working?

Discussion in 'New Members Forum' started by EXTRAKTER, Jan 9, 2013.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. EXTRAKTER

    EXTRAKTER New Member

    Joined:
    Jan 9, 2013
    Location:
    United States
    Ok, So I have a Ce4 clearomizer attached to an Ego-T battery. The battery has charge but whenever I attach the tank to it and try and press the button to inhale it just flashes 3 times in a row. My friend has the same tank and battery and when I attach his tank to my battery it vapes just fine. So I have narrowed it down to being the tank that has the issue. So how do I fix this I just got this a day ago. Someone please help me out.
    -Thanks in advance.
     
  2. b16 n47h

    b16 n47h Full Member

    Joined:
    Jan 6, 2013
    Location:
    crewe, cheshire, uk
    It could be shorting. check the conections and the base if that doesnt help have a look at the coil and check the wiring. was it like this from new if so id contact your vendor.
     
  3. telijah

    telijah Senior Member Verified Member ECF Veteran

    Joined:
    Dec 18, 2012
    Location:
    Tampa, FL
    Make sure the atty head is screwed on tightly as well. I know that happens with my CE5, I think the CE4 has the same removable atty heads...
     
  4. EXTRAKTER

    EXTRAKTER New Member

    Joined:
    Jan 9, 2013
    Location:
    United States
    Yeah I think it is shorting but how would I go about fixing something like that. How would you disassemble to check wiring? I can't take it to the vendor right now cause I got it at a flee market and they are not open during the weekdays.
     
  5. telijah

    telijah Senior Member Verified Member ECF Veteran

    Joined:
    Dec 18, 2012
    Location:
    Tampa, FL
    Cant you unscrew the base of the CE4, removing the post which has the removable head, or do CE4's not have the removable heads?

    Edit: Here we go: http://www.discountvapers.com/produ...r_Clearomizer_Breakdown_parts__99057_zoom.jpg

    Remove the base from the bottom, and make sure the coil is screwed on tightly. On the CE5s, the tip has a tendency to sometimes unscrew the head when taking it off and over time, it becomes "disconnected" while still seeming to be attached, causing it to short, and causing my battery to flash slowly when trying to press the button.
     
Thread Status:
Not open for further replies.

Share This Page