eGo Battery not charging

Discussion in 'New Members Forum' started by mcgatson, Nov 23, 2012.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. mcgatson

    mcgatson Full Member

    Joined:
    Nov 21, 2012
    Location:
    Southport, NC
    Hey ya'll,

    I'm having a problem with one of my eGo 650mah batteries. I went to charge it tonight and when I screwed it onto the charger the light stayed green and would not charge. So I Googled this and all I could find was clean your connections with a q tip, which I always do they still look brand new. The other option was to try and raise the center pin of the battery. I did that and it didn't help. So needless to say I probably need to take it to my vape shop but I work odd hours and may take a few days to make it there and was wondering of ya'll had any thoughts on what I could try until then? My battery is 90 days old so roughly 90 charges which should not be enough to be shot right?
     
  2. Ryedan

    Ryedan ECF Guru Verified Member ECF Veteran

    Supporting member
    Joined:
    Mar 31, 2012
    Location:
    Brampton, Canada
    mcgatson, I have had a couple of those batteries for a while. I think you have done everything right in analysing this problem, but I have one question for you. When you screw the battery onto the charger, does it bottom out without any increase in force required to tighten it? The increase will be slight. Hope this makes sense.

    In my opinion, if you feel more force as you tighten it you have a defective battery. If this is not the case, you did not pull the center pin out far enough when you did that.

    90 charges is definitely not enough cycles to wear out the battery.
     
  3. mcgatson

    mcgatson Full Member

    Joined:
    Nov 21, 2012
    Location:
    Southport, NC
    I'm pretty sure I understand you, when I screw the battery in there is an obvious resistance then I can give almost one more turn before it locks tight. So I'm guessing it's a defective battery.

    Not what I wanted to hear but crap happens.
     
  4. NoMoreMondays

    NoMoreMondays Senior Member ECF Veteran

    Joined:
    May 14, 2010
    Location:
    Indiana
    I had a couple eGo batteries pull that sort of stunt on me. Of course I baby my batteries and they get a regular cleaning every evening with a q-tip slightly dampened with Everclear.

    Anyways, after several attempts to revive the first one (I only had it for about two months) I put it away. A couple weeks later another one bit the dust. Different supplier, different model and different mAh ... I tried raising the pin, cleaning the battery AND the charger numerous times, finally I was fed up with it. Screwed on a fresh carto and enjoyed the last few puffs. Or so I thought! After the battery stayed dead even after 10 minutes wait time, I screwed it back into the charger and the little green LED turned red. I gave the other "dead" battery the exact same treatment and both are still in service today.

    Give this a try: Unplug your charger. Use a q-tip dampened (not wet!) with rubbing alcohol or the like and clean the connection at the charger. Push the button on your battery to see, if it lights up. If it does, vape it until it stays off, then screw it into the charger.

    Good luck!
     
  5. zoiDman

    zoiDman My -0^10 = Nothing at All ECF Veteran

    Supporting member
    Joined:
    Apr 16, 2010
    Location:
    So-Cal
    I have one eGo charger that is a little Fussy.

    I have to screw the Battery in (Not Too Tight) and then Wiggle the Battery until the Red Light comes on. They I have to lay it down Every so Gently in the Charging Bowl so that the Contact is not lost.
     
  6. JUDGMENT AFFIRMED

    JUDGMENT AFFIRMED Ultra Member ECF Veteran

    Joined:
    Jul 24, 2012
    Location:
    BELLE VERNON PA.
    Hi zoiDman,
    At the 5 month mark for me, i now have one Joyetech charger like that. Exactly as you describe.
    The important thing, that seems to apply with all this stuff, "NOT TOO TIGHT". Bad things can happen.
     
  7. zoiDman

    zoiDman My -0^10 = Nothing at All ECF Veteran

    Supporting member
    Joined:
    Apr 16, 2010
    Location:
    So-Cal
    I agree. Not Too Tight is the Key.

    It keeps the Threads from getting Worn Out but Also keeps the Center Post of the Battery Connection from being Pushed Down.

    Both on the PV and the Battery.
     
  8. JUDGMENT AFFIRMED

    JUDGMENT AFFIRMED Ultra Member ECF Veteran

    Joined:
    Jul 24, 2012
    Location:
    BELLE VERNON PA.
    The current advice, that seems to be getting more common, is raise your battery pin. I haven't had to touch my batteries in 5 months and thats the last thing i would do. Their are risks in doing that and as in this case, didn't do any good. Ive had lack of contact between battery and device at least twice. Ego to 510 adaper worked for the Kgo to Kanger t2 problem. And adjusting the center post on my Vision v2 got it working.
     
  9. Mdemon

    Mdemon Senior Member Verified Member ECF Veteran

    Joined:
    Mar 3, 2012
    Location:
    Trinidad
    Hi mcgatson. Two things to consider as well...
    First if you've regularly been overtightening when attaching the battery to anything, the rubber grommet around the center post may have become damaged. If raising the post so you're sure its contacting properly & still no dice, it may be shorting because of the damaged grommet & won't charge.

    Second put the battery close to your nose & take a whiff near the button. If you get even a slight burned electrical/slightly metallic smell then you've got a fried PCB. This can happen if you either get juice down in the button or from using a shorted atty/carto.

    Either way better off just getting a new batt. Hope this helps figure out the prob. :)
     
Thread Status:
Not open for further replies.

Share This Page