EGO C Twist blinking 3 times

Discussion in 'General Vaping Discussion' started by whitetortuga, Nov 21, 2012.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. whitetortuga

    whitetortuga Senior Member ECF Veteran

    Nov 4, 2011
    United States
    Hey everyone, just had a quick question. My ego C Twist blinks 3 times every time I press the button. It is charged, and I even charged it over night to be sure. I'm not sure what the issue is, it wasn't dropped or anything. Just started doing this. I tried to turn it off the one time and it blinked I don't know how many times, more than 10 though. Anyone have any advice on this? I'm confused what is going on. I have tried 4 or 5 different cartos/tanks with no luck!


    Thanks guys!
     
  2. AttyPops

    AttyPops Yeah, I type stuff. ECF Veteran

    3 blinks = short (too low ohms).

    Clean the threads inside the connection and see if that helps. Also, if that doesn't work, use a paperclip or some-such and try to pry the center post up a little bit...GENTLY. Don't rip the little rubber grommet that separates the center post from the threads.
     
  3. whitetortuga

    whitetortuga Senior Member ECF Veteran

    Nov 4, 2011
    United States
    That is weird. I have also used different ohms.. One is 2.4-29. Also, I have used the same carto for weeks on it and it has worked. I did try to pry it up a bit with no luck!
     
  4. AttyPops

    AttyPops Yeah, I type stuff. ECF Veteran

    Did you clean it inside the connector (maybe it's shorted with gunk?)

    I only mentioned the pry thing since some have indicated that certain tanks/cartos may push the center pin down too far and it shorts INSIDE.....

    So if you don't have an tank/atty/carto on it.... and push the button...what happens?

    EDIT: BTW... a short is basically zero ohms...
     
  5. whitetortuga

    whitetortuga Senior Member ECF Veteran

    Nov 4, 2011
    United States
    Ok so here is how it goes:
    I screw the cartomizer on: 3 blinks
    I press the button with the cartomizer on: 3 blinks
    I take off the carto: Nothing happens
    I press the button with no carto on: Nothing happens
    I push the center pit side to try to move it up a bit: 3 blinks

    Thanks for your help!
     
  6. AttyPops

    AttyPops Yeah, I type stuff. ECF Veteran

    I'm uncertain of what you mean by the last point...

    So are you saying that you push on the center pin and push the button and get 3 blinks? (And that you're not shorting it with a metal object)?

    It shouldn't blink when you just screw a carto on without the button pushed!

    Is the button stuck too?

    P.S. How old is it? Time for a new one?
    I only have a regular eGo...not a twist. So maybe they are different or something...I'll wait for someone else to chime in here........
     
  7. Iffy

    Iffy Vaping Master Verified Member ECF Veteran

    Supporting member
    Feb 3, 2011
    Florida Suncoast
    The only thing that I can think of to try is...

    Have you tried the 5 click on/off?

    How old is da batt?

    Please let us know what ya determine. Good luck!
     
  8. AttyPops

    AttyPops Yeah, I type stuff. ECF Veteran

    Do they do 3 blinks with the 5-click thing too Iffy?
     
  9. whitetortuga

    whitetortuga Senior Member ECF Veteran

    Nov 4, 2011
    United States
    Sorry, when I use a paper clip to try and push up the center pin, it blinks. Not pushing the button or anything. It isn't that old, I got it at the end of August or so. Also, no, the button seems just fine! No 5 click on/off either. It doesn't matter.
     
  10. AttyPops

    AttyPops Yeah, I type stuff. ECF Veteran

    Try it with something plastic (non-conductive). Still blink?
     
  11. Iffy

    Iffy Vaping Master Verified Member ECF Veteran

    Supporting member
    Feb 3, 2011
    Florida Suncoast
    Mine do.

    OP, sounds like your button may be stuck. Either that or it's a tosser.
     
  12. whitetortuga

    whitetortuga Senior Member ECF Veteran

    Nov 4, 2011
    United States
    Just tried it and it didn't blink with plastic. Also I tried it with the metal again, and no blinking. Still blinks 3 times though when I hit the button with a cartomizer on. Well I pressed the button like 3 times and it blinked +/- 37 times (I lost track).
     
  13. whitetortuga

    whitetortuga Senior Member ECF Veteran

    Nov 4, 2011
    United States
    Button seems to be responsive. It is blinking 3 times every time I hit it.
     
  14. AttyPops

    AttyPops Yeah, I type stuff. ECF Veteran

    $%!&*&$# <self-censored> why didn't they use a different # of blinks for that? Grrr......
     
  15. Iffy

    Iffy Vaping Master Verified Member ECF Veteran

    Supporting member
    Feb 3, 2011
    Florida Suncoast
    Check with your vendor. Hopefully it might still be under warranty.
     
  16. AttyPops

    AttyPops Yeah, I type stuff. ECF Veteran

    The 5-click thing would require 5 clicks, of course, so IDK why 3 clicks made it go super-blink unless it's discharged.

    The no-blinking when not shorted on empty connector means it's not internally shorted when stuff isn't screwed on. Have you tried backing off the atty/carto a little at a time? Trying to see if you get sizzle without 3 blinks?
     
  17. whitetortuga

    whitetortuga Senior Member ECF Veteran

    Nov 4, 2011
    United States
    3 Clicks - YouTube


    Here is a video that might be of some help. If you listen, you can hear the buttons working. Also, this cartomizer was just an example (at 3.0 ohms or something).



    I have already had a passthrough that broke about a month ago, and the vendor was no help at all. All they said is that they die around 300 charges. No way did I charge it 300 times (1000 may) in 2 months. Not even close. This is the second one from that same vendor.
     
  18. AttyPops

    AttyPops Yeah, I type stuff. ECF Veteran

    That's cool that you did that.

    Do you have a multimeter? What is the ohms reading on that tank? (V.N.?) Also the old VN's had a long center pin that pushed the center connectors down too far........

    EDIT: Took another look...nm.
     
  19. dolphins35

    dolphins35 Vaping Master Verified Member ECF Veteran

    Oct 22, 2012
    Spanaway, Wa
    Mine did the same exact thing. I had mine for about 6 weeks. I took it to my vender and he said it was a bad connector or shorted wire inside. He said he could fix it but the it would cost more than a new one. I had just missed my 30 day warranty by 2 weeks.
    My vendor honored the warranty anyway. Thanks Matt!

    Long story but I asked him to take it apart and show me and it was a wire that melted and shorted out. Black inside.
    Be Careful.
     
  20. whitetortuga

    whitetortuga Senior Member ECF Veteran

    Nov 4, 2011
    United States
    Wow thats terrible.. That is two batteries from this place in a short time. Man does this really, really make me mad.
     
Thread Status:
Not open for further replies.

Share This Page