Ego-T Battery problem

Discussion in 'New Members Forum' started by Jari91, Jun 28, 2012.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Jari91

    Jari91 New Member

    Joined:
    Jun 28, 2012
    Location:
    Canada
    Hey guys

    just started vaporizing recently and its been great. Got myself the Ego-T and I have been smoke free for a while now. I ran into a problem today. On my way to work, I was using my vaporizer in the car when it stopped working. It just blinks three times and no steam. I have tried shutting it off and also plugging into the charger and nothing seems to be working. Light just blinks 3 times. I am wondering if anyone has come across this problem before and can give me a tip on how to snap it back into working order or is my battery done? My Vaporizer looks like this: Upgraded eGo-T Battery with Stardust Tank Clearomizer
    2.0. any help would be great. Thanks

    Jari
     
  2. MikeI70

    MikeI70 Full Member

    Joined:
    Jan 13, 2012
    Location:
    Long Island
    Is it only this battery you have a problem with? I'm thinking it may be a charger issue.
     
  3. minyddol

    minyddol Super Member ECF Veteran

    Joined:
    Jun 7, 2012
    Location:
    Jason Valentine- Aberystwyth
    If both were bought from the same place send the seller a email...might exchange both
     
  4. Vapoor eyes er

    Vapoor eyes er ECF Guru ECF Veteran

    Joined:
    Sep 13, 2011
    Location:
    Toronto, Ont.
  5. Jari91

    Jari91 New Member

    Joined:
    Jun 28, 2012
    Location:
    Canada
    Yes its only a battery problem. Second vaporizer is working fine after charge. Problem came with this one. Was working fine during the first part of my ride to work. Came to a red light, not working.
     
  6. VPCx3

    VPCx3 Full Member

    Joined:
    Jun 22, 2012
    Location:
    Denver
    I agree; contact the seller and ask for an exchange. I haven't had any problems with my eGo-T, but I know someone who had the same problem with an eGo-C. It was a simple case of a bad battery.
     
  7. Green Mtn Vpr

    Green Mtn Vpr Senior Member Verified Member ECF Veteran

    Joined:
    Apr 24, 2011
    Location:
    VT
    Its the new vaping and driving safety electronics! Kinda like how they want to make cell phones auto disable in a car. After all you might block vision with all that vapor!

    Seriously tho...had it happen before and the batt was done (charger ran other batts up fine)

    Time to order a Twist!

     
  8. dnrtn2342

    dnrtn2342 Super Member Verified Member ECF Veteran

    Joined:
    Jun 27, 2012
    Location:
    columbus, ga
    What do u have attached to the battery? I ran across this a couple days ago, I had a bad 306 atty, tried atty on two diff fully charged batteries and got 3 blinking blue lights
     
  9. dnrtn2342

    dnrtn2342 Super Member Verified Member ECF Veteran

    Joined:
    Jun 27, 2012
    Location:
    columbus, ga
    Do a test, take the stardust off "blinking bat" put it on the good battery, if it blinks again, your stardust is dead.

    Take a good stardust off good batt and put on blinking batt to see if it works. Trust me I did same thing 3 days ago
     
  10. sleazy1or2i

    sleazy1or2i New Member

    Joined:
    Jun 27, 2011
    Location:
    Indonesia
    Is that joye ego battery or from other
     
Thread Status:
Not open for further replies.

Share This Page