Evic charge problem

Discussion in 'Battery Issues' started by cleanzero, Feb 10, 2013.

Thread Status:
Not open for further replies.
  1. cleanzero

    cleanzero Full Member

    Sigh, I've been using my eVic for 10 days and everything has been fine. Unfortunately now I'm experiencing a problem. The battery charge level on the display once the eVic is charged does not go below 100% anymore and after some hours of use I get the " power too low" message. I also noticed that I don't get anymore the "charge completed" message when the battery reaches the fully charged state. I've tried to reset to factory settings by downloading and overwriting the code.bin file but to no avail. Someone else has been experiencing this ? Suggestions ?


    Inviato dal mio iPad con Tapatalk HD
     
  2. Dustin4President

    Dustin4President Full Member

    I am also having a charging issue on my eVic. I have the 1.1 Firmware and did not upgrade anything yet. I have charged for a while at work, but had to disconnect at 93%. I used the eVic all day with no troubles. I then re-connected the included charger to let it charge up. When I went to sleep the screen said there was a 99% charge. When I woke, the screen said 93% charge. I would think that 6+ hours of charging would have completely charged the eVic, but it would appear that it lost charge during the night.

    Any advice would be much appretiated.
     
  3. MikenGA

    MikenGA Ultra Member Verified Member ECF Veteran

    Interesting. After charging all night, evic showed 73% charge. I disconnected, and strangely enough, the charge slowly rose to 100%. I have no idea what's going on, but it is certainly unusual.
     
  4. jaco944

    jaco944 Full Member

    Just a thought could your computer or evic be going to "sleep" and stopping charge?
     
  5. ImThatGuy

    ImThatGuy Ultra Member Verified Member ECF Veteran

    Regardless of my computer going to "sleep" the usb ports still have power. I don't have any charging problems on my evic. Just wish it would last the whole week without any kind of recharge...

    And why do some evic users still have 1.1? 1.2 is a great update and should be installed.
     
  6. cleanzero

    cleanzero Full Member

    Bah, my eVic is completely messed up. The charge goes randomly from 0% to 100% and viceversa. I also discovered that my serial number is in the range of recalled eVics and that when I use low resistance cartomizers the device delays to activate. I asked for a replacement and the seller will send me a new control head as soon as he has them in stock.


    Inviato dal mio iPad con Tapatalk HD
     
  7. speedjason86

    speedjason86 Senior Member ECF Veteran

    mine is doing the same. I think the evic charges battery by looking at the voltage not by change in voltage during charge.
    it still works flawlessly just wont say the battery is fully charged. I think they should fix that in the next update.
     
: evic
Thread Status:
Not open for further replies.

Share This Page