Genesis Coil woes

Discussion in 'Rebuildable Atomizer Systems' started by MrsMustang, Jul 16, 2013.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. MrsMustang

    MrsMustang Full Member Verified Member

    Joined:
    Aug 14, 2012
    Location:
    Chicago Ridge, IL
    I bought the genesis mini RBA from got vapes a few weeks back. The wick and coil were preinstalled. Vape heaven. After a few weeks of using it, its pretty gunked up and needs to be replaced. I received ss mesh and wire in a bag with the tank, have no clue the gauge of either. I have watched dozens of you tube video’s on rebuilding these and they seem pretty straight forward. Problem I’m having is the wire keeps breaking between the center post and the top of the ss mesh. The coils I’m building are about .9 ohms. As soon as I fire my device the wire between the top coil and center post immediately glows bright red and the wire breaks. I have tried the wire that came with the tank and also 32 ga kanthal. I want to scream. I have rewrapped this coil with wire 7 times and it keeps happening. There are no kinks in the wire, its not pulled too tight. The coil is oxidized, I passed the wire through a blue flame. I seriously don’t get it. I’m at a loss. Advice, please??
     
  2. DSmooch

    DSmooch Super Member ECF Veteran

    Joined:
    Sep 21, 2012
    Location:
    Where the wrong turn means no return.
    mrs, your wick is shorting.
    now .9ohm with 32g? you have one loop? maybe add a couple of loops, and pulse slowly until you get passed the first hot spot. or even better, if its your first wick, just give it a good torch (to oxydize it) and enjoy :)
     
  3. Thrasher

    Thrasher ECF Guru Verified Member ECF Veteran

    Joined:
    Oct 28, 2012
    Location:
    Madeira beach, Fla
    add to the other post:
    how many wraps of wire?
    if your getting .9 ohms with 32 gauge and 4 or more wraps then there is def a short somewhere probably between the coil and the mesh.

    make sure there are no loose ends touching anywhere a small piece of wire laying on the screws will drive you nuts.

    and the resistance is way to low for whatever voltage you are using and at .9 ohms is heating up too fast for you to find the hotspot.
    what type of device?



    for future reference you dont have to pull a coil when its dirty just do a quick dry burn and blow or scrape off the junk. you can even torch it real fast while in the geni if need be.


    but a lot more info would be helpful, mod, voltage. wraps, and a pic would be wonderful .
     
Thread Status:
Not open for further replies.

Share This Page