help ego t batts won't charge

Discussion in 'Battery Issues' started by bajabug_hawaii, Jan 18, 2012.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. bajabug_hawaii

    bajabug_hawaii Full Member

    Joined:
    Nov 1, 2011
    Location:
    north bend, oregon
    hi all quick question. got an ego t from extremevapor for xmas thanks to my lovely wife. first thing the new batterie's charging light went green after a few hours. i thought all was goot till the next day when the first battery button started flasshing and then it wouldn't charge thought it was a fluke till it happened with the other one the next day. sent em back and they replaced them. now the red light won.t go out. tried it in the usb and wall cgarger. please help don't wanna go back to analogs!!! thanks
     
  2. DZ

    DZ Super Member ECF Veteran

    Joined:
    Oct 20, 2011
    Location:
    Littleton, CO
    Are you tripping the "on/off"? try clicking it 5 times fast and see if that helps. Sometimes batteries can take a few hours to charge.
     
  3. bajabug_hawaii

    bajabug_hawaii Full Member

    Joined:
    Nov 1, 2011
    Location:
    north bend, oregon
    tried that no dice really getting frustrated cuz i like the ego more than my blue...
     
  4. sheik124

    sheik124 Senior Member ECF Veteran

    Joined:
    Oct 28, 2008
    Location:
    Tampa, FL
    Your charger might be killing those batteries.
     
  5. bajabug_hawaii

    bajabug_hawaii Full Member

    Joined:
    Nov 1, 2011
    Location:
    north bend, oregon
    it's the gharger that came with it lol
     
  6. cags

    cags Vaping Master Verified Member ECF Veteran

    Joined:
    Jan 27, 2011
    Location:
    east TN
    but chargers can be bad too. I think I would contact the vendor again
     
  7. bajabug_hawaii

    bajabug_hawaii Full Member

    Joined:
    Nov 1, 2011
    Location:
    north bend, oregon
    i checked and the charger is putting out voltage maybe the amperage is off or something?
     
  8. martinc

    martinc Vaping Master Verified Member ECF Veteran

    Joined:
    Dec 12, 2011
    Location:
    Montreal,Quebec,Canada
    Maybe its a bad connection;

    1-Unplug the charger
    2-Take a pointy object,wiggle out ever so slightly the center post of the charger,maybe a mil
    3-replug charger,try again
    4-screw the batts in there until it makes contact;no need to tight anything,just seated does it.
     
  9. bajabug_hawaii

    bajabug_hawaii Full Member

    Joined:
    Nov 1, 2011
    Location:
    north bend, oregon
    tried that no dice the first battery finally turned green that was about ten hours of charging tho ***? the other one is charging now we'll see how it works out
     
  10. martinc

    martinc Vaping Master Verified Member ECF Veteran

    Joined:
    Dec 12, 2011
    Location:
    Montreal,Quebec,Canada
    8 hrs required when completely down minimum
     
  11. bajabug_hawaii

    bajabug_hawaii Full Member

    Joined:
    Nov 1, 2011
    Location:
    north bend, oregon
    damnit!!! the second battery still won't charge
     
  12. bajabug_hawaii

    bajabug_hawaii Full Member

    Joined:
    Nov 1, 2011
    Location:
    north bend, oregon
    ok now one battery is getting warm while charging, not hot just warm and the light never goes to green. ***???
     
  13. Shizzle

    Shizzle Super Member Verified Member ECF Veteran

    Joined:
    Jan 6, 2011
    Location:
    the burbs
    it shouldn't be getting warm...i just checked mine on the charger, and it is stone cold. it sounds like you've got a bad charger.
     
  14. bajabug_hawaii

    bajabug_hawaii Full Member

    Joined:
    Nov 1, 2011
    Location:
    north bend, oregon
    it's charging the other one tho ***???
     
  15. martinc

    martinc Vaping Master Verified Member ECF Veteran

    Joined:
    Dec 12, 2011
    Location:
    Montreal,Quebec,Canada
    Return that kit.
     
  16. cags

    cags Vaping Master Verified Member ECF Veteran

    Joined:
    Jan 27, 2011
    Location:
    east TN
    I think you may need to contact the vendor again
     
  17. bajabug_hawaii

    bajabug_hawaii Full Member

    Joined:
    Nov 1, 2011
    Location:
    north bend, oregon
    damnit this will be the second time i've had to return it!!! are they a bad vendor? anyone with experience with them? any body here by chance have a contact number??? it's taking forever to get a reply from them. thanks all
     
  18. ChipHead

    ChipHead Super Member ECF Veteran

    Joined:
    Feb 13, 2011
    Location:
    NH
    For what it's worth, my ego-t 1100 mah baterries take about 4 hours to charge to green from a totally dead flashing light condition.
     
  19. bajabug_hawaii

    bajabug_hawaii Full Member

    Joined:
    Nov 1, 2011
    Location:
    north bend, oregon
    ok well now the one that did charge is turning off for some reason after 1-2 secs of vaping *** this is getting old
     
  20. bajabug_hawaii

    bajabug_hawaii Full Member

    Joined:
    Nov 1, 2011
    Location:
    north bend, oregon
    plugged the one that was turning off into the charger now it's green i think it might be the charger anyone know of a place in oregon to get one ? sorry this is kinda turning into a rant thanks
     
Thread Status:
Not open for further replies.

Share This Page