Issues with an IGO 4 by Clope

Discussion in 'Clearomizers' started by mbloomer04, Feb 28, 2014.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. mbloomer04

    mbloomer04 Full Member

    Joined:
    Jan 24, 2014
    Location:
    United Kingdom
    I have 2 x IGO 4s by CLOPE (see http://www.clope.tn/#/2/igo4-kit) and I am starting to get a burnt taste from them both after about 2 months , it was suggested to me that I may need to change my wick.

    Can anyone confirm this and if so does anyone know where I can find some online as close do no seem to sell them on their website.

    Sent from my GT-N7100 using Tapatalk
     
  2. emg81

    emg81 Senior Member Verified Member ECF Veteran

    Joined:
    Jan 16, 2014
    Location:
    Southern Illinois
    Are you still using the stock coils and wick it came with? If so.... yeah you would definitely need to change your wick and dryburn ur coil or maybe even do a complete re-coil.. i personally don't use my wicks for more than a week. Best wick i have found is organic cotton u can pick up at about any local drug store for about $3 for about a year or so worth of wick material even if u share lol

    Sent from my SCH-S738C using Tapatalk
     
  3. shiddyshad

    shiddyshad Full Member

    Joined:
    Oct 30, 2013
    Location:
    Maumee, OH
    It looks like that ecig comes with either a ce4 or ce6 tank. Those are the atomizer heads you'll need to order. You can probably find them at a brick and mortar if you call around or search for somewhere in Europe close to you that you can order from.
     
Thread Status:
Not open for further replies.

Share This Page