1. Win Vaping gear! The ECF 15 Millionth Post contest

    We are fast approaching the 15 millionth ECF post and we have a contest to celebrate this huge landmark and amazing prizes to give out to our members! Head over to the official contest thread to see the rules and check out the prizes generously pledged by our registered suppliers on the prize announcement thread.

iTaste SVD problem :(

Discussion in 'APV Discussion' started by Electrician480, Oct 10, 2013.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Electrician480

    Electrician480 Full Member

    Joined:
    May 6, 2013
    Location:
    Baltimore
    Hey everyone. I bought an iTaste SVD about a week ago and it was working great. But now when I press the fire button it doesn't always light up. Ill have to press it 10 or morw times before it works for me sometimes. Its very sparatic and doesn't work everytime. Also sometimes now when I get it to work it will just turn off in the middle of holding the button. It started this today.

    Any ideas what it is? My new tank, batteries, and flavors just arrived today to and out of all times now is when it gives me issues!! Ahhh :(
     
  2. Electrician480

    Electrician480 Full Member

    Joined:
    May 6, 2013
    Location:
    Baltimore
    and as of this second wont even turn on :confused:
     
  3. Electrician480

    Electrician480 Full Member

    Joined:
    May 6, 2013
    Location:
    Baltimore
    oooook and now its working :2cool: but I am still confused.... does it have something to do with the dual coil? or maybe the wattage? I noticed when I put in my 2250 mah battery that the amperage jumped up to 2.5A from 1.5A from my 800mah battery

    is there a chart or anything with good settings to keep the SVD running at? maybe I had the settings to low for the DC ?
     
  4. Electrician480

    Electrician480 Full Member

    Joined:
    May 6, 2013
    Location:
    Baltimore
    annnnd now it isn't working. ... what the *&^% is going on with this thing?
     
  5. IoNeK

    IoNeK Full Member

    Joined:
    Jun 26, 2013
    Location:
    Bako,CA
    Hmmmm.. well lets see if we can get to the bottom of this for yah.

    1. You said dual coil.. Did you build it yourself? If so keep in mind most regulated mods wont fire below 1.2 I believe.

    2. Have you dropped your mod recently on a hard surface?

    3. Have you tried firing the SVD with a different juice delivery system?
     
  6. retired1

    retired1 Curmudgeon Admin Verified Member ECF Veteran

    Supporting member
    Joined:
    Apr 5, 2013
    Location:
    Canada
    Yeah, we'll need to know more information. What tank are you using on it. What's the actual tested resistance of the coils?

    1.5 ohms and above will fire just fine on the SVD. Start getting lower than that, and you're going to have issues. 1.2 ohm and it flat refuses to fire on mine.
     
  7. Electrician480

    Electrician480 Full Member

    Joined:
    May 6, 2013
    Location:
    Baltimore
    Here's what I got on it right now. I did not build them myself.

    https://www.myvaporstore.com/ProductDetails.asp?ProductCode=UDCT-TC
    https://www.myvaporstore.com/ProductDetails.asp?ProductCode=EF65022FT
    SMOKTech 510 Dual Coil Tank Cartomizer - 5 Pack

    I had dropped it once on the concrete but it was only from about 2 ft. It worked after this and was actually hitting harder but upon getting home it just won't fire.

    If on the SVD the U is the symbol they use for ohms instead of Ω then it is ohmed at 3.6 currently.

    It doesn't turn on or turn off easily like it should either. click it 3 times and nothing happens so it's hard to tell whether its even on or not now. I just click it a bunch and hold the button and wait to see if it will light up for me. It randomly will light up and start heating sometimes but not like it should.

    I figured when I dropped it it didn't do much harm since it worked for about 3 hours afterwards.

    Any other info you need?

    Also, when it hit the ground it landed almost perfectly horizontal
     
Thread Status:
Not open for further replies.

Share This Page