My atomizer isn't reading

Discussion in 'APV and Mods Discussion' started by Tat2edhearts, Aug 2, 2017.

Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Tat2edhearts

    Tat2edhearts New Member

    Aug 2, 2017
    I bought a used tugboat box mod and a tank that they were selling with it. They work great together, yet when I try and use my vgod pro tank with it it doesn't read. I tried adjusting the 510 pin but it causes my posts to wiggle. Any suggestions on what I should do or why it doesn't read.
     
  2. Wheelin247

    Wheelin247 Ultra Member Verified Member ECF Veteran

    Sep 17, 2013
    Lakeland, Fl. USA
    It could be the coil. Have you tried putting a new coil in it? I know I had an RDA that did the same thing. I built a new coil to throw in it and put it on the mod and it read the resistance correctly.


    Sent from my iPhone using Tapatalk
     
  3. 93gc40

    93gc40 Vaping Master ECF Veteran

    Oct 5, 2014
    California
    Adjust the pin on the Mod up????? instead of the atty......

    Sent from my SCH-I605 using Tapatalk
     

Share This Page