My coils keep breaking!

Discussion in 'New Members Forum' started by mishappp, Dec 31, 2013.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. mishappp

    mishappp Full Member

    Joined:
    Nov 3, 2013
    Location:
    Simi Valley
    I'm building my own coils in 28 gauge kanthal and it seems that I'm doing it wrong because they keep snapping, what should I improve on? I should note they keep snapping when Im engaging them with the battery not me just bending them.
     
  2. Blkwdw86

    Blkwdw86 Senior Member Verified Member ECF Veteran

    Joined:
    Oct 6, 2013
    Location:
    Gladewater, TX
    Your voltage is too high, or you have hot spots.

    Make sure you're verifying the resistance of your coil with a multimeter before putting power to it. Wraps to gauge is only a rough guideline, a starting point; when your coil is done you have to know what the resistance is so you know the proper voltage to put to it.

    If your resistance/power ratio is right, then you haven't been working the hot spots out of your coils. Read through the rebuildables forum for tips and tricks on that. There are also Youtube vids to guide you through working these out of your setup.
     
  3. Ryedan

    Ryedan ECF Guru Verified Member ECF Veteran

    Supporting member
    Joined:
    Mar 31, 2012
    Location:
    Brampton, Canada
    What device are you working with?
     
  4. JeremyR

    JeremyR Vaping Master ECF Veteran

    Joined:
    Dec 29, 2012
    Location:
    Oregon, IL
    Welcome to ecf.

    Severe short or the wire was really kinked before hand.. It's pretty hard to blow a 28 g coil.

    What atomizer are you using?
     
  5. dice57

    dice57 PV Exporer/Juice Saucier Verified Member ECF Veteran

    Supporting member
    Joined:
    Sep 1, 2013
    Location:
    Mount Vernon, Wa
    Sounds like you have a short. If it's a fogger, then the wire around the positive terminal is probably touching the side wall.
     
  6. mishappp

    mishappp Full Member

    Joined:
    Nov 3, 2013
    Location:
    Simi Valley
    I'm using a k101 mod, with a 30 amp battery. I was working around .8 ohms, it worked 3-5 times 2-3 second pulls before it popped. Ill try wrapping better.
     
  7. Paul.K

    Paul.K Super Member Verified Member ECF Veteran

    Supporting member
    Joined:
    Aug 27, 2013
    Location:
    California
    What atomizer are you using? Also can you post a picture of your coil setup?
     
  8. mishappp

    mishappp Full Member

    Joined:
    Nov 3, 2013
    Location:
    Simi Valley
    I'm using a trident atomizer and I already took the coils out to rebuild it later.
     
  9. Paul.K

    Paul.K Super Member Verified Member ECF Veteran

    Supporting member
    Joined:
    Aug 27, 2013
    Location:
    California
    Try to post a pic of your coils on your next build. Also are you torching your kanthal before wrapping your coil?
     
Thread Status:
Not open for further replies.

Share This Page