1. Win Vaping gear! The ECF 15 Millionth Post contest

    We are fast approaching the 15 millionth ECF post and we have a contest to celebrate this huge landmark and amazing prizes to give out to our members! Head over to the official contest thread to see the rules and check out the prizes generously pledged by our registered suppliers on the prize announcement thread.

Roughstack not working

Discussion in 'MadVapes' started by HippyJonny, Jun 16, 2011.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. HippyJonny

    HippyJonny Senior Member ECF Veteran

    Joined:
    Aug 7, 2010
    Location:
    Northern California
    Hey all,

    Just got a Roughstack V2 Maxi and I can't get the thing to work. I'm using AW IMR 18650 batteries with the raised top and I can't get it to fire. I couldn't find an RS trouble shooting thread. Any ideas?
     
  2. six

    six Vaping Master Verified Member ECF Veteran

    Joined:
    Feb 17, 2011
    Location:
    under the blue sky
    Make sure the nut that holds the switch in is tight. - Or before you tighten it, remove the nut entirely, pull the switch out and re-seat it. Make sure the spring that contacts the 510 connector is seating properly. When my second RS arrived, the nut was loose and the spring was shorting. It took a couple of tries but when the spring seats right, all is well.
     
  3. backer

    backer Full Member

    Joined:
    Jan 5, 2011
    Location:
    McAllen, TX
    What a coincidence I just got mine in today as well same problem, just won't fire. Tried a few different cartos and attys different batteries, at the very best with one of the batteries I got the smallest little hit with what I can only describe as the smallest vapor production I have ever see, and I've used a blu ecig so that's saying something. Using TrustFire Protected 18650 Battery, 2400 mah batteries.
     
  4. HippyJonny

    HippyJonny Senior Member ECF Veteran

    Joined:
    Aug 7, 2010
    Location:
    Northern California
    I've been unscrewing and rescrewing this thing for almost two hours now. I'm getting nothing. Ticket has been submitted. Totally bummed.
     
  5. backer

    backer Full Member

    Joined:
    Jan 5, 2011
    Location:
    McAllen, TX
    So have I, It's just not working. I'm so disappointed as well, I was so excited when it came in the mail today, charged up the batteries and nothing.
     
  6. HippyJonny

    HippyJonny Senior Member ECF Veteran

    Joined:
    Aug 7, 2010
    Location:
    Northern California
    That's kinda reassuring, Backer. Maybe there's a bad batch rolling out right now. At least we got a support group.
     
  7. backer

    backer Full Member

    Joined:
    Jan 5, 2011
    Location:
    McAllen, TX
    Yeah, good thing it's not my only mod either, but you are defiantly right good to know I'm not alone, and maybe with 2 of us we can get a quicker response.
     
  8. gimmieshelter31

    gimmieshelter31 Super Member Verified Member ECF Veteran

    Joined:
    Mar 26, 2011
    Location:
    Perry Hall,MD
    I can only imagine the disappointment you two feel . I just got my Maxi RS and it works fine. I'm sure Hoog will get you straightened out.

    Remember that if the small piece of straw inside the atty connecter is not in place , the spring will contact the - side of atty connecter and the atty won't fire. It is only held in place with a dab of hot glue and could easily get jarred loose during shipment.

    Just a thought. Good luck.

    Russ
     
  9. backer

    backer Full Member

    Joined:
    Jan 5, 2011
    Location:
    McAllen, TX
    Thanks for the suggestion, but the straw is in place. It seems like the spring is to wide, I want to tighten it, but don't want to void the warranty.
     
  10. HippyJonny

    HippyJonny Senior Member ECF Veteran

    Joined:
    Aug 7, 2010
    Location:
    Northern California
    When I disassembled the switch the very first time, the straw was around the spring. I put the straw back in place in the connection pot before I reassembled the whole thing. Nothing. Two hours of fiddling and looking through the forums and nothing.
     
  11. tofucute

    tofucute Ultra Member Verified Member ECF Veteran

    Joined:
    Oct 22, 2010
    Location:
    sOCal
    :(Ordered mine 2 months ago and just had to send it back to be fixed.:( the plastic straw looked half melted or deteriorated or something. they are also replacing the switch. feeling sketched about it's reliability and longevity ...
     
  12. backer

    backer Full Member

    Joined:
    Jan 5, 2011
    Location:
    McAllen, TX
    Just recived a reply to my tick about my roughstack not working. They are sending a replacement. Hope your problem gets resolved just as fast. It's already been shipped.
     
  13. hoogie76

    hoogie76 Forum Supplier ECF Veteran

    Joined:
    Aug 1, 2009
    Location:
    Charlotte, NC
    Sorry folks, what the problem is is on the center contact of the top cap there is supposed to be a bit of solder to make contact with the battery top post. Some of these went out without the solder and it appears to be an issue with trying to make a good contact to the battery.. Really apologize for the problems and will get them resolved asap..

    hoog
     
  14. backer

    backer Full Member

    Joined:
    Jan 5, 2011
    Location:
    McAllen, TX
    Thanks Hoog, really appreciate how fast this is getting resolved. One of the reasones I chose a RoughStack is because I hear you are really good and fast the customer service, love that you guys stand behind your products. Looking forward to many more dealings.
     
  15. HippyJonny

    HippyJonny Senior Member ECF Veteran

    Joined:
    Aug 7, 2010
    Location:
    Northern California
    Thanks for the update and fast service. I can't wait!
     
  16. MJBinNM

    MJBinNM Senior Member ECF Veteran

    Joined:
    Feb 12, 2011
    Location:
    New Mexico
    I happened upon an accidental improvement to replace the piece of straw. I have some of these Easy Brush Cleaners around. They have a hard plastic cap on them that has a hole in the end. I cut about 1/4" off the end of the cap, enlarged the hole in the end just a little to fit the center pin and it fits tightly into the back side of the connector. I didn't have to glue it or anything and it stays in place.

    My RS has a KR-808/901 connector, so I can't verify if this will work with a 510 connector, but they are about the same size.

    The brushes work good for cleaning the center tube and coils on you CE2s also.
     
  17. gimmieshelter31

    gimmieshelter31 Super Member Verified Member ECF Veteran

    Joined:
    Mar 26, 2011
    Location:
    Perry Hall,MD
    MJBinNM,
    TY for the tip with the Easy Brush Cleaners.I'm gonna try that when I get a chance.

    Russ
     
  18. HippyJonny

    HippyJonny Senior Member ECF Veteran

    Joined:
    Aug 7, 2010
    Location:
    Northern California
    New Roughstack received! Thanks for the fast turnaround! The best part is - it works!

    Next month I'm gonna invest in some more batteries so I can go 6 volt. Can't wait!
     
  19. backer

    backer Full Member

    Joined:
    Jan 5, 2011
    Location:
    McAllen, TX
    Lucky you, mine was sent on Wednesday but never left Cornelius, NC. I'm so upset I was hoping it would have been here by today, It was my father's day gift. Not Hoog's or MadVapes fault, but just a bad experience so far and now I don't even know when it will come in.
     
  20. six

    six Vaping Master Verified Member ECF Veteran

    Joined:
    Feb 17, 2011
    Location:
    under the blue sky
    USPS doesn't do a very good job with tracking. Their system isn't anything like UPS or FedEx.
     
Thread Status:
Not open for further replies.

Share This Page